PDA

View Full Version : Mac Classic Ethernet issues



mfortuna
March 6th, 2008, 12:31 PM
One of my retro machines is a Mac Classic with 4 Meg DRAM, 40Meg HD, and Asante SCSI EN/SC Adapter. I used to own an SE that I bought new. On ebay the SE seems to command a high price because of the signatures inside the case. So I settled for a Classic.

I have installed the webkit images and I can't get fetch or internews to work outside of my intranet. I can use fetch to connect to a a PC FTP server on my intranet. If I use mactcp ping I can ping the comcast DNS machines, ftp.apple.com, news.comcast.net. etc. I tried making the classic be a DMZ in my linksys router setup but that didn't help either. Maybe these applications are just too old. Usually if ping works and there isn't a port issue, things will work.

I'm running system 6.07. and I used the 1.4.5 network installer.

Any suggestions?

Thanks,

Mike

paul.brett
March 6th, 2008, 09:55 PM
Sound like it could be the subnet mask is wrong.

Paul.

mfortuna
March 11th, 2008, 08:32 AM
The intranet subnet mask is 255.255.255.0 on all devices including the Classic. I wonder if the linksys is messing with traffic since I assigned the Classic's address and didn't use DHCP. I wish I could plug the Mac into the cable modem but if DHCP deosn't work it probably won't work.

Mike

ahm
March 11th, 2008, 09:11 AM
You might need to set a gateway address.
Usually it's the inward-facing address of your Linksys.
(Can't remember if that's gonna be 192.168.1.1 or 192.168.1.254)

Andy

mfortuna
March 21st, 2008, 10:18 AM
I may have found a solution for this but I have not tried it out yet. Actually two solutions.

Patch mactcp2.06 with 2.11. This is a 3rd party patch.

Update to a newer MacOS.

mactcp2.06 doesn't handle a lot of modern tcp/ip features that are used by ISPs.

Mike

mfortuna
April 1st, 2008, 11:19 AM
I tried running the mactcp 2.1 patch on a fresh copy of mactcp2.06. It always bombs right at the end with an error code 50. My mac ends up with the new mactcp control panel but it doesn't work any different. I still can't get to the internet, although I can ping remote servers.

Does anyone have a copy of mactcp2.1 they would be willing to send me?

Thanks,

Mike

mfortuna
April 15th, 2008, 10:17 AM
Figured out soemthing by accident. I installed a new analog board in my classic which improved the video display. I went into the control panel to adjust brightness and noticed I had a entry for "copy of mactcp" which I made because I didn't want to lose the original when I tried the patched version.

So I moved the copy to another folder and rebooted. I can now use fetch to get to ftp.apple.com.

So even though the patch claimed it failed it appears to have worked, or at least improved things.

I guess the OS loaded the copy first and then ignored the patched version.

Mike