View Full Version : Kaypro 2'84 + Advent turbo rom: The saga continues...

March 17th, 2008, 04:20 PM
Okay, getting this kaypro 2'84 up and running has proven way more challenging than I had initially assumed. Here is my current status:

1. I finally received my Advent Turbo Rom v3.4 + stack of cp/m floppies from Sharkonwheels! (which my postman kindly folded up and crammed into my tiny postal box). The disks appear unharmed, however.

2. I removed my former kaypro rom and installed the Advent Turbo Rom. It boots up to a screen that says "Advent turbo rom v3.4" and sits there however. Does anyone have a manual for the ROM or anthing? I googled but was unsuccessful.

3. I have 2 x 360 kb ds/dd disk drives for it, one generic drive and one TEAC FD55BV (http://www.bitsavers.org/pdf/teac/FD55BV_Spec.pdf). I tried just setting the teac to DS0 and the other one to ds1, but the turbo rom never tried to read any disks, so I figure i have it set up wrong. Any brave souls willing to take a look at the manual and help me configure the jumpers?

At the moment, the computer just boots and hangs at the startup screen, making a little beeping noise whenever i touch any of the keys on the keyboard.

March 17th, 2008, 05:09 PM
Huzzah! I was about to get my TEAC 360kb drive working! I currently only have 1 drive working, but I was able to boot up, and then swap in the BASIC-80 disk and play some really lame games =) Special thanks goes to sharkonwheels for the wonderful bounty of disks he included!

Now, to get that 2nd drive working, and figure out how to use all of this software!

p.s. Anyone have a problem with the Kaypro keyboard frequently sending the same letter twice in quick succession?

March 17th, 2008, 09:51 PM
p.s. Anyone have a problem with the Kaypro keyboard frequently sending the same letter twice in quick succession?

Hmmm..the dreaded keyboard "debouce" I recognise from the TRS-80 mod 1 days. Were Kaypros plauged with this too?

March 17th, 2008, 11:11 PM
Try booting off the disk I labelled "56kb TurboROm boot" and see if you can do a dir on b: with one of the other disks in the b: drive.

Some quickie troubleshooting:
1- try the drive currently as 2nd drive select (DS1 id DS0-DS3, DS2 if DS1-DS4) as 1st drive select (DS0 or DS1 depending on labelling)
2- Make sure the LAST drive on the floppy cable has the terminating resistor installed.

In other words, jumper the 2nd drive as A:, and make sure it actually works.

Those boot disks should be set up for (2) DS/DD drives minimum, as I booted up on that 56k boot disk in order to create the 62kb boot disk.


March 18th, 2008, 04:15 AM
Okay, I will try that later. I just booted it up using the 62kb boot disk. Does it matter if the terminating resistor is installed on both of them? I think the drive I currently have hooked up as A: (by itself) has the resistor pack soldered on to it, whereas I think the other drive has a DIP resistor pack that I could easily remove. Also, does anyone know where a BASIC-80 manual is online?

March 18th, 2008, 07:30 PM
Resistor pack should ONLY be on the drive which is on the last connector.
I don;t remember if the Kaypros are super-picky on that or not, but better safe than sorry.

For manuals, check:


and others - google is your friend...


March 20th, 2008, 05:42 PM
I haven't fiddled with the 2nd floppy drive yet, but I just got my first "hello world" program to run in Basic-80! Hooray!

April 18th, 2008, 05:38 PM
Chris, does that mean there is a happy ending to this story?



EDIT: Wow - this is my 1000th post!

April 24th, 2008, 04:27 AM
Hi Sharkonwheels - I sent you a message via eBay regarding Kaypro IIx stuff before I realized you were on this forum :)

April 24th, 2008, 07:06 AM
I sent an eBay reply already.

I assume you mean a 2x, not a IIx?


April 24th, 2008, 07:21 AM
Ah, yes - it's a 2x. I've been dealing with so many different machines over the past few weeks I'm confusing myself.

April 24th, 2008, 05:42 PM
update, since I realized I left this thread hanging:

Success! I got both floppy drives working, and now have a fully functioning kaypro 2'84 w/ dual 360kb floppy drives!