View Full Version : Installation problems on an SE/30

April 30th, 2008, 04:42 PM
A question for Mac folk. Sorry if this seems a stupid question but I don't know too much about these machines.

Is it possible to prepare a 7.1 "bootable" SCSI external hard drive from a Mac running 7,1, connect that drive up to another working Mac (with a damaged OS) and then use the drive to boot the machine, AND THEN install OS 7.1 from copies of the installation disks on the external drive (hence repairing the OS?)

The reason I ask is that I've recently installed 7.1. succesfully on one of my Classic IIs after obtaining some new original installation disks. It's now in clean configuration. I was looking to clean up my SE/30, which has OS 6.x installed and is full of all kinds of crap from previous users. When I tried to install 7.1 over the top from floppies, the machine had trouble reading the installation disks. I'm suspecting some kind of fault in the floppy disk drive. It tries to read it and gets through various stages before coming to grief. It sounds like it's trying to read a track and failing.

Problem is, this part-installation has now damaged the existing OS on the HD of the SE/30 and it won't boot? Is it possible to do what's described above and so fix the problem?

If worst comes to worse, I could just replace the floppy drive and try again. I do have a non-working SE sitting around here for "parts". On thinking about it, this might be the easier solution if the floppy drive is damaged as I'll have to do it eventually (but it may just need a clean?).

I just hope the Installation disks have not become corrupt! In retrospect I should have made copies of them first and used those.


April 30th, 2008, 07:11 PM
That's a tricky one.

As I understand it, it should boot off of the first bootable device it finds, but, it may take a while to determine that the HD is not going to boot, so, be patient.

However, if it didn't read the floppy well enough to install the OS then, I doubt it would now.

As mentioned in another thread of yours, the heads might just be dirty and/or the rails might be gummed up.

Pulling the drive from the parts machine may not put you any further ahead and your efforts might be better directed in pulling the drive from the affected machine cleaning the heads and rails and lubing the rails as outlined in other threads about cleaning floppies. The current drive, at least, does read disks to an extent.

Anonymous Freak
April 30th, 2008, 09:13 PM
SCSI Macs by default try to boot from the floppy drive first. If there is a disk in the drive, and it fails to boot, it will eject the disk, then go through the SCSI bus. First, it will look in the PRAM to see if it is set for a specific drive. You can erase this by holding Command (Apple)-Option-P-R immediately after the "BONG!" and hold it down until you get a second "BONG!".
If the PRAM doesn't specify what drive to boot, it then goes from highest numbered device to lowest. The internal drive is almost always device 0, meaning it has lowest number, and will try to boot last. So if you have any external hard drives with valid System Folders, it will try to boot the highest SCSI device first.

Also, holding down "Option" will force it to try to boot from an external drive, even if PRAM says to boot from internal drive first.

And holding down "C" will force it to try to boot from CD, if a CD-ROM drive is present.

Finally, holding Cmd-Option-Delete-(Number) will force it to try to boot from the SCSI device number you are holding down. (So Cmd-Opt-Del-5 to boot from SCSI device 5.)

Now that you're getting all these old Macs, you may want to head over to the 68k Macintosh Liberation Army Forums (http://68kmla.net/forums/).

April 30th, 2008, 11:02 PM
Yes, you can make it boot from external HDs. Follow Anonymous Freaks advice. Make sure you have a different SCSI ID on the external drive, there is only one SCSI bus on the SE/30.

As far as using a drive from an old SE, make sure the model used 1.4MB drives (SE FDHD) and not the older 800K drives found on the original SE. Are you 7.1 install disks DD or HD?

www.68kmla.net is the place to go for old Mac help, you will find me on that forum under the same name.

If you can get the case open just try cleaning the dust bunnies out of the drive and maybe using a drive head cleaning disk. The SE/30 can alos use an external 1.4MB superdrive but they are a bit hard to find.

Terry Yager
May 1st, 2008, 05:11 AM
The SE/30 can alos use an external 1.4MB superdrive but they are a bit hard to find.

Got one if ya want it.


May 1st, 2008, 09:19 PM
Got one if ya want it.


An external 1.4MB drive for a mac? Have a picture or model #?

May 2nd, 2008, 02:37 AM
Thanks for the advice guys.

I'm going to attack the problem by trying to fix the 1.44 Drive first. The first thing will be a clean.

You wouldn't believe it but I can't find ANY of those 3.5 inch cleaning disks in town here. I've been to the major electronic stores and a couple of big stationary places. They just aren't sold any more. In one of the big electronic chains the staff member didn't have any idea what they were??

Oh well, time to head to our national e-bay equivalent and see what I can pick up there.


May 2nd, 2008, 03:31 AM
Yep, I have to buy mine on ebay. I usually buy them 2 at a time, comes with both the 5.25 and 3.5 cleaning disks. Some guy in Canada sells them.

May 21st, 2008, 06:04 PM
Just an update on this....

I cleaned the internal 3.5 inch drive with a cleaning disk, but still no go. I wondered for a brief moment if this machine might actually be an upgraded SE and still have the 800k drive, but even disks of that capacity can't be read or even formatted.

It must be faulty. When I get some time (at a premium in my life at the moment), I'll try to remove it and clean it. It might be as simple as that. If that fails, I'll seek a replacement.

The good news is that the Hard Drive is now clean and sporting OS 7.1. I achieved this by using an external plug-in 3.5 drive.

I'll also have to snag some RAM from somewhere. For a baby Mac, this SE/30 impresses me with it's speed compared to the Classic IIs I have, but with a paltry 2MB onboard and now with OS 7.1, there is not even enough head space to run Nortons Tools!


May 30th, 2008, 07:41 PM
My floppy drive now works as it should.

I removed the drive (not as trivial a job as in PCs) and examined it. Sure enough, it was host to a whole warren of dust bunnies.

Vacumed and blew these out, sprayed the lot with contact cleaner and put a drop of light oil on the spindle.

Reassembled and tested. It's fine.

Now, I just need 2-6MB or more of RAM and this machine will be the bonniest of my baby Macs.