PDA

View Full Version : Repair of an ST-412



modem7
September 27th, 2008, 10:40 PM
I recently came across a faulty ST-412 drive. It wouldn't 'ready'.
Using the good old substitution technique, I determined that the faulty component was the Hall effect sensor used to pick up spindle rotation.
An oscilloscope showed that the sensor was outputting pulses but that the waveform was at the wrong levels.
In a good ST-412 sensor, the waveform swings between 0 and +5 volts, but with the bad sensor, the waveform was swinging between +2 and +5 volts.
The output of the sensor feeds into a 7414 Schmitt Trigger on the circuit board and the +2 volt is not low enough to trigger the 7414.

Answer: I used a diode/resistor network which resulted in the waveform swinging between +0.4 and +2 volts (suitable for 7414).


from +----------------------+ to
Hall effect ---| 4 x diodes in serial |---+----> circuit
sensor +----------------------+ | board
|
\
/
\ Resistor
/
\
|
|
|
-----
---
-

I'm not sure if that's a viable long term solution because of the extra load placed on the Hall effect sensor (I don't have the specs for the sensor).
For now it is working, and if the sensor fails or deteriorates, I will probably replace the sensor with a modern day one (with possible additional circuitry).

http://members.dodo.com.au/~slappanel555/misc/repaired_ST412.JPG

chuckcmagee
September 28th, 2008, 12:43 PM
Oooo, very impressive repair. Yep, second you talked about +2, the old 0.0 to 0.8 TTL level thing came to mind. My electronics knowledge isn't large enough to have come up with that great solution. I was fairly successful at getting those drives on ebay so I now have a spare or 2.