View Full Version : What to do with an IBM 55 SX? 8555

December 1st, 2008, 05:48 AM
Hey. Guess I am asking what would you do with one?
Any parts in it worth scrounging, trash the rest?
No monitor, gonna salvage the keyboard.
But not familiar with this, thanks for anything you can add.

December 1st, 2008, 06:37 AM
Well it is a good starter system if you still like working with MicroChannel however an FPU upgrade might be nice and (mine at least) came with a rather large ESDI drive. I'm currently trying install AIX 1.3 on it.

December 1st, 2008, 07:17 AM
If It works, I would suggest selling it.. It would make you some cash and let it go to home where it is wanted!

December 1st, 2008, 09:17 AM
Selling would be an option, what is an asking price for it, cheap to move it quickly?
Thx for the info.

December 1st, 2008, 02:26 PM
Ok, got it fired. PS2 55 SX 8555-031

1920 KB OK

163 = (ok)/ > IBM. Think that means error# and get the manual.

IBM PC Basic
VC1.10 IBM 1981
62940 bytes free

Then I have a menu at the screen bottom.
An OS of sorts I assume, this thing must go then
I am not learning anything new right now!

December 1st, 2008, 03:27 PM
Well for starters it has a meg of ram. (CORRECTION, TWO MEGS OF RAM)
The second thing is that the battery in the Dallas chip has died (161) and because of that the internal clock needs to be reset (163).
You are then being dumped into BASIC (I didn't know it could even do that) as it can't boot from both the floppy drive or the internal hard drive (ESDI, and if you need one I have a stack).

December 1st, 2008, 05:06 PM
Don't you get a 165 ERROR for dead battery and then 161/163 after you fix that? I would make up a reference disk and see if the system will reconfigure itself. Could be it had a card added or removed without running the reference disk to set it up.

161 System Options Error - (Run SETUP) Battery failure
162 System options not set correctly-(Run SETUP)
163 Time and date not set - (Run SETUP)
164 Memory size error - (Run SETUP)
165 System options not set - (Run SETUP)

I think the 55SX came with 2MB (2 72 pin slots onboard), which is what he is showing with 1920K OK. There might be more RAM on a RAM card but that does not show up until you have configured all the MCA cards.

All PS/2s as far as I know dump you to BASIC when there are no bootable drives to start from, I think the 165 ERROR just locks the system up completely (can't even configure the built in stuff let alone any MCA cards). 165 is the common error for a dead battery, the other 2 are common for a system that needs setup after battery replacement. Won't hurt to try a configuration setup anyway.

http://members.chello.at/theodor.lauppert/computer/ps2/8555sx.htm <== reference disk

December 2nd, 2008, 12:05 AM
Replace the battery and use the reference diskette to restore the settings. That should fix all of the above!

December 2nd, 2008, 10:43 AM
Is the battery a radio shack item?
What should I a$k to sell/trade this comp?

I pressed F2 and it started basic, stayed on the error screen till I did.

Now I think this pans out as....new battery/set clock fixes 161 & 163, new error will be 165 or 162 and fix that with the ref disk.

I may actually get to use my 3.5 drive, surely caked full of dust by now:twisted:

December 2nd, 2008, 10:56 AM
You may not need to replace the battery. The battery may have enough power in it to save the configuration information, but not the date and time. The original 6 V battery in the second Model 50Z I acquired only has about 3 V left, but it's enough to save the configuation information, but it's not enough to keep the clock going. I don't get any errors on startup, but if I start an operating system like DOS it will ask me for the date and time. Having the correct date and time is not a big deal (I don't even think these PS/2s are year 2000 compliant).

Run automatic configuation from the reference diskette first. If you keep getting date and time error codes at startup, then replace the battery. The battery may cost you $10.

December 2nd, 2008, 03:32 PM
Unless different revisions didn't use the dallas chip, if you want to replace the battery you will have to do some work.

I documented it all here. (http://www.rotteneggs.com/r3/show/se/321442.html)

December 2nd, 2008, 08:45 PM
His model like my 65SX use the dallas chip, others have a different battery and later ones a coin battery. Atleast they are socketed and easy to pull out. You will need a slightly different version of the RTC chip since they do not make/sell the originals anymore.

December 3rd, 2008, 09:42 AM
OK, Next. That only leaves me with one question.
The battery connect internal to the chip? As in no prongs directly into the MB? Was not sure if they were cut off prior to photographicing.
Nice write up, might be something I will enjoy completeing unsuccesfully.:p

December 3rd, 2008, 08:12 PM
Or, you could just buy a DS12887 for about 6 bucks and plug that in.

I bought some from a place called FuturLec and they all worked fine in the PS/2s and Commodore PC-40s I put them in. Even measured full voltage in-circuit.

December 8th, 2008, 11:13 AM
The 55sx does not have a Dallas chip, it has an external battery attached to the chassis. Easy to replace. I had two of them, but I gave them both away. I still have the monitor that came with it.

December 8th, 2008, 01:25 PM
The 55sx does not have a Dallas chip, it has an external battery attached to the chassis. Easy to replace. I had two of them, but I gave them both away. I still have the monitor that came with it.

Every reference I see on the web shows that it does (on the motherboard), you can still have that dual camera battery in the chassis next to the speaker even with a Dallas chip on the motherboard.

December 8th, 2008, 04:40 PM
I no longer have the machine. My version had a externally-wired battery, but I did not bother to check for a Dallas or other mboard battery also. It never occurred to me that there would be two batteries. I will assume you're correct OR maybe I had a modded version.

May 7th, 2018, 10:08 AM
http://members.chello.at/theodor.lauppert/computer/ps2/8555sx.htm <== reference disk

Link rot, here's a current link:


May 7th, 2018, 10:46 AM
Just like Master Chief, "wake me when you need me" but I hope it wasn't five years or whatever....

http://www.tavi.co.uk/ps2pages/battery.html#8509237 Bob says the Dallas chip is replaceable. I myself do not know.

http://ps-2.kev009.com/ohlandl/8555/8555_Planar.html#Early_Riser and the other two risers have the four (?) pin header. DS1287 and DS12887 datasheets say lithium power cell... Oh, maybe (probably?) that is the speaker header.

May 16th, 2018, 09:15 AM
I have a 55SX. I bought a used replacement Dallas realtime chip a few years ago, and it works fine. There's a way to mod one of those realtime chips with an external battery. I have not tried it.

Just my two cents: Don't trash the system. Even if it doesn't completely work, the parts are worth something.

May 23rd, 2018, 02:48 AM
There's a way to mod one of those realtime chips with an external battery. I have not tried it.
My Commodore 286 PCs, like the PC35-III, have these Dallas RTCs on board. I had to mod already two of them. When googling just now using "battery, dallas rtc" this manual (http://www.mcamafia.de/mcapage0/dsrework.htm) showed up. It looks like the one I used as guide one year ago. In one case I first de-soldered the RTC, in the second case it was an "on board" job. It worked out fine as well but I tend to desolder the RTC first; the risk of damaging the board with the dremel tool is too high IMHO.
Tip: in my case the RTC sits right under the floppy drives so instead of soldering the battery holder to the RTC I soldered two wires, soldered the holder to the wires and put the holder + battery in an empty matchbox. The matchbox I glued to the side of the inside of the PC.