PDA

View Full Version : Compaq Contura 4/25 won't power on



Echoes
February 4th, 2009, 08:29 AM
A friend of mine gave me an old laptop, from what i can see it's a compaq contura 4/25, 486, 200 mb HD, bw screen, no trackball, no touchpad, no pointing device at all.
Battery was dead, obviously, my multimeter indicated 0V.
I changed the CMOS battery, attached a power supply, and a bright yellow light started to glow. But the laptop wouldn't turn on. :(
If I take out the battery, neither the yellow led nor the laptop will turn on.

So, do someone have this laptop? Is it normal that it doesn't power on if the battery is completely discharged or missing? :confused:

BTW, the battery seems to charge a little bit... it is now 1.50 V after about 1 hour of charge. Would a high voltage zap help it, or is it completely useless at this point?

billdeg
February 4th, 2009, 11:43 AM
I have one of these, it works so I never spent much time otherwise on it. Did you check the contacts for the battery?

Echoes
February 4th, 2009, 12:27 PM
I'll do it tomorrow, but... could you check, when you'll have the time, if you can power it on with the battery removed?

QuantumII
February 4th, 2009, 12:28 PM
My Contura 3/25 had this problem as well (When it was younger) A quick 12v zap to the battery woke it up to that the laptop could charge it.

Try that, 12V for 10 seconds :-)

billdeg
February 5th, 2009, 04:40 AM
I just confirmed, you do need the battery installed to boot the computer without having to go through the BIOS setup, but the computer will allow a person to boot from a diskette without the battery. My system boots to Windows 95, but it was originally a 3.1 system that has been upgraded. I have the 4/25c with the color monitor. I remember when these were new.

Did you try zapping the battery back to life?

Bill

p.s. I am going to leave my Contura powered up for a few hours to recharge the battery.

Echoes
February 5th, 2009, 10:26 AM
Well, I zapped the battery about 20 minutes ago. I'll check the status in a few hours.

BTW, you said


you do need the battery installed to boot the computer without having to go through the BIOS setup

But my problem is different! With or without the battery, it doesn't power on at all :(
It seems like it needs a charged battery to power on, and I say this because:


Completely discharged (0V) battery + AC charger = no sign of life
Partially discharged battery (1.5V) + AC adapter = leds blink toghether like if it was powering on, then everything dies
No battery + AC adapter = no sign of life
No battery + no AC adapter = just guess this one :p


If zapping doesn't work I'll try to connect a 12V stabilized power supply instead of the battery. After that, I'll just try to use it as a fridge magnet.

Echoes
February 7th, 2009, 01:19 AM
The computers seems totally dead. :(

I'll get another one (same model, but probably working) in a few days.

Thanks for your help, guys :)

Echoes
February 9th, 2009, 08:36 AM
Wow! The contura 3/25 powers on but it has no ram at all (and guess what, the ram connector it's different from the one on the 4/25). And it seems also that a bios eeprom is missing.

Anyone wants one of those for 5 + the price of the shipping? :mrgreen:

billdeg
February 9th, 2009, 08:44 AM
FYI - Here is a link to pictures of my 4/25c
http://vintagecomputer.net/browse_thread.cfm?id=216
bd

Echoes
February 9th, 2009, 02:05 PM
FIY <- I had to search for this :rolleyes:

I could fix it maybe, but I don't have the time (at least not right now). I think I'll just give it away, this is not a big loss anyway.