View Full Version : help mac lcII wont start

February 9th, 2009, 04:17 PM
i have just bought an lcII and it wont start.fan runs but drives dont keybord lights flash an screen flashes wht could cause this?

February 9th, 2009, 04:52 PM
Do you know if the PRAM battery (Mac's equivalent of CMOS battery) is ok ?

February 9th, 2009, 05:15 PM
If the PRAM battery is dead, the little CPU it keeps running will go bonkers. (Yes, PRAM is inside a tiny CPU on this board)...

Replace the battery.

If it still won't work, leave the battery in it and take a small flathead screwdriver and run it down each side of the chip, shorting the pins together as you go. Then it should power up.

Sounds screwy but I've done that to dozens and dozens of those old machines back when I worked at a repair shop in the mid 90s.


February 9th, 2009, 07:06 PM
what chip is it?

February 9th, 2009, 07:17 PM
hooked two aas to the pram battery port
\hard drive wporkjs still no beeps or video

February 9th, 2009, 07:25 PM
hooked two aa's to the pram battery port.hard drive works now but still no beeps or video

February 10th, 2009, 05:17 AM
Post a hi-res pic of the board and I'll ID it for you. It's a small surface mount chips with a Motorola M on it.

February 10th, 2009, 05:41 PM
well i got it to make the sad mac noise but the monitor was off lol

uhm im using 2 aa batterys as the pram is that good enough or should i get the adjustable power supply from the attic (cant afford batteries)

also, heres a link to where the pictures are

February 10th, 2009, 07:48 PM
OK... near the middle of the board is a small tubular crystal. It's connected to the chip right next to it, labeled UD8 EGRET (If I'm reading the silk screen correctly)...

That chip has a Motorola and an Apple copyright on it and is a surface mount chip. That's the one you want to rub the screwdriver across the legs on. Just put it at the top of the legs, where the legs meet the body of the chip and slide it down the tops of those legs, making contact with the legs as you go.

Sounds silly as hell, but I've done it many many times. Some Mac boards had a button on the motherboard you could use to reset the PRAM, but this one didn't. Too bad I didn't think about tracing that button circuitry back all those years ago.

If you still get the sad mac after that, post what the message is.


February 10th, 2009, 09:17 PM
now when i turn it on i get green lines on the screen :P

February 10th, 2009, 09:34 PM
well got 2 more unhappy mac sounds but no video during them
still doesnt want to start

February 11th, 2009, 06:06 AM
You either have a bad motherboard, VRAM SIMM, or bad RAM... At this point those motherboards are so cheap it's not worth doing component level repairs. We wouldn't do anything beyond swapping the SCSI controller on those boards back in the 90s because they were so cheap even then.

There's also a way to connect to the MAC boards remotely for diagnostics using the serial ports but I've never done it.


February 11th, 2009, 12:10 PM
least i only paid 10 dollars for it :(

this is the second mac i killed, we just don't get along i guess.