PDA

View Full Version : 1541/C64/Vic-20



Eddyvf750
February 10th, 2009, 05:46 AM
Hi, I'm new here, and new to the idea of old computers, so please forgive me if I ask questions that have already been answered.

In the process of applying "keep/toss/donate" to the mountain of stuff in the basement and attic of my house, I came across my unintentional collection of old computers. I have 2 Apple IIe's, a Commodore 64 and VIC-20 and a Timex Sinclair. So far I've found they all work but I haven't tried the Timex yet. They are the earliest history of my computer life and the flood of memories that came from using them again after so long was amazing.

But...
I have 3 1541 drives, but I can't get any of them to do anything but LOAD. When I try to format a new disk, everything seems okay until I try to SAVE to it; no luck.

Among the disks that I found was one that track-checks a disk. After I format a new disk, I run the check program and all three drives show track errors for the last 3 tracks- the error code in the program indicates "missing sync bit".

I took the covers off the drives and noticed that the faulty tracks were the ones closest to the hub, so I thought it might be that the head drive system, which is at the end of its travel there, might be sticky or something, due to not being used for more than 20 years, but everything looks clean and bright and there doesn't seem to be any mechanical difficulties, although the disk drive does seem to hesitate now and then.

All the stuff including the disks was stored in a dry, relatively dust-free place (the attic) and there are no obvious discrepancies.

Any ideas?

Thanks for your help.

Eddie

tezza
February 10th, 2009, 08:48 AM
It could be a slipping belt, leading to variable speeds. Data is more compressed in the higher tracks so if errors are happening there it means the disk is not spinning as smoothly as it should. This would explain the hesitation symptom too maybe?

Tez

Eddyvf750
February 10th, 2009, 08:57 AM
Thanks, Tez, I'll take one of the drives apart further and check the drive belt. What you said makes a lot of sense.

Is there anyplace I can get new ones?

Eddie

tezza
February 10th, 2009, 10:42 AM
There are a lot of these drives around, and they come up from time to time on ebay. You might like to post a note in the "Items Wanted" section of this forum.

Another possibility could be the drive rails which guide the head have become "sticky" towards the end, as a result of the lubricant drying out. It would pay to check these also.

With help, I've recently repaired a disk drive (http://www.classic-computers.org.nz/blog/2009-01-18-kaypro-drive-repair.htm). In that article I mention some tests/procedures you might like to try.

I should add though that I don't know a lot about these 1541 drives. I'm more familiar with the older Tandon/Teac type 5.25 drives common in PCs, 8-bit Apples, TRS-80s, CP/M machines etc. These drives might differ considerably from those. However there are people on this forum who know these drives well. Hopefully they can give you some guidance here.

Tez

Druid6900
February 10th, 2009, 12:13 PM
Chances of 3 drives, all failing in the same way, while possible, is pretty slim.

I'd be looking towards a common denominator, such as the C64, the cable, or the diskette, if the same one is being used in all 3 drives.

tezza
February 10th, 2009, 12:54 PM
Good point Druid. It would certainly be worth investigating that angle.

Tez

Terry Yager
February 10th, 2009, 08:35 PM
I'm inclined toward the sticky rails theory, but wtf do I know?

--T

patscc
February 10th, 2009, 09:10 PM
This is taken from the C64 User Guide:

21: READ ERROR (no sync character)
The disk controller is unable to detect a sync mark on the desired
track. Caused by misalignment of the read/writer head, no diskette
is present, or unformatted or improperly seated diskette. Can also
indicate a hardware failure.

Like Druid pointed out, it's odd that all three drives would have the same fault.
Are the new disks you're using new new, or new as in unused from your 20+ year stash ?
What brand are they ?
Are you using the correct side, or a 'nibbled' side ?
Do you have any other disks you can try formatting ?
Do you have any other C64 disks you can try reading ?
VIC-20's also support the 1541. Have you tried it on the VIC ?
patscc

carlsson
February 10th, 2009, 10:27 PM
Since the 1541 is an intelligent device, as long as you can send any command on the bus neither the host computer nor the cable should matter. Once you sent the N command to the drive, it will work on its own formatting those 35 tracks. I agree that it is remarkable if three drives in a row have misaligned R/W heads, in particular if you can read (load) floppy disks fine. I would also try to find another floppy disk to format.

wiskow
February 25th, 2009, 06:55 PM
Something that hasn't been mentioned here already is that you need to be sure the disks you are using with your 1541 are double-density (DD) disks, and NOT high density (HD).