PDA

View Full Version : Odd Joystick Issue



ropwoo
April 20th, 2009, 06:38 PM
Hi,

New poster - Hello!

So I have an odd issue with my TI. For some reason the TI Joystick won't move up. So I have 4 systems and at first they all work 100%. Then after some time, (10-minutes) the joystick wont move up. Thai has happened on ALL my systems. I have used multiple joysticks, multiple PS, multiple cartridges and still the same issue. Any thoughts?

barythrin
April 21st, 2009, 08:50 AM
What model of TI are you referring to? I'm not 100% sure what all could cause that. Potentially cold or bad solder joints for the joystick port and/or the controller chip getting warm after a while and not functioning correctly? (If it's the overheating thing and the timing is fairly consistent you could try putting a regular fan to blow on the system to keep it cooler and see. Sometimes when wiring gets warm and has breaks in it.

Since you've tried different joysticks and different computers that adds to the mystery, unless there's something else you're sharing between the systems. Joysticks are fairly simple wiring wise, each button under the joystick pad just has two wires and shorts two pins on the joystick port, the computer loops and checks for what pins are "on" and that results in the action.

- John

ropwoo
April 21st, 2009, 05:40 PM
Interesting thing is that I have changed out every common component with the exception of the monitor. I have used multiple joysticks, multiple computers, two different power supplies, two different speech synthesizers and different cartridges. All have the same impact - no up motion with the joystick after a period of time. Problem is I have gone through all 4 of my TI consoles. So now I have no way to test any further.

cosam
April 22nd, 2009, 01:45 AM
As John says, it sounds like something is starting to fail as it warms up. It's however very strange that all four of your machines have the exact same problem. Unless it's down to some extraordinary coincidence, I suspect there's something common to them all that you've overlooked.

Maybe tracing the problem on one of the machines will reveal where things are going wrong? It may not be the root cause, but it might just shed some light on the matter. I'd start at the joystick port pin for the "up" signal and work back through the circuit. Maybe you'll uncover a bad connection or a component that's on its way out. Wouldn't hurt to check your voltages either, especially to the joystick-related components.

willowmoon93
April 22nd, 2009, 07:46 AM
Ooooooh I remember this one with TI-99/4A's !!! This is a very simple problem with all the TI-99/4A computers. If the ALPHA LOCK key is locked (all the way down), the computer won't recognize anything on the joystick as far as the "up" signal is concerned. So make sure your ALPHA LOCK key is released and then your joysticks will run fine.

Ksarul
April 26th, 2009, 11:44 AM
As Willowmoon says, check to make sure you didn't hit the Alpha-Lock. If that isn't it, definitely look at the possible heating issue.