PDA

View Full Version : Trying Out OS/2 Version 3 (Warp)



irishmike
April 27th, 2009, 12:37 PM
Greetings:

Just installed OS/2 Warp Version 3 on my IBM Model 95 and I am actually surprised how familiar it seems yet it is so NOT familiar at the same time!

I could use someone that knows the ins and outs of OS/2 in areas like TCP/IP and setting it up to use the network card etc. I installed the Internet Connection Kit and it seems to be running okay (for an old IBM PS/2) but I plan to launch a BBS from the system and need to get Telnet services working on the system (including a daemon) or I may just use it for a cool vintage system to play with as well... but OS/2 is actually new to me.

I would point out how it seems to be AmigaOS all grown up, but I don't want to feel that fire ;-)

Help with this would be appreciated including a good BBS software to run on this system and a good ANSI editor, etc.

dpatten
April 27th, 2009, 02:13 PM
In my experience OS/2 Warp 3 doesn't have the proper TCP/IP support for use in a networked internet connection. I actually paid honest to God money for a copy back before Windows 95. It worked great-- with dialup.

You can rig it by using the Microsoft TCP/IP setup with Win-OS/2

Your best bet is probably going to be Warp 3 Connect which has somewhat better networking functionality or Warp 4.

irishmike
April 27th, 2009, 02:29 PM
@dpatten: Thanks for the response.

Forgive my ignorance, but is OS/2 Warp Connect a whole other version of OS/2 Warp or is it an add on? In any case, where would one find a copy? I don't have a cdrom for this unit (it is SCSI) and I don't plan to go and find one -- My OS/2 is all on Floppy disk naturally. If someone has a copy of the connect they would be willing to make an image of? Or a lead on where to actually obtain a copy is fine too. But PM me if you can help a guy out!

Thanks,

Mike

mbbrutman
April 27th, 2009, 03:20 PM
Huh? OS/2 Warp was fine for Internet use.

The TCP/IP was an addon, and there might be fixpacks for it, but it should work fine. I had it on both dial-up and LAN. Telnet, FTP, NewsReader/2 all worked fine. I also had PM/X either on OS/2 2.11 or Warp for X-windows apps coming from Unix machines.

The bigger complaint about OS/2 Warp is getting it fixed and up to date. I was on Fixpack 3 when I finally migrated away from it.

irishmike
April 27th, 2009, 04:48 PM
@mbbrutman: I am trying to get it to connect through the NIC (not dialup) and so I need to know how to do it. I just installed it fresh today and I put the connection kit from the bonus pack into the system... but as I said, it is a complete new system to me (I am not familiar with OS/2 -- yet) and need to get it to have a static IP from the NIC. So, Do I or don't I need the OS/2 Connect? If I do, where can I find it. The OS/2 install package was on a shelf at my friends office and he of course said "Take it"... so I did :-)

Thanks in advance for the help.

Mike

Unknown_K
April 27th, 2009, 09:54 PM
Warp 3 connect has ethernet setup out of the box. I had issues with internet and warp 3 (not connect) a while back and I wiped it before I figured it out.

I might get back to is later in the week (tons of other projects going on) when I stick a 9 or 18Gb SCSI hd into my PS/2 95. Planning on partitioning it up and running DOS/WFW, NT 4, and Warp 3 if it all works.

irishmike
April 28th, 2009, 02:59 AM
@unknown K: thanks for the reply. I have posted a PM to you as well on another subject that you might be able to help out on.

mbbrutman
April 28th, 2009, 05:32 AM
IrishMike,

Normal, unadultered OS/2 Warp can get on a network using an Ethernet card. It is not just a dial-up only option. This is how I ran my system.

Telling you how to do it - that's another problem. I have the machine and the images of the hard drives, but I have not run OS/2 on it in 3 years now. It's a Linux only machine at the moment. Find one of the OS/2 newsgroups on Usenet and do some reading, or post and ask for help. The OS/2 die-hards are still there.

OS/2 Connect integrated the TCP/IP stack and added a few features like routing capability, but it is not required for your setup.

Mike

BuggZ
April 29th, 2009, 12:36 PM
I have an old 486 machine with OS2 v3 on it. If I have time tomorrow, I'll connect it up and see if I can come up with some information for you.