PDA

View Full Version : CF on a Stinkpad 750



Anonymous Coward
May 5th, 2009, 05:29 PM
I have one of those mini-IDE to compact flash adaptors with a 2GB SanDisk Ultra II connected, and I am having some troubles getting the TP750 to see it. TP750 BIOS supports up to 8GB EIDE drives. When I boot the system from floppy I am able to access the compact flash without any problems. However, I cannot boot from compact flash, and the BIOS can't seem to detect it when in CMOS setup.

Anyone in here know how to fix this problem? I am pretty sure I once found a website that showed how to get everything working, but as usual I lost the link.

Dreamcast270mhz
May 5th, 2009, 05:38 PM
have you made it bootable first, if unsure double check. And, as always merging legacy hardware with modern, you will encounter impossible scenarios. Now there may be a way to trick the Thinkpad into believing it's reading an HDD or else other media.

patscc
May 5th, 2009, 05:44 PM
Have you tried another CF ? It seems not all CF are created equal in terms of how well they adhere to IDE.
patscc

Anonymous Coward
May 5th, 2009, 06:16 PM
I haven't tried a different one yet, but the Ultra II seems to be a pretty good card to use. I've already switched it into fixed disk mode.

I have a theory that maybe thinkpads only work with drives that have IBM FRUs. Is there anyone in here that runs a TP750 or TP360 with a non-IBM drive?

Vlad
May 5th, 2009, 06:20 PM
I dunno about Vintage ones but I've replaced a hard drive in a T Series that didn't seem to care it wasn't an IBM drive.

Anonymous Coward
May 5th, 2009, 07:27 PM
The problem is solved.

Just do FDISK /MBR

patscc
May 5th, 2009, 09:24 PM
Interesting. I didn't quite catch this in any of the earlier posts, but is sounds like the CF was initially partitioned & formatted on another computer. What computer did the FDISK/MBR occur on ?
patscc

Anonymous Coward
May 6th, 2009, 05:05 AM
Yes, it was partitioned on my XT. Though the XT had the same problem trying to boot from it. It was being used as a secondary drive. It seems to be a pretty common problem with CF when installing DOS.