View Full Version : IIci Powerup and PSU Problem(s)

June 11th, 2009, 12:01 PM
I bought a IIci through a friend from a guy for $60. This was a bit pricey, but my friend saw it start up and it has a port for the Apple II disk drive to hook up, so I wanted it. It was also maxed out, hardware-wise.

I got the machine from my friend, who brought my $60 to this guy.

I plug it in, and can't get it to turn on. There's a wonky switch in the back, and my friend says the guy played with that and the front buttons to get it to turn on.

I turn the back switch to a ( | ) position, and it clicks inward. Nothing happens. I then screw with the front buttons, and nothing. I try every combination of the back switch and the front two buttons, leaving the machine unplugged or plugged for weeks at a time to try to get the 5v trickle charge however the machine would like it. No dice.

I tried pulling the PSU out and reseating it, and still no luck.

Do I need a new PSU? Is there anything else I can do? What position of the switch in the back is this "server" position where it turns on automatically when able?

Is there somewhere I can apply 5v to make the thing happy? If so what amperage (or does it matter).. I was thinking molex 5v from a PC PSU..

Also, while we're at it, what's the proper way to power on this beast?

June 11th, 2009, 02:11 PM
The power switch on a IIci is a pushbutton. No twisting.

If you are pushing it and it is not powering up, the most likely culprit and simplest to repair is to replace the battery.

If you replace the battery and still nothing, you probably have some leaked electrolyte which has etched a trace in the power-on circuit. I had some Mac II systems which had this problem.

Also, if you connect an Apple II drive to the floppy port of the IIci, it will not work. I can't say from experience that it will harm anything either, but there's no reason to chance it---the Mac floppy controller can be touchy about what it will and will not let you get away with.

June 11th, 2009, 02:14 PM
Also - the front buttons are the "programmer's switch"; one is reset, the other is a non-maskable interrupt which gets you to a hardware monitor (or invoke MacsBug, if running). If they did anything to cause the machine to power on, I would be surprised.

June 11th, 2009, 02:21 PM
Open up the power supply and disassemble it. On the upside down top board in it you will find a small metal foil capacitor. Typically the circuit board around it will be discolored from heat.

Replace that small capacitor and the power supply will turn on again.

It was a common fix back in the day when I worked at a grey market Apple repair center.


June 11th, 2009, 06:02 PM
Thank you, I will try this soon and report back. It'd be great if I didn't have to go hunting down a PSU.