PDA

View Full Version : That damnable desktop



CommodoreKid
June 26th, 2009, 08:01 PM
I have this desktop my dad had built for me around 2003 or 2004 for Christmas. Windows XP, and specs that would have made kids drool in 2004.

I brought it to college with me this year, along with my Toshiba laptop (with about the same capabilities, from the same year) and my newer Dell with more modern specs. I figured that I would use the desktop for the majority of my gaming, and perhaps programming. Back home, it used a wireless card and antenna to connect to my home network, but I planned to hard wire it at college. It worked... sorta.

They seem to want to keep this computer off of the network, for reasons unbeknownst to me, and therefore I gave up on trying to keep it connected. When I got to school, they forced all machines running XP to upgrade to the then new service pack 3. So, I gave it SP3, just like my Toshiba. The problem I realized NOW is that the Toshiba was getting new updates regularly, but the desktop was not getting any, being off the network.

So the stupid thing has now refused to run almost any kind of game I wish to play, because it doesn't have any updates that fixed stuff wrong with SP3. This, in turn, turned the machine almost useless over night, except for a few choice programs.

The real kicker is that we got a new network wireless router at my house, which has an encryption unknown to it. So basically, it's on its own when it comes to updates, until I can find a clever solution. I just got a nice IBM model M keyboard for it too. *sigh* I wish this damned thing would cooperate. It errors up like a mofo these days.

And that's all the motivation I needed to go and try a few ideas that have been percolating to get it running again.
*runs yelling at the computer holding a monkey wrench, a CAT6 cable, and a can of iced tea*

Chuck(G)
June 26th, 2009, 08:08 PM
Are most of the things that SP3 broke related to new DLLs? If so, you can use local (to your app) copies of old DLLs by creating a .local file in your app's home directory.

Raven
June 29th, 2009, 03:38 PM
Many options here:

- Hook up to a private network of yours wired with internet access temporarily, update, profit.

- Download the updates, put them on a jump drive or other media, install, profit.

- If the above two options won't work, mix them. Download every available update, set up a Server 2003 box with WSUS, and then point your XP machine to it for updates, update, profit.

- Download a more updated SP3 integrated CD from a torrent that has all the updates up to the current month (this is what I do when I install XP on a machine), and then you're pretty close to fully updated before you even get off the ground.

All hope is not lost. :)

Edit: Also, there is (depending on how you installed the update) a service pack uninstaller installed with the service pack, search for how to use it..

CommodoreKid
June 29th, 2009, 07:18 PM
No problems. I uninstalled the ASUS wireless card manager, but ended up uninstalling the driver too... *insert expletive here*.

Sooooo, I reinstalled it, and went through the configuration, and at the end of the setup for the wireless card manager, it asked me if I just wanted to use the built-in windows one instead. Uh, yeah! That's what I was trying to do in the first place!!! ARGLEBLARGHLE

After that, it let me connect to the network just fine... ????????? WTF? Why didn't the company's card manager not let connect to my own freakin network?
It always went into a cycle:


Search for network
Attempt to aquire network address
Give up
Repeat

Windows built in program did a fine job connecting to the network, so I was able to update the crap out of it. After the mandatory re-boot associated with the updates, it somehow got set back to the ASUS wireless card manager, and then did the same mess as before. I almost gave the *expletive* up on it.

I just repeated the process of uninstalling and reinstalling the program & driver combination, and set Windows to handle the wireless, and lo and behold: IT WORKED AGAIN!!!!1!1!!!111!1!1111

If it does this again upon my return to it, I may have to go crazy on it...
Otherwise, the computer is running alright, but some games are still being a *foul word*.