View Full Version : Xerox 860 IPS

July 23rd, 2009, 08:02 PM
I just got a Xerox 860 IPS but, I can't get the bloody thing to boot. Its a pretty oddball system that was popular as a word processing system in the 80's for places with money. It usually came with a portrait display and only the word processing system.

In fact, I've read people from Xerox claiming it only ran that word processing system and used a custom os. Nothing else was ever available.

Well, mine came with a more normal 12" monitor and a box of original Xerox labeled disks with things like cp/m, dbase, visicalc, and wordstar. Even has a COBOL disk. It came from UC Berkeley with a ton of spare cards. Most labeled 'bad'. They must have been very flaky machines. I seriously have 10 ram boards labeled bad with descriptions of the various failures. Another 5 or so of the crt boards. Luckily a few are labeled good. They may not actually be.

So, most of the app disks don't boot at all. The cp/m disk reads a bit then prints, "C" and stops. The word processing system reads awhile then stops and does nothing. Without a known working boot disk it make things hard. Is it the disks or the hardware ? Anyone have a boot disk ?

Most every cp/m system I have ever used prints out the cp/m copyright banner etc on boot. Seem like maybe its dying after the c in cp/m but why ? Doesn't make much sense.

I tried swapping out all the cards with others from the huge pile of spares and it always did the same thing. Doesn't feel like a bad card issue.

The power supply in this thing is truly epic. Massive transformer and caps the size of beer cans. Funny thing in the few pictures around online they show two boards as part of the supply. One on each side. Mine one has one. Still I dont think I;d get as far as a huge Xerox logo across the screen if half the power supply was missing. Mine seems to be a later revision but, who knows.

Anyway, until I get a known good boot disk I'm stuck. If anyone knows someone with one of these that can copy a boot disk for me let me know.

Lou - N2MIY
July 24th, 2009, 02:42 AM
Finally !!!!!

I have a load of 860 IPS manuals, boot disks, absolutely everything except the machine. Send me a PM and we'll figure out how to get this mess out of my closet and to your house!!!!

You will be in 860 heaven (and I will have more room for dec stuff!!!) What I have is all related to the word processing system - it was rescued from an attorney in the next state who was giving away a load of 8" disks. He threatened to throw away these manuals and word processing program disks, but I told him I would hold on to them until I found someone who needed them. The search is over!!!


July 24th, 2009, 09:36 AM
JACKPOT!! pm sent

August 4th, 2009, 11:29 PM
I want to first off thank Lou that sent me some pretty cool stuff today. I havent even had time to go through it all yet but, its fun reading. Thanks Lou !

When I got Lou's box it made me go mess with the machine more. I haven't played with his disks yet but, in the short time I had to play with it tonight I realized the main boot drive was dead or dying.

This may make sense since it came mysteriously with a xerox copy of the Shugart repair manual as the only single document with the it. I ripped it out and made the other drive DS1. Now it boots a bit farther. Could it be that it needs both drives operational to even boot ? I've never had cp/m bug me about memory drives but, I'm not an expert. What might go in the other drive if it does need it ? A swap floppy ?

Anyway, I get this far and no further and suspect it wont until I fix the other drive. If I can. Anyway, this should make it clear cp/m exists for the 860 and it isn't just a word processor. The disk I have labeled cobol is an indication of that as well ;)


August 5th, 2009, 09:06 AM
Anyway, I get this far and no further and suspect it wont until I fix the other drive. If I can. Anyway, this should make it clear cp/m exists for the 860 and it isn't just a word processor. The disk I have labeled cobol is an indication of that as well ;)

The 62K signon is telling you that you've pretty much got the maximum memory that CP/M 2.2 allows, and that the RAM disk (M:) is simply using other (bank switched) memory for operation. You could probably patch or re-assemble the CBIOS to get rid of it, but there's no point to that.

Does your 860 have a hard disk, or could it be equipped with one? If so, that may be what's stalling things now.

August 5th, 2009, 10:43 AM
No hard disk. Just dual 8" Shugart 851. One drive is down though so, I have it removed. I thought perhaps it wont boot until it finds the 2nd drive. I can't imagine what disk would need to be in there though. I don't have any disks labeled anything obvious.

August 5th, 2009, 11:17 AM
No hard disk. Just dual 8" Shugart 851. One drive is down though so, I have it removed. I thought perhaps it wont boot until it finds the 2nd drive. I can't imagine what disk would need to be in there though. I don't have any disks labeled anything obvious.

Looking for a B: drive isn't part of the usual CP/M boot process, although there's always the possibility that Xerox has added something. But a hard disk initialization is almost always part of the boot process when the CBIOS has been created to support one. That's often where things hang up.

Do you have a PC with an 8" drive? 22Disk does have an 860 definition. The only 860 disk I've got in my collection is labeled "System 3.2", which I'm assuming isn't CP/M.

August 5th, 2009, 04:59 PM
This is going to be fun since I have none of the cp/m documentation, no service documentation, and for once the internet is silent on the subject. In fact, there seems to be comments from people that worked at Xerox at the time that claim stuff like cp/m never existed for these.

As far as I can tell there was never a hard drive option for these. Seems odd since these were still in use well into the 90's. There is no mention of any upgrades to these at all in fact even though they were used over many years.

The other fun fact is these must have been really prone to hardware issues. I have like 25 boards that came with this that about 70% of are marked bad. Along with some hand scribbled notes about the faults found in what appears to be only three or four machines this maint guy was responsible for. If twenty bad boards came out of just 4 machines that's a terrible failure rate.

Since the only thing I am sure doesn't work at the moment is one of the drives I think I'll start with trying to get that running. At least I'll be able to rule that out. Its also the only thing I can find service docs for since its just a shugart drive.

I'll try and take some pictures of the thing.

edit: Sorry for not answering the question. I don't have any other 8" drives unfortunately. Thanks to Lou and the guy who gave me this I think I have the boot disk issue covered but, I'll look through the stacks and see where your disk might fit in. It could be something interesting.

August 5th, 2009, 07:05 PM
I'll have to take a look at it again when I get a chance.

Lots of Xerox stuff used CP/M; for example the 3700 laser printer (it had an 820 board inside).

August 6th, 2009, 08:18 PM
OK so, I got both drives working and they seem pretty good. I get the same results now using either drive. Stupid molex connectors.

I have a zillion possible boot disks and several diagnostics disks but, they all give pretty much the same results.

I think this may have been a waste of time actually. I think it is possible I may be missing 2/3 the power supply. Its seems odd I can get as far as I can if this is true but, if you look at this http://www.digibarn.com/collections/systems/xerox860/DSC01329.JPG you will notice two boards below the guy's hands. I don't have those. Nothing is there at all.

If you look at this picture http://www.digibarn.com/collections/systems/xerox860/DSC01323.JPG You can see them from the other side.

This picture shows the one I do have http://www.digibarn.com/collections/systems/xerox860/DSC01319.JPG . Those leds indicate the various voltages being OK and all mine are brightly lit.

There are not a mess of dangling wires without places to go. In the whole machine there are only two molex connectors not connected to anything and they are very neatly strapped to that transformer you see in the pictures. They only lead into the transformer. Maybe its just me but, when I'm stripping parts I don't take time to neatly tie of the leads to what I just removed. They are also perfect length, if untied, to reach boards about were those would have been.

All the outs of the transformer lead into that other supply board (I have) and again all the leds are showing ok. One would think all needed voltages are ok and in fact everywhere I have tested they are.

The 860 in those pictures has a full screen display and is a model A. Mine has a partial screen display and is model F. I sort of supposed that mine was a later revision that maybe they reduced the board count or perhaps the extra boards were something only the full screen required. Mainly because I can get everything to boot up to a point. If two out of three boards of the power system were missing it would seem odd to even turn on. However I see no difference between my existing board and his.

I was going over these ancient 3x5 handwritten notes from the IT guy who must have serviced these. Most are just thinking out loud or phone numbers to call for help but, one said,
"Power Supplies
- A1 + A2 are for keyboard and display
- A3 is for system"

Now it would seem odd that the display is working fine if it was missing its power supply. The keyboard is full of mainly 74 series stuff and its got +5 everywhere I've tested.

This guy writing the notes doesn't seem like he's an expert but, more like he's doing on the job training and taking notes as he goes. He also keeps talking about "straping" the floppy drives as a needed solution to some problems. I have no idea what that means. He is obviously talking about hardware too and not the disks unless hes confused.

As an example one 3x5 note says this,

"860 Problems
If you flash back to Xerox.
If You can not load your system disk
If you get E error codes
It could be your power supply also
check your straping
on your disk drives"

I suppose he means 'strapping' but, who knows. He may also be trying to write poetry. I'm not sure. The formatting is his not mine.

Any thoughts ? I haven't broken out a scope yet. Could those other boards be just filtering for those voltages so, it shows as fine but, really is all over the place ? I've only taken a multimeter to it so far. I suspect I may be missing parts I'll not be able to replace though.

Lou - N2MIY
August 7th, 2009, 03:00 AM
"Strapping" is/was commonly used the way would use "jumpering" now. The Shugart drives were very flexible and have many jumpers. Perhaps this guy was doing a lot of drive swapping with drives from other (maybe non-860) machines and often ran into the jumpers not being set correctly.

If indeed the missing parts are power supplies, you certainly can build those, however, I agree that it would be impossible that you made it this far with any missing power supplies.

Are your CP/M disks single or double sided (you can tell from the sector hole location, holding the disk write protect notch down, the SS sector hole will be just past 12 o'clock, DS will be just past 1 o'clock.) If DS, are both heads of the drive working? Maybe since both drives now work, switch them back to the original arrangement.


August 7th, 2009, 09:46 AM
I am pretty sure they are all double-sided and drives are back in the original positioning. One cool thing about the system is it will automatically boot off the other drive when it doesn't find a bootable disk in the first. That saves me from having to swap them around. I also get the same results no matter which boots.

The keyboard is a piece of the puzzle as well. It has no power light or audible keypress so, I really can't say if its working at all. Perhaps that's where cp/m is hanging. cp/m does make the printer reset after it loads.

The cp/m disks get to the banner I posted earlier but, all the word processing disks just load for a bit and then nothing happens. No error code displayed or well anything. Just sits at the point I would guess it just tried to run what it just finished loading. Leds indicate 0000 which seems to mean the system is OK. If there is an error the display shows a four digit error code.

If I had access to a working 860 or a service manual this would be a lot easier. I have plenty of diagnostics disks and I can generate error codes by swapping in various boards but, there is just no way to look them up.

Xerox may never have let service manuals out into the wild for these. The reference manual just says to call the support # if you see anything but, 9999 after the diag tests are run.

March 13th, 2011, 03:03 PM
If you are looking for Xerox 860 parts, I might have what you need; including several keyboards, full page monitors and the innards of the console. Of the five systems, three of them were scrapped but I saved the console innards: digital and power supply circuit boards, power transformers and Schuggart 8" drives. Most of the pieces are boxed up, but I can find them given a little time. I had played around with the 860 for a few years in the late 1980's. I haven't fired up an 860 in a decade or so, but I do recall there were a few hardware issues; easy to fix. Definitely fun to play with. Never had any problems with the digital boards. Have one used CRT and have a new-old-stock CRT in box. I have two systems worth located in the garage.
Santa Barbara, CA

March 27th, 2011, 01:34 PM
If you are looking for Xerox 860 parts, I might have what you need; ....Bill
Santa Barbara, CA

Dear Bill,
I have got a Xerox 860 (unfortunately still not working) and would be interested into some spare parts... This monster just starts up, (both leds of the drives light red and seem to work) but the screen and the printer don't power up. I have no idea what goes wrong. May be the crt board? I don't know. The diagnostic panel showes an error code of 7020 or 25? (what I can remeber...) and 0007, but I don't have a service manual... May be you can help me. What do you want for the spare parts?
Thank you very much