PDA

View Full Version : Can't get Star Commander to work



Raven
December 14th, 2009, 07:45 PM
I used to use Star Commander to write C64 disks and it worked great. I was using it on my XP IBM Thinkpad then. I now have a desktop (I still have the thinkpad if it really comes to that) with a parallel port, and so I set things up on it. I have one of those switchable adapters that can do XE1541 or XM1541 (mine's in XM mode), and a 1541 drive keyed to number 8 hooked up.

I go into Star Commander, and it doesn't respond to my input.

I downloaded the beta version, and it responds fine. I click and go to set the right panel to drive 8 - it tells me I need to configure the prog, so I set it to XM1541 and hit OK - it tells me that I should set ASYNC to on (it was on auto, but it says this even with it on "always"), and asks me if I wanna continue. I go to hit enter, and it does nothing. No input does anything. The same happens in the scsetup program, so I can't configure the program, and thus can't use it.

I have GIVEIO installed, but don't see an entry in devmgmt, but either way SC should function..

So... wtf am I doing wrong? Windows 7 32-bit btw.. I downgraded from 64-bit and 4GB RAM to 32-bit and 2GB RAM so I could run 16-bit apps again, it was starting to piss me off.

Raven
December 14th, 2009, 07:58 PM
Just tried it in XE mode and same result... *baffled* :confused:

carlsson
December 14th, 2009, 09:35 PM
I never tried Star Commander in a command line shell under Win32 or newer. You could just as well give OpenCBM (cbm4win) a try. Some people complain they never get it to work, but I had quite some success with that one once I had locked the driver with instcbm --lock=yes.

If you insist on SC, I would recommend to run it in pure DOS mode.

Raven
December 14th, 2009, 09:48 PM
I had no trouble with it on XP, which is why I assumed it would work on Win7, the HALs were already there and the NTVDM is the same..

I will try OpenCBM tomorrow.

I am at another PC at the moment, but I downloaded OpenCBM and had a look - I like the looks of it, modular commands and a central driver to tie them together - elegant. This also means that it'd be simple to whip up a nice explorer-like GUI if I wanted to - perhaps I will if this works for me.

sjgray
December 15th, 2009, 01:12 PM
This also means that it'd be simple to whip up a nice explorer-like GUI if I wanted to - perhaps I will if this works for me.

Instant GUI...
http://www.6502.org/users/sjgray/software/cbmxfer/cbmxfer.html

Steve

Raven
December 16th, 2009, 09:54 AM
Oooo that's nice.. unfortunately my new 1541-II doesn't have a power cable, but when I get the cable for it (friend has it sittin' around) I'll give it a go!