View Full Version : telnet into my 8088

Mike Chambers
December 20th, 2009, 12:38 AM
i've been installing and tweaking MINIX 2.0.2 on my ol' XT clone the past few nights, and i'm pretty happy with the way i've got it set up now. if anybody feels like logging in remotely via telnet, be my guest!

i set up a guest account for anybody who wants to take a peek. i've gotta say i'm extremely impressed with what i can get that old thing doing with MINIX. i will probably never put DOS on it again! :eek:

of course, multitasking gets pretty limited when you have 640 KB, so not too much can be running all at once. at first i thought i had it set up to use a swap partition, but it turned out it wasn't using it becuase it has to execute in real mode. (which makes sense) i'd need a 286 or better to make use of the swap.

so yeah, there's nothing too interesting to do on there. just the standard UNIX-ish stuff. it's just a neat little curiously. it has an httpd and ftpd that came with the distro, but i have them disabled to save RAM. maybe if i come up with some kind of actual content i'd set those up.

without further ado, here's the info. if you're bored you can always open vi and leave me a text file note saved in /home/guest/ or something :p

hostname: irc.rubbermallet.org on port 8088 - not the standard telnet port
username: guest
password: vintage

the system should be pretty damn secure, but please do me a favor and try to destroy it on purpose. thanks. -_-

December 20th, 2009, 01:46 AM
Hmm..tried it Mike but it didn't seem to like me.

Connection failed.


Ole Juul
December 20th, 2009, 01:48 AM
I'm not having any luck here. Port 8088 Perhaps I'm missing something.

Mike Chambers
December 20th, 2009, 01:58 AM
whoops! sorry. try irc.rubbermallet.org port 8088 instead to telnet in.

Ole Juul
December 20th, 2009, 01:59 AM
That's better. :)

Edit: Good work! No vi though (unless I spelt it wrong) so I'm leaving a message here instead.

Mike Chambers
December 20th, 2009, 02:33 AM
oh you might have to :

export TERM

then start vi

December 20th, 2009, 05:35 AM
check your /tmp :)

Mike Chambers
December 20th, 2009, 11:24 AM
lol, i see it.

# ls /tmp

April 19th, 2011, 05:27 AM
I assume this is not still running, as I did not get anywhere when I tried it:

mgh21@robert:~$ telnet irc.rubbermallet.org 8088
telnet: connect to address Connection refused
telnet: connect to address Connection refused
telnet: Unable to connect to remote host: Connection refused

I have a Sperry PC (an IBM PC clone made by Sperry-Univac, which later merged with Burroughs and became Unisys). I would like to try Minix with it as you did with your old PC. The HDD failed years ago, but I have a SCSI card which may work in it. Does the older version of Minix support SCSI? My Sperry only has 512K of RAM, while most other clones had 640.

Mike Chambers
April 21st, 2011, 08:19 AM
yeah, it's been down for some time that machine no longer has minix on it. you're getting multiple IPs on telnetting because that domain name is set up as a round-robin IP pool for my IRC network.

i can't say if the old Minix supports SCSI but i suspect it might support some adapters. for info on that, check out this site http://minix1.woodhull.com/

as far as the 512 KB RAM issue, that could pose some problems. i think it will probably BOOT and possibly give you a shell, but not too much else.

May 9th, 2011, 01:40 AM
Thanks for the reply. I got the old computer out of the crate where it has been for some time today, and turned it on. It did turn on, and then I booted it off an MSDOS floppy I found. Some of the keys are not working, so I will have to take the keyboard apart and see if it is just dirt. I will let you know if I make any progress.