PDA

View Full Version : Morrow Mico-Decision 2



Old-Timer
July 4th, 2005, 12:32 PM
I was just given an old MD2 with a Wyse 50 terminal.
One 5-1/2 floppy drive and one CM5619 hard drive.
No cables, or software floppies. Only a New-Word manual for the MD2.
The power supply was dead. I repaired it and now have the
proper voltages to the MOBO and drives.
When turned on, the hard drive lights up and spins, and shuts down
after about 2 minutes.
Nothing on the screen. The terminal is working OK as I tried it on
my old S-100 bus system.
I may not have the terminal wired correctly. I used the following
four wire DB-25 connections:
1 to 1 2 to 3 3 to 2 7 to 7

Does the MD2 require any special handshaking ?
I would expect some output giving a sign-on message to the screen.
An RS-232 break-out box does not show any activity on the
transmit line at the computer.
Is there a way to boot from the floppy ?
Any suggestions will be appreciated....
Old-Timer (John)

Terry Yager
July 4th, 2005, 02:31 PM
If you open up the MD, inside you will find that both serial ports are re-configurable from DCE to DTE, by moving the jumpers around. It should be easy to figure out the correct handshaking by the way the ports are set up.
It's just straight, natural CP/M, so it should boot from the floppy, as long as your bootdisk is not corrupted. I don't recall what kind of power-on message is displayed, if any. It should also be noted that the MD-2 didn't come with a hard drive, so there's no telling what you have, or how it's been modded, unless you open 'er up for an eyeballin'.
For more help, see the recent thread in comp.os.cpm under the topic "s100 and morrow cpm based computers need home"...

--T

Old-Timer
July 5th, 2005, 05:38 PM
Well, Im starting to make some progress. I can now use the Wyse 50
terminal. I had crossed RS232 lines 2 and 3. The Morrow does not like
this. When I went to direct lines 2 and 3, the computer displayed a
startup line and checked memory (It was OK).
Still not using any handshaking. Just lines 2, 3, and 7.

I also believe that my machine is a model MD16. There is a yellow
sticker with MD16 on the hard drive (which I think is a 19 MB (unformatted).
Many of the IC's have late 1984 dates, so it was probably made then or
sometime early in 1985.

Still cannot boot.
After memory check, it tries to boot from the hard drive, and finally
displays a "Error on CP/M System Disk" "Push reset to try again".
The message then repeats again.
If I put a floppy in the drive, it asks if I want to boot from the floppy
drive. It tries when I enter a "Y", but still will not boot.
One of the floppies must of had a CP/M system because it displayed
a message "CP/M V3.0 Loader", then the message
Disk error on drive A: Seek error or Data Not found.
None of my other floppies were system disks.

I cleaned and de-magnetized the heads, but still same error.
Same error with an old 360K TEAC drive.
Tried the MD16 floppy drive on my Win-98 machine and it seems
to work OK.

Any one have a boot floppy with CP/M 3.0 on it ???
One web site said Caladera released CP/M to public domain in 1996.
So there is no copyright problems.
Is there a way someone could E-Mail the system files so that I could
put them on a 5-1/4 drive ?

Any Suggestions ??????
Old-Timer (John)

Terry Yager
July 5th, 2005, 07:46 PM
Sounds like you've pretty well covered all the bases. Your hard drive & boot floppies have become corrupted, so aquiring a good bootdisk with hdd utilities is the next logical step. Post your request in ng comp.os.cpm, surely someone there will have one.

--T