PDA

View Full Version : More Commodore 1541 Drive Problems!!



antiquekid3
January 2nd, 2010, 06:27 PM
Ugh! I so I lug home another 1541, and it still doesn't work! It has some different symptoms, though.

Before I start, here's what I've done to both: cleaned the tape heads and dusted them out.

So the first one tries to read a disk, the red light flickers, and then starts blinking rapidly. The newest one just sits there with both lights lit, never going off.

I suspect the first one to be an alignment problem. The second I suspect to be a circuit/chip problem.

I just took out the boards from both and exchanged them. The "good" board (#1) in the new (#2) drive has the exact same symptoms as when the unmodified #1 drive. The other (#2) board in the #1 drive does the exact same thing as the #2 drive did originally. Essentially, swapping the physical drive (motors and head, etc.) did nothing. Does that make sense?

Should I be daring and try an alignment procedure? Can I really screw it up more than it is right now?

How can I be SURE it's my drives and not my Commodore? I don't have another C64 to test them with.

Help! I'm so puzzled! :confused:

Kyle

carlsson
January 3rd, 2010, 08:11 AM
Try Ray Carlsen's checklist for faults and symptoms: http://personalpages.tds.net/~rcarlsen/cbm/1541chip.txt

See also rest of his documents: http://personalpages.tds.net/~rcarlsen/cbm.html

antiquekid3
January 3rd, 2010, 09:12 AM
I've already looked at that, and I think that'll help me with the one that doesn't talk to the computer. Right now I'm trying to align the drive. It's not going so well...

Kyle

SUCCESS
January 3rd, 2010, 03:49 PM
I have three 1541 drives.
Only one of then have worked fine always. The second one has some sort of thermal issue, after 2 or three hours of use, stops reading at all. Neither the directory track can be read.
The third one is out of allingment, but the electronic works fine. The third one flashes always, no matter what you ask the drive.
I tried several method to allign it, and managed to get it working, but then died (cannot be alligned doing the same thing I hed done before). IF I put the electronics from the third into the second, the drive works perfect. So it's clearly a mechanical issue in drive 3. Also, putting the electronic from the second into the third have not effect. The drive continues giving read errors.
My brother has another 1541 (ALPS version) and does the same thing that my second 1541. After two or three hours stop working. Just bang the head and fail on everything. Just put a fan for an hour and works again. I really hate this drive.

Prior to moving the stepper check carefully if it's an alligment issue, because once you lose the screws you are done.
I've read that a common problem is the lack of force in the load pad that hold the disk when you turn the lever.
Media position in relation to flywhell position cannot change once the reading process has started.
Check out this, because it's very important.
The other thing is the speed of the flywheel. Is not common problem but when it's out of adjust the red ligh blinks

Allingment:

Boring and exahusting proccess. It's the last thing you wan't to do, believe me.
But just in case, you will need a program to help you to allign the drive. That's a hard contraint because all the programs are in d64 or prg, so you need a working drive or the XE1541 cable to transfer to the 64 some program. I haven't done something like that, because I don't want to fry my C64.

What I've done is:
1) tranfer the program 1541ali to a floppy using the XE1541 and the SC running on a DOS PC.
2) usign the C64, a good 1541 and a datasette, tranfer the 1541ali to a tape usign "copy lin". I can actually load the 1541ali soft into C64 usign the working drive, but unplugging the IEC cable from good 1541 and plugging it into the other while the C64 and the drives are turned on is a bit dangerous IMHO. So I decided to save the 1541ali program to a tape.
3) load the program from the tape
4) Inset a commercial disk (this will be the "standard") choose the option "move from track 1 to 35 and repeat" . I loose the screws while holding the steper. I moved it a bit in each direction until the drive moves smothly form track 1 to 35, without banging.
5) Tigh the screws very slowly and evenly !!!!!!!!!!!!!!!!!!!!! in order to avoid moving the steper.
6) read track 1, track 17 and 35. If the ligth doesn't flash. you have finished. If it flashes, lose and move a bit again until this three track readings work fine.
7) usign the function "5" in the 1541ali, perform a full check, track by track. Try several disks.
8) if it worked fine put some nail paint into the screws and pray the drive doens't go out of alligment again.


MOre info about drive adjuts and alligment soft here:


http://home.comcast.net/~safeharborbay/tcr/cbm/1541.html


Pedro.

geoffm3
January 4th, 2010, 12:52 PM
It appears that you've already attempted a realign, which isn't going to work unless you can load some software up on the C-64 to test with (or you have an o-scope). You'll also need an alignment disk. I always just used a mass-produced program disk (like a Q-link disk) to do this. The program I had was a PD program, can't remember what it was called, but you could use a joystick to move the head back and forward in .5 track step increments. The program would read the track ID off of the track and display it, so you could rotate the stepper motor on its mount until it showed the proper track.

So, alignment is not difficult, but you need to be able to load software first.

You might try just swapping chips between the two boards and see if you can get anywhere doing that. Most of the important ones are socketed.

antiquekid3
January 4th, 2010, 01:01 PM
Yup, I have a 'scope. I just don't know where to hook it up and what to look for. I also don't have a mass-produced disk...just a bunch of disks that were either copies or with user programs.

What is the best aligning procedure with a 'scope? A link would be very useful!

Kyle

geoffm3
January 4th, 2010, 01:07 PM
Never done one with an o-scope since I didn't have one back in the day. ;)

But, this appears to be a good writeup of a procedure:

http://sleepingelephant.com/ipw-web/bulletin/bb/viewtopic.php?t=1488

Look at post from eslapion.