View Full Version : External CD-ROM and HP Apollo 715/100

Cube Over
January 21st, 2010, 07:14 AM
Hello Dear Retromaniacs,
this is my post here and I want to be part of your community.
I have started with Apple ][ clone back in 1987 and now I am still using Apple G4 Cube at home.
I am an OSS Architect and so do hardware/software high-level design for living.
That's why I am also very interested of what was done and how it was and who was the persona etc...

I have small collection of old and rare machines:
- SGI Indy with IRIX 6.5
- HP Visualize C180 with HP-UX 10.20
- HP 715/100, 715/80 (HPUX 10-20 but Next Step is 3.3)
- Fujutsu-Siemens with QNX 6.4
- HP Vectra VL with BeOS 4.5
- Apple G4 Cube with MacOS 10.5

I am trying to install NextStep into 715/100 and here's a problem - the machine does not seem to "see" the external SCSI drive.
I have it in a box with all proper connections, and there is external terminator on the box (it does light up!) so there is some issue...
I boot into BCH and issues "search" command as BOOT_ADMIN>
I see two internal hard drives (scsi.6.0, scsi.5.0) and an internal tape drive (scsi.3.0)
The ext. box and drive I am using are known-good because I used those to setup my Indy.
The box has SCSI ID switch so I experimented with the ID as follows:

set to 4 and machine sees only two HD drives (no tape is seen, although tape and extCD have non-conflicting IDs 3 and 4 !)
set to 3 and also I do not see extCD nor tape
set to 2 or 1 or 0 - only three internal devices are seen, when "sea"rching for boot devices, the external CD drive DOES SPIN, although NOT SEEN even as "possible DEVICE"
set to 5, only on scsi.6.0 hard drive is seen (it is the hpux boot drive)
set to 6, nothing is seen
set to 7 (this is the scsi initiator id) nothing is seen

What am I missing? From Service Manual instructions pertaining to SCSI storage setup, I checked that all terminators are removed, and that IDs are really set as they are seen (strange that tape conflicts even with different IDs).
It's been a long time since I used SCSI (back in Powermac 8500 in 1994) so I may have forgotten some trick...

On the CD-ROM inside the box (yes I disassembled it) there are some additional jumpers:
"SECTOR SIZE" - open - hm?
"TERM PWR" - closed - hm?
some others I can't recall

Yes I also tried another drive, pretty CD-RW new one (made in 2001) it also has the same jumpers set the same but ID was 4.
Can any owner of such machines give a clue?

I have got that "press TAB" after Numlock lights up can fix your screen sync issues, thanks to usenet.
I have hand-made that weird HIL 10-pin to PS/2 KBD, PS/2 MOUSE connector myself, at the price of burning one keyboard :)
Then I have found HP AUI-TP transcever, so everything is looking absolutely lovely and ready for the Next Step, so...

What's the catch?

Cube Over
January 22nd, 2010, 12:13 AM
It's amazing. I solved the issue, and NextStep is quickily installing now!
There were 3 conditions to success:
a/ SCSI ID for CD-ROM had to be 2.
b/ on-the-drive TERM jumper had to be removed
c/ on-the-box "big LPT" SCSI terminator had to be present.


January 22nd, 2010, 12:28 PM
Hi, and welcome! I used to have a 715/50 but still have a older 735/100 running HPUX 10.20

So the problem seems to be you had double termination on the external drive.

Not sure if the SCSI ID would have been critical other than avoiding those already assigned. There may be recommendations in the manual which match those that are programmed into the standard BIOS booting commands.

I have no idea what this is: "big LPT" SCSI terminator. Perhaps the built-in machine-side terminator for the external SCSI-2 bus?

The block size jumper for HP is the same 2048 setting as a PC/Mac would use. The other setting (512) is suitable for Sun and SGI.

Does NextStep support your video properly and is it more interesting than HPUX 10.20?

Cube Over
January 22nd, 2010, 01:04 PM
Yes, NextStep supports my video card, audio, network and keyboard.
But the mouse did not work.
Also, I declared a win too early - treacherous SCSI detection stopped working when I put the drive back into cage.
It was working once, and I installed NextStep on alt path, then with non-working mouse had to pull the power cord off.
Next reboot cause some hard drives checking, and that was when NS found HPUX partition on pri path and could not check it, falling into single user mode.
I spent some time fixing mouse, unsuccessfully,
Connected SCSI CDROM back and it was not detected. All the same settings didi not bring me success, which explains why I had hard time getting it right the first time.
I managed to get it seen a couple of times, putting TERM jumper on the drive, issuing SEA and then pulling it off and again SEA,
But booting from CD failed.
BTW I noticed that my internal QUANTUM W32275A drives use some sort of SCSI adapters to adapt internal IDE-like ribbon to D-shaped narrow 50-pin SCSI the same as on the back.
Could they be part of a problem? Which SCSI "option" might interfere with SCSI INIT (or whatever is used when probing for device presence)?
I might need to disassemble the cages and have a look at HDD jumpers, but guesswork will be hard to perform if I dont' know what I should be looking for,
And I'm sure that HP Guide does not list settings for those drives specifically...

January 23rd, 2010, 12:32 AM
I've never installed NextStep on an HP workstation, but I run several systems under different versions of HP-UX with all sorts of SCSI devices. I've got a couple of Jasper boxes I stuff with drives, an Icebox, and standalones.

Terminators only go on the system board (jumpered) and on the last device. Whether you're jumpering in a built-in terminator on a drive or using an external one, as long as it's on the drive at the furthest end of the physical cabling from the system you're OK. No other devices should be terminated. To keep things easy, I usually leave off jumpering on the drive then use either the "Centronics" connector terminators (big silver plastic things, usually) or the white rubber-coated 50 pin high density D-sub terminators, depending on what the last device wants.

If the drive acts odd when you put it in the case, look for something making an electrical connection in there, or a cable being pulled, or whatever.

Many drives I use have adapters inside the box to a different external connector. There are many different standards for SE SCSI cabling, I intermix them freely without problems. Just make sure they're all the same type of SCSI as the controller, e.g. single-ended (the standard on-board controller for these systems), vs. differential vs. wide, wide-fast, etc. (usually add-in boards, though standard on some B and C series.)

As to device number assignments, it doesn't matter so long as there are no conflicts. There are conventions, such as using 3 and 4 for primary hard disks, but it doesn't actually matter so long as you don't have multiple devices with the same number on the same SCSI chain.

Cube Over
January 24th, 2010, 10:40 PM
Anybody aware of the purpose of J6 (three pins jumper) on the motherboard, close to Adaptec AIC-37C65CL chip?
It may be somehow related to a nearby floppy connector, but I secretly hope it's for switching off automatic internal termination.
The service manual says "no external terminator needed" if there's no device connected.
My current theory is that is somehow works incorrectly.
Weird that device spins when I scan the bus - but BIOS finally decides it's unworthy to show up as boot.

Cube Over
January 24th, 2010, 10:58 PM
The CD_ROM works when connecting to internal SCSI segment, in place of DAT drive.
But it's very rare and intermittent when connected to outside segment.
I have proper termination (tried on-the-drive, Centronics passive, Centronics active) and I tried two boxes (one for CD, another for HD) and two CD-ROMS (MATCHITA & YAMAHA), to no avail.
The only part I did not change is the cable. It must be either the cable or the output chips U1, U2 near J5.
But I have another machine (715/80) and I'm going to check it.
If it works then 715/100 has "issues"... if not - then it must be the cable.

January 28th, 2010, 10:54 PM
I hope the 715/100 is OK--those are nice machines.

I've got one not busy at present. Has NextStep been made freely available, or do I have to drum up an old disk?
My mother gave me some software when she was working for Next, but I never got the OS (I expect she thought I had it in my collection of "just about every computer around".)

January 28th, 2010, 10:56 PM
I hope the 715/100 is OK--those are nice machines.

I've got one not busy at present. Has NextStep been made freely available, or do I have to drum up an old disk?
My mother gave me some software when she was working for Next, but I never got the OS (I expect she thought I had it in my collection of "just about every computer around".)

October 5th, 2014, 06:36 PM
Thought I would dig up this old post as I've now got Nextstep 3.3 (for PA-RISC)) running on my 1993-vintage HP 735/100. It took three tries to get it installed due to a problem hanging during boot but it all works now and it truly is the most beautiful Unix desktop of all that I've seen from that era.

Initially it came up in 8-bit monochrome but I was able to configure the display to 8-bit colour - not that dithered colour is much better than smooth greyscales. I've captured a couple of screen shots using the "grab" utility but the TIFFs generated do not open with any of the normal Windows viewers. Anyone know what the deal is there or what I should use for conversions?

I still have to apply the Y2K patch as it does not accept dates past 1999.