View Full Version : Softdisk monthly software collection - killed 2 motherboards

July 14th, 2005, 08:14 PM
I would not believe it if I did not see for myself. I was testing an unmodified Apple ][e that was working fine. I attempted to load a diskette called Softdisk monthly software collection for Apple II+, IIe, IIc, IIgs Issue 78.

My screen suddenly went haywire. see picture:
http://www.vintagecomputer.net/apple/appleIIe_rev1/symptom_ram_problem.jpg (At the time I thought that this might be some kind of ram problem hence the file name)

I figured oh well...and I found a new motherboard.

Installed Tested, worked.

THEN I ran that damn disk again. The exact same thing happened. Now I have two identically-stricken motherboards. Same exact screen/result.

I plan to burn this diskette.

Anyone experienced this kind of thing before? I assume that there is no fix and the boards are dead, but I am not an Apple expert. At first I thought it was a RAM failure not related to the disk, but after destroying the 2nd motherboard I am convinced it was the software. Fortunately I took pictures to confirm.

Crazy, huh?

July 16th, 2005, 10:10 AM
I never, never heard of any Apple II software destroying hardware. 2 motherboards ? I would have thought it would taken out the disk controler or the drive itself. I have heard of the flat ribbon cables going bad and taking out hardware. But never a software. I would have tried a different drive. A semi bad cable might do the same thing. That is good one moment and another it is bad.

Was the disk hard to turn in its jacket? Can you rotate the floppy material to see if there is something more that magnetic material in the floppy?

I would test each chip in a known good mother board. It has to be a chipp. I think I have a IIe repair manual somewhere. Have not seen it YEARS.

Softdisk was not copyprotected, should have not did what it did. Something else might cause this to look like stranage happening at the same time. What are the Odds?

Maybe some one else will reply. You might want to post this to an apple II news group. Just search the google for the Apple II newsgroups.

Keep us in formed.

Take Care,

July 16th, 2005, 11:03 AM
Note - I tried multiple drives and cables. Makes no difference.

July 16th, 2005, 11:40 AM
Stranger yet. I have heard of some code telling the disk drive/ HD/ read write head to keep trying to get a track that does not exit. There by smashing itself out of wack. But nothing that attacks the motherboard. Are you sure the disk turns freely in the sleeve?

I would post this on the Apple II news groups. I am sure they would be interested.

Take Care,

Terry Yager
July 16th, 2005, 12:29 PM
I dunno if this applies to the 6502 or not, but since it is a clone of the 6800, it might.
There is supposedly an undocumented opcode for the 6800 which can cause physical harm to the hardware. The "Halt & Catch Fire" (HCF) command toggles the bus (on<->off, 1<->0) at the full speed of the CPU, which causes the bus lines to heat up from "bus contention" to the point where they can actually burn out.




See also: "Killer Poke"



July 16th, 2005, 03:53 PM
A couple of observations:

1) The screen posted is simply an uninitialized text screen. This is normal if the normal Apple //e "cold reset" routine has not run.

2) Seeking an Apple disk drive by any amount, in or out, cannot damage either the drive or the computer. In fact, the normal boot process seeks the head back well past track 0--that's the "clunking" noise made by all Apple II's when booting.

Now, with regard to the possibility of a program causing physical damage to an Apple //e--yes, it is possible, but very unlikely. The mechanism by which damage could occur is a prolonged "bus fight" in which two or more circuits simultaneously drive a bus wire or wires to different logical states.

The Apple II machines do not decode R/W for accesses to ROM or to the "input" I/O addresses. As a result, writes to these addresses can result in bus fights as the processor writes data at the same time that the addressed device presents data for reading. Typically, these are a cycle or two in duration and result in either no effect or a transient logical malfunction due to a current spike during the fight. It is quite unusual for a fight to result in permanent damage to one or more chips. (Usually the two chips driving the bus wire(s) in opposite directions are undamaged, but damage is possible.)

It would be very interesting to see an disk image of this disk, to try to identify the code that may be causing the problem. Since this is a widely distributed disk, it is amazing that it has caused problems for two of your boards, but apparently, for no one else...

Terry Yager
July 16th, 2005, 05:17 PM
Really, don't destroy the disk. Save it for analysis by someone with the knowledge to figure out what is going on with it (do I hear anyone volunteering, michael?).
How did you come by the disk in the first place? It was probably not distributed by Softdisk with destructive code, but modified somewhere along the line. I'll have to look and see if I have that disk, and set up an Apple ][ for testing purposes (I have a few available, so sacrificing one won't be a problem). Do you know what program(s) are supposed to be on it? I have a couple of Apple shareware libraries here too, so I'll see what I can find for byte-by-byte comparison purposes. BTW, if you need another mainboard to replace the busted ones, I have some.


July 16th, 2005, 06:11 PM
Comparing this disk with another original would be a very interesting experiment.

Converting it to a disk image would be useful, too, since it could be run on an emulator to safely inspect it for "unusual" code.

July 17th, 2005, 04:44 AM
Thanks for your replies. To add a bit of information to the sequence of events:

1. load other disks fine, run programs fine. for example the apple ][e introduction disk

2. insert the Softdisk monthly software collection disk. The disk is read for all of one second, the screen goes haywire as illustrated by the pic link I listed in my earlier post.

3. cold boot the computer and it's now permanently down, does not attempt a disk access, etc.

4. I got a new motherboard, and repeated the process. Same results.

If anyone wants this disk, please contact me off board and I will mail it to you promptly. You can have it!

July 23rd, 2005, 04:12 AM
Also, the rumoured HCF instruction is not present in the 6502 repertoaire.