PDA

View Full Version : Weird IBM 5160 Problems



Raven
April 28th, 2010, 04:39 PM
I just got an IBM 5160, and it's awesome. It's having some trouble, though.

When I first got it, it was tossing errors about missing command interpreter. I set the DIP switches to what they should be for two floppy drives, VGA, etc., and now it boots up to the HDD just fine. However, it boots up to a D prompt instead of C, and if I try to run DIR on C it throws a seek error. FDISK reports that only one partition, C:, exists. Meanwhile it's throwing a 601 (FDC) error every boot, even though I set the switches for two floppy drives (it has a 360k and a 720k) and both drives work fine.

Anybody got any ideas?

lutiana
April 28th, 2010, 04:47 PM
What kind of drive it is? MFM?

You could try and do a low level format to prep the drive then re-partition it and see if the issue goes away. If it does not then you might have a hardware issue.

Raven
April 28th, 2010, 04:49 PM
It's an MFM drive, yes - full-height 20MB IBM.

The previous owner (Chromedome45) says that it didn't have these problems when it left, but I did reconfigure the DIP switches since then (which fixed other problems).

lutiana
April 28th, 2010, 04:54 PM
A seek error could be a software failure or a hardware failure, so low level formatting it, re-partitioning it and high level formatting it would pretty much rule out software as an issue.

I had some similar problems with a 5160 I bought, one of two things fixed it. Either re-seating the cables on the back of the drive or hitting it on the top with the back end of a screw driver. I am honestly not sure which one did the trick, but the thing worked flawlessly after that.

I'd recommend the re-seating the cables and only hitting it as a last resort though.

Chuck(G)
April 28th, 2010, 04:55 PM
Review your switch settings carefully. The 5160 allows for 4 floppy drives--and since it doesn't have a CMOS setup, it takes the switches as the gospel truth.

Raven
April 28th, 2010, 05:02 PM
Can anybody confirm that this switch chart is correct?
http://www.howard81.co.uk/upload/vcf/xt/xtdips.gif

My floppy switches are, according to that switch, set to 2 drives - 7/8 set to 0/1.

I am curious, since I've never worked with a machine that supported 4 FDDs, if the 601 error might be related to the problem where C: seems to lead nowhere? I.e., if it thinks there are three floppy drives?

Edit: Perhaps I'm a dip-switch-idiot and have been flipping them the wrong way.. The red DOT is the side it's flipped TO, right? Or do I have it backwards.. If I have it backwards, then that explains some things.

vwestlife
April 28th, 2010, 05:07 PM
Note that if a PC or XT motherboard is set for more than two floppy drives, even if those extra floppy drives don't actually exist, the first hard drive will appear as letter D or E.

I found this out when my dad and I were installing a hard drive in his IBM Portable PC. He had owned it since new and up until then it was untouched inside, except to expand the RAM to 640K. When we first set it up, it worked, but the hard drive was showing up in DOS as the E: drive! Turns out, the motherboard came from the factory with the DIP switches set to four floppy drives. Prior to installing the hard drive we never noticed that, because we never had a reason to try typing in C: or D: at the DOS prompt on a dual-floppy-only machine.

Chuck(G)
April 28th, 2010, 05:13 PM
I've got a hunch--swich the settings of 7 and 8--if you think you have it set for 01, set it for 10 and see what happens.

Raven
April 28th, 2010, 05:15 PM
Solved thanks to a combination of my conjecture confirmed by vwestlife.

Apparently I had which way to flip these dipswitches backwards, and it was causing both the 601 and the mislettering.

I can only guess now as to why it had issues when it got here, and my best one would be that one of the switches was partially flipped, screwing up the machine in more than one way.

Anywho, VICTORY! :D

lutiana
April 28th, 2010, 05:36 PM
Raven, check out our Wiki on the 5160, it has tons of info.

http://wiki.vintage-computer.com/index.php/IBM_PC_XT_(5160)