PDA

View Full Version : Osborne Executive



Raven
May 19th, 2010, 03:33 PM
My friend has just acquired one of these, if I understand correctly, very rare machines.

It's a demonstration model according to the man who owned it. He also informed my friend that it had OS/2 2.x and Windows 3.x on it though, so who knows if he has any idea what he's talking about.

Anyway, they turned it on and blew a capacitor or fuse or something (I didn't get the chance to tell them that was a bad idea before looking inside) but my friend is an electronics guy so he should be able to sort that out. After fixing the screen (which is what isn't working after that fiasco) we'll go about restoring the machine.

I've never used CP/M or any Z80 computers (and my friend has far less vintage computing experience than me, so he certainly hasn't), so I thought I should let you guys know what's going on with this so that you can help us out if there's anything we need to know.

Lord Moz
May 19th, 2010, 04:54 PM
It's a demonstration model according to the man who owned it. He also informed my friend that it had OS/2 2.x and Windows 3.x on it though, so who knows if he has any idea what he's talking about.

I wasn't aware of any Z80 ports of OS/2 or Windows... ;)

Perhaps he has a 386+ upgrade card (which I've also never heard of) in the thing... :lol:

It's amusing dealing with some "computer people."

The Executive is an interesting machine. Never owned/used one, but often thought it'd be nice to have. I had an Osborne 1 eons ago, but it only had 1 working floppy drive, so was mostly useless, and my dad scrapped the thing for its little 5" B&W CRT.

Good luck on your friend's restoration.
__
Trevor