PDA

View Full Version : Into the dark side



wmmullaney
July 30th, 2010, 01:25 PM
I just recently bought a couple VGA cards for my 286-12 and 386 computers from a recent haul. I'v never really worked on anything past a 486, so this is all new to me.

Anyway, I put a card in the 286. It came right up, 640kb base 384kb extended memory OK, both interrupt controllers pass. Then it gives a MEMORY SIZE ERROR, RUN SETUP and a DISKETTE DRIVE MISMATCH. PRESS F1 TO CONTINUE OR CTL+ALT+DLT FOR SETUP

Setup gives very few options, has drive numbers for the mfm drive, and sizes for the floppies. I put a 3.5" drive in it and configured it as drive 1, 1.4mb. It spun on startup but gave to same error. F1 gives a replace boot media, press enter error, but the drive is unresponsive.. Tried that with 2 different controllers. I don't have a 5.25" dos disk atm, so I wouldn't know if that drive would work. Any ideas/suggestion?

It's a SAMSUNG S550


Thanks!

Chuck(G)
July 30th, 2010, 01:47 PM
An SD550 mayble (http://www.artofhacking.com/th99/m/S-T/33307.htm) If so, how's your battery?

wmmullaney
July 30th, 2010, 05:10 PM
I think that's it, all the jumpers are configured correctly

It was dead, thanks for the suggestion ;) replaced with a new one. Now it holds BIOS changes, and no longer reports the memory error. It is still whining about the floppy drive. Here is a screen shot:


EDIT: Link didn't work, its here

http://picasaweb.google.com/wmmullaney/Misc#5499870820843549890

Agent Orange
July 30th, 2010, 05:15 PM
wmmullaney:

Check to see if your BIOS supports SWAP FLOPPY A<>B. A simple toggle may fix that.

wmmullaney
July 30th, 2010, 05:24 PM
Hey AO,
The BIOS seems very rudimentary, the only option remotely related to the floppy is just the select (720, 1.2, 1.4, 360)

Thanks

Chuck(G)
July 30th, 2010, 06:42 PM
What brand.model of floppy are you using? If you peek at the floppy during boot, does it do a seek?

NathanAllan
July 30th, 2010, 07:39 PM
Also see if the fdd is plugged in right-- it can happen to anybody especially if it doesn't have the plastic guide around the pins. But I think that error is because it isn't jumpered right (either on the drive or the motherboard).

But if it worked before, check and see if each setting will work that apply to your drive (720 or 1.4).

Nathan

wmmullaney
July 31st, 2010, 05:24 AM
The drive that came with the machine is an EPSON SMD-300. The other drive looked generic. On power up, it does a seek, and the light comes on before it reports the error.

Pin 0 is labeled clearly on the drive and card, so it is connected the right way. I don't see any jumpers on the drive, and this is the controller card I tried: (the other is also an mfm, I haven't taken the HD out to figure out it's number)

6624UG (http://stason.org/TULARC/pc/hard-disk-floppy-controllers/U-Z/UNIDENTIFIED-Two-IDE-AT-Interface-drives-6624UG-SU.html)

(I think I have a couple more controllers if that's an issue.)

All JP1-9 are on pin 1-2, and the Jx1-4 do not have a switchbank soldered in. (I can remedy that if necessary)

All this is really new to me, thanks for the patience and help ;)


Have a great day

Chuck(G)
July 31st, 2010, 08:09 AM
We really need to ID your motherboard if it's not an SD550. If it is, note that you already have a floppy controller onboard. You'll need to set motherboard JP12 open if you want to use the multi-I/O card--or disable the controller on the multi-I/O and connect your floppies to the motherboard. Your poison.

wmmullaney
July 31st, 2010, 11:03 AM
It is, thanks for the help, Chuck! Apparently some idiot put jumpers in the onboard controller, so I overlooked it. Removed that plug, now both the 3.5" and 5.25" floppies work great on the mfm card (with j20 removed). The mfm hd booted fine into something called SPEED only for TURBO COMPUTERS. It had some games, nfl, weel of fortune and solitaire. HD is 20mb ST 225.

Again, thanks for all the help! Computer fixed

Chuck(G)
July 31st, 2010, 12:17 PM
Beer? :)