View Full Version : Compiling BYE

August 1st, 2010, 08:49 AM
Since I have some working drives now, I've been playing getting the heath bbs online.

Since this is way over my head, I was wondering if some one might be able to help.

I've got BYE520 from http://z80cpu.eu/mirrors/oak.oakland.edu/cpm/bye5/.

I can compile it in m80/l80 and run just fine, until I insert The code from.b5h8-2.iqs into the .ASM file, where they tell you to put your custom IO code. (I did unsqueeze the b5h8-2.iqs). B5h8-2 is said to be the IO module for the H89.


It will compile ok, but kills the heath when I run it.

I am compiling the software in myZ80 cp/m emulator on the PC, because the file is too big for the tiny drives on the heath.

I know this is ancient tech, and no one uses BBSs much anymore. :confused:

August 1st, 2010, 06:11 PM
I'm very interested where you are taking this. Only wish I could help more as you are a couple of steps ahead of me now!
That link had lots of files - which one is the one you are using and what is the extra code you are adding?
Debugging asm can be fun - I tend to use either a little routine to print a character on the screen, just to show it got to a certain place.
Can you just clarify the M80 code - you have control C. That doesn't sound right. M80 should return to the A> prompt when it finishes. Though it can take a while. I was recompiling MPM over the weekend with M80 and it is over two minutes.

August 1st, 2010, 07:02 PM
You should definitely not Control-C out of M80...assembling large programs can take a good bit of time, especially on slower systems. I assembled something-or-other on my Kaypro II the other day that took over 5 minutes (probably a piece of terminal software). Of course, this may not really matter if you're doing it in an emulator. Still, if you're Control-C'ing out of M80, it's probably not finished.

August 1st, 2010, 08:21 PM
I grabbed the file bye520.lbr, then un-lbr'd it, and un-crunched it (as the extracted files are .?Z?). QBBS, which I would like to try requires bye 5.08 as a minimum.

The addition file is an .ins (insert) file, that controls the machine specific IO.

It does not return me to the a> prompt.


it returns me to a * prompt, after reporting the # of fatal errors, and leaving a .REL and .PRN files behind.

The files are then linked with l80. And if I don't touch the original BYE520.ASM, it will compile/run ok. Displaying a "BYE 5.2 1986 ... xxxxxxxxx.COM not found".

If I add the text in the .ins file to BYE520.ASM, it will still compile right.. but crashes both myZ80 emulator, and the heath.

The next step, will be to add sections one at a time, until i cause it to crash.

This way so I will know what the offending data is..


August 1st, 2010, 09:45 PM
Re "it returns me to a * prompt, after reporting the # of fatal errors, and leaving a .REL and .PRN files behind."

There is not really any point in running L80 until M80 has compiled with no errors.

Any clues with the errors - which line, what are they etc?

Is it possible to attach a file to the forum - if so can you attach the source?

Actually, isn't M80 for .mac files? I wrote some notes to myself a while back about which assembler to use with which program. Unfortunately, stuck at work here for another 9 hours. About half the files in the archive are .asm and half .mac and while it is possible to manually change one to the other, it is very tedious. Subtle things like .equ vs equ

August 2nd, 2010, 02:28 AM
Hi! I seem to recall Rich Cini had the BYE CP/M BBS software running on his N8VEM system a while back. You might want to check the N8VEM mailing list archives as to how he did it. As I recall, he had to change some IO port settings to use the serial port and eventually got it working on the internet for worldwide access. It was pretty neat but I don't know if it is still working or not.

Thanks and have a nice day!

Andrew Lynch

August 2nd, 2010, 11:24 AM
This is what I see when I compile BYE. I attached the .asm file in the zip. According to the header:

; to adapt this program to various computers, clocks and modems. It
; may be assembled with ASM, LASM, MAC, RMAC, SLRMAC or M80. If the

I am going to try disable any of the BBS related, and see if I can just get to the terminal. Start small, and work my way up.



No Fatal error(s)


Link-80 3.44 09-Dec-81 Copyright (c) 1981 Microsoft


Data 0100 12D7 < 4567>

44899 Bytes Free
[0000 12D7 18]


August 2nd, 2010, 06:24 PM
Ok that compiles for me too. When I run it I get "minutes on system 81, DISPATCH.COM not found, abort". So I guess need that program and/or its source?

August 4th, 2010, 05:58 AM
I got that version to compile as well, and run on the heath.. wonder what I changed.. I've rebuilt that .ASM file so many times in the last week, who knows.

But BYE E will run, and try to connect to Qstart.com. BYE on its own stops, and I assume, is waiting for the appropriate response from the "modem"..

Not sure if I have an old external modem floating around to see if its talking or not..

August 5th, 2010, 06:02 AM
Had a little success with BYE last night. Turned off all of the bbs routines, and got it to start up, and send an init string to the lantronics.

Because the lantronics does 2 wierd things, I need to adjust BYE to work with it..

Telnet in, It sends:

But BYE registers it as a voice call. I think its looking for CONNECT 300, CONNECT 1200, CONNECT 2400. I think I need to MOD it to look for just CONNECT (and set the baud rate to 2400).

August 6th, 2010, 08:00 PM

I was able to modify BYE, and match a setup with my lantronix uds-10.

Had to remove alot of old modem code, especially around the auto answer routine..

But, I'm able to telnet into my heath box, and run cpm commands from there!

If any one is interested, I can post my modified BYE that works with the lantronix.

Now, going to see if my port forwarding is working through the interweb.. If it is, I'll post the address, and see if any one can play on the machine..

Telnet to: thecave.endoftheinternet.org , port 23

Its only 2400 baud, so be gentle.

Edit: Seen a couple people online..

There isn't alot to do on the machine right now..

Basic CPM system commands..

Mbasic is on drive a:
CPM system is on b:

Really can't hurt anything..