View Full Version : Osborne, Kaypro machines found - assistance needed!

August 11th, 2010, 06:35 AM

I just had a great find yesterday on Craigslist: an Osborne 1a, Kaypro 4/83+88 and many boxes of software, manuals, newsletters, magazines and more.

I'm new to CP/M machines, especially the Osborne. The Kaypro's working nicely so far, other than some disk drive issues that I plan on fixing.

But O-1a is still not booting. It asks for the boot disk but then only says "BOOT ERROR" over and over again. It appears this is a common issue. The A: drive seems to spin up but it never reads the disk. To be honest, I'm not even sure if I have the proper disk to boot it with, since the software I got was almost all for the Kaypro and possibly a Heathkit Zenith H89. It has the double density upgrade installed.

Is there somewhere I can find a boot disk to download? I see the ones on Dave's page for the 1, I assume they'll be fine on my 1a. Just want to make sure it's not my drive and not the wrong disk. I've tried writing them with IMD on an MS-DOS 386 machine, but all I get are write/sector errors. I really have no idea what settings these disks need for the Osborne. All I get is "Write error <1> No sector"

Also, I've heard there's a key to press for swapping A: and B:, thought it was Shift but I've tried holding Shift on startup or pressing it later and it does nothing.

Here's a video of all the stuff that came in the lot, if anyone wants any more info let me know. Looks like there could be some uncommon things in here:

CP/M Craigslist Haul (http://www.youtube.com/watch?v=oLnTAYMMLOc)

Thanks so much for any help you all might provide!

August 11th, 2010, 01:00 PM
IMD is pretty good. Are you trying to write in a 1.2 MB drive or a 360k one? The latter worked well with my Kaypro. I've never made Osborne disks though.


August 11th, 2010, 05:07 PM
Only had a chance to write with a 1.2MB drive. Got a bit overwhelmed by all the settings just to even get a basic write started, had no idea what kind of disk settings to use, have yet to get back home and try on my IBM 5150's 360k drives.

August 11th, 2010, 05:53 PM

Also, I've heard there's a key to press for swapping A: and B:, thought it was Shift but I've tried holding Shift on startup or pressing it later and it does nothing.

Try Shift P

If that doesn't work, try SHIFT ' (ie: the ' below the double quote marks which would be SHIFT ").

PM me if you like, and I'll pop a good boot disk in the post.
I can also send you a disk drive diagnostic program for the Osborne - at least you'll be able to do some read/write tests on the drives, once you get it booting.

You didnl't happen to get a Drive C or any disks labelled Drive C in the batch of stuff you got, did you?

August 11th, 2010, 06:05 PM
I'll be trying the 360k drives here soon to see if I have any better luck that way.

Thanks for the tips, and for the offer Lorne, PM sent! I'll be looking for a Drive C disk as well, there are hundreds I have yet to even look at.

August 11th, 2010, 06:36 PM
If those two tricks don't work, there's something by either sharkonwheels or chuckcmagee that I'd read before that tells exactly how to switch the drives.

I printed it for future use, but can't find the damn thing now.

September 15th, 2010, 04:01 AM
Just to set the record straight, it's SHIFT " at boot up, and it was Billdeg who wrote about it.