View Full Version : ND-Satellite/9 - how to test it?

October 24th, 2010, 03:10 PM
I recently got (http://www.vintage-computer.com/vcforum/showthread.php?22472-Friday-haul-ND-computer-with-terminals) a Norsk Data (http://en.wikipedia.org/wiki/Norsk_Data) ND-Satellite/9 computer. This is a machine from the NORD-100 (http://en.wikipedia.org/wiki/NORD-100) series. However, the hard drive (winchester, 21 MB) doesn't want to play nice. So, does anyone have any experience in testing NORD-100 computers?
My ND-Satellite/9 notes (http://sites.google.com/site/tingox/nd_900-135) page show all the things I have tried so far.

October 27th, 2010, 02:15 PM
Ok, with the help of a few very experienced people I have now performed a very basic test of the machine. Luckily, I had a set of floppies with "Test Programs for ND-100" (ND-10523D). In my case, this is a set of four 8 inch floppies. I was looking for the program "config".

I inserted the floppy, did a MACL + ENTER (MACL is master clear, it resets the cpu and all devices). Then I loaded the floppy (actually, the monitor) with 1560& (no ENTER here, it just tells the machine to start loading from device 1560, which is the floppy drive). The the (floppy) monitor prompt showed up, a'*'. However, trying config + ENTER just got med "no such file". But the monitor has a list-files command, so the it was just a matter of listing the files on the floppy, swapping to the next floppy, listing files and so on. I found the file configuration-c:bpun on floppy number two of four.

With that in the drive, it was just a matter of writing config + ENTER, then the config prompt showed up '>'. After that I could use RUN to test the machine. With the exception of one v.24 / current loop interface (terminal interface 6, device number 350) everything looks ok.

I will do more testing later, including testing the winchester hard drive.

October 28th, 2010, 01:48 AM
Cool! If I had a floppy like that I could test my own ND-110/CX. Well, I have a 5.25" floppy drive. And I would have to drag it out of storage :)

October 28th, 2010, 12:37 PM
Unfortunately, I have only 8 inch floppies, so I can't help you there.

This evening, I did some more tests. For each program, I started out with the familiar sequence MACL + ENTER, 1560&, then loaded the program from floppy, and did a "RUN" command in the program. If the program has looping tests ("the tests are now looping") I aborted it with the ESCape key.

INSTR (instruction-b:bpun) - tests the cpu instructions - result: ok.
MEMORY (memory-c:bpun) - tests the memory - result: ok.
PAGING (paging-b:bpun) - tests paging - result: ok.
CACHE (cache-2063d:bpun) - tests the cache. When this program started up, it wrote: "This is a NORD-100. Physical examine cannot be done during this program!". result - all tests failed (15 errors). However, the config program that I ran yesterday printed out the computer configuration, and in there it said "cache: NO". I have asked the person who know this if this machine has any cache or not. We will see.
Update: it is now confirmed - this machine doesn't have cache. All is well.

More tests (FLOPPY and DISC (aka winchester hard drive)) when I have learned how to do those tests without destroying contents on the disk or floppy. :)

December 1st, 2010, 11:55 AM
Two nights ago, I found some time to do more testing of the ND-Satellite/9 machine. First I opened up the machine, in order to verify exactly which hard drive I had in there. This included disconnecting the hard drive connectors (which I had done before) and physically removing it from the machine so that I could read the labels etc. In short, the drive is a CDC 9410-24 Finch IV drive, using a "SMD" interface, with a capacity of 24 Mbyte.

On to the testing. I inserted the floppy with the DISC-TEMA program, did the familiar

DISC-TEMA to load the program. After loading, the program asked for the name of the disc. Using the HELP command gave me a list of possible names. The most likely candidates were

Using the trial-and-error method, It tried this sequence:
DISC-23MB-1 which gave the error message
The controller does not correspond with the specified disc-type.
DISC-21MB-2 gave me
No such Device. 1)
but DISC-21MB-1 got me this

Data way to disc system 1 tested.
Memory address register on disc system 1 tested.
Memory buffers initialized.
Cool! (The ">" is the program prompt). The local ND expert had told me that the only safe command to use is PARITY (actually PARITY-CHECK), because it only reads from the disc.
After issuing the PARITY command, it asks for a unit number (0-1), so I tried unit 0 (zero). The command went on for a while, the console beeped, and I got the prompt back. No messages or anything. Is that all? So I tried PARITY with unit 1, and got loads of error messages. I had to use the Escape key to abort the test. Ok, so that probably means that the hard drive is ok. Well, then, only one thing to do: try to boot from the hard drive! Here goes:

which tries to load the system from the hard drive. after a while the system printed this:

*** 00.01.14 TERMINAL 670:
(this is just the start of the output). Wohoo! The machine lives!