PDA

View Full Version : Monroe cp/m disk format



leaknoil
December 20th, 2010, 06:09 PM
I am trying to figure out a way to copy the very few Monroe disks I have. I want to put them online on Dave's site.

This is for the Monroe OC8820

I have tried both Imagedisk and Copy II pc and everything fails. At least with default settings. There is only one index hole and I don't think there is anything special about the media.

Searching around online the only reference I can find is for some program called 22disk that converted cp/m formats. It had a entry for what it calls the Monroe 8800 series. Anything look out of the ordinary below ? I am trying to copy a known good boot disk. I have tested after a couple of tries at copying and it still works. It is starting to show wear on the surface though. I'm getting scared to keep beating on it and had to clean the drives heads.

BEGIN MON1 Monroe 8800 Series - SSDD 96 tpi 5.25"
DENSITY MFM,LOW
CYLINDERS 80
SIDES 1
SECTORS 16,256
SIDE1 0 1,5,9,13,2,6,10,14,3,7,11,15,4,8,12,16
BSH 4 BLM 15 EXM 1 DSM 153 DRM 63 AL0 080H AL1 0 OFS 3
END

Chuck(G)
December 20th, 2010, 06:22 PM
Hmmm, 22Disk? Just what sort of jerk would write a dog like that?

You're dealing with a 96tpi 250Kbps (quad density) disk, with sector numbers from 0-15 on one side only. You should be able to use DiskImage on a 1.2MB drive to read this (note that this will require a 300Kbps data rate, not 250Kbps). Alternatively, you can use a 5.25" DSQD drive such as a Teac 55F and declare it to be a 720K 3.5" drive and read it with 250Kbps.

I probably still have the sample floppy that the above definition was derived from.

leaknoil
December 20th, 2010, 07:07 PM
Ahh its all your fault then. Well not really.

There is another thing though I just thought of. They offered both cp/m and something called MS8 for these. I wonder if they used different formatting. I only have a couple MS8 disks.

I think the problem is I can't find a drive controller combination out of all my drives that will write 300kbs DD. I've tried a few now. It looks like it reads fine I just can't write it.

I have three different FDC and 5 different 1.2mb drives and can't seem to find any combination that will handle 300kbs DD. Is it rare they support it ? I am trying to find the one fdc card that used to always seem to come through with imagedisk but, I can't find it.

After reading your post I tried a couple claimed as 720mb 3.5" and they fail to write 250.

Chuck(G)
December 20th, 2010, 07:24 PM
Are you using 2D (double-density) 5.25" disks and not HD (high-density)? Even though the format is an 80-cylinder one, it's still double-density.

leaknoil
December 20th, 2010, 07:54 PM
Yep. DSDD.

I just found my 'magic' FDC and its able to pass the 300k DD write test now. Its some random PoS clone thing from the 90's. Not sure why it works and nothing else does but, it does.

Still all is not well. Imagedisk gets nothing but, errors after cylinder 40 of 80. The drive makes an odd metallic click too reading after 40 at 300k. The copies don't boot so far either. I'm using 1:1 interleave. Should I raise that ?

Reading imagedisk throws out no errors until it hits cylinder 40. Writing it throws out no errors at all but, does make the click after 40. Slightly different though then the read.

Chuck(G)
December 20th, 2010, 08:08 PM
Do you have double-stepping disabled on the Imagedisk menu? It sounds as if you don't and you're trying to step past (physical) cylinder 80.

leaknoil
December 20th, 2010, 08:53 PM
I didthe read letting imagedisk do a full analysis and that what it defaulted to. I just tried a read out with it set to single space and it got past the 40 track thing fine. Unfortunately still no go. Won't boot off the copy. I can hear it make a couple reads then nothing. Original still boots.

On a related note I just got, two minutes ago, an email from a guy in Sweden that says these were "LUXOR ABC80/ABC800 " clones or they were the clones of this. It's hard to tell. It was a paragraph of all caps and a little hard to follow.

Here how I have imagedisk set:

Cylinders: 80
Sides: 1
Double Step: off
r/w gap: As Calculated
Format Gap: As Calculated
Format Fill: E5
Full Analysis: Yes
Interleave: As Read
Retries: 5
500 -> 500
300 -> 300
250 -> 250


edit: ok I looked up the Luxor stuff and I guess it could be somehow related but, they are totally different things. The colors share a lot in common and are unusual. I wonder how they are related.

Chuck(G)
December 20th, 2010, 09:08 PM
Well, to find out what's going wrong with your copy, I'd have to dig mine out. Not tonight, however.

While you're at it, run AnaDisk in scan mode on the original and see what it reports as being evil.

leaknoil
December 20th, 2010, 09:19 PM
I wouldn't even ask you to go digging for a disk tonight. I just thought I'd see if anything rang a bell. If you do think of anything let me know. I only have a couple working boot disks and they ain't getting any younger. I feel bad beating on them like this actually. Copy II pc is a mfm read deal and ran the poor disk for 20 minutes at least a couple of times. It still didn't work. It may be I just don't have a floppy drive that can write this format.

leaknoil
December 21st, 2010, 11:11 AM
OK, I got it working. Just had to try a fourth floppy drive. I still can't figure out how to use MS8 but, at least I'm not so worried about trashing the original disks trying.

I just can't figure out how to list the second floppy drive. There is just zero info out there about MS8.

Johnlester875
June 13th, 2011, 12:06 PM
MS8 i
MS8 is a modified version of Microsoft MSDOS 2.0/3.0 with Identifiers FPY0,FPY1,FPY2, HDK0,HDK1.
to format a floppy is format FPY0:/s
to copy one floppy to another is copy fpyo:, fpy1:
the printer port was lpt1 and the com port was com0 or com1
hope this helps
johnlester