View Full Version : RA82 spinup troubles

February 4th, 2011, 05:54 PM
So I located a circuit in the house which is used the least and plugged the drive in. Flipped the breaker and was greeted by fans spinning up and no nasty noises or magic smoke. Good. :)
Next I took a piece of wire and jumpered the 6 o-clock and 9 o-clock pins together in the SEQ IN port so it would be allowed to spin up, unlocked the heads, and started the spinup.
The lights in the house dimmed, the motor and drive started to spin up, but then it kicks out and lights the fault lamp.
Hmm, okay. So either something is wrong or the motor is overloading. I'm not quite sure.
Tried two more times, same deal.
I checked waht a single fault light meant according to this (http://www.pdp-11.nl/peripherals/disk/ra81-info.html) and there is nothing attributed to just the fault lamp. I can't check the bulbs either. I don't know how to remove them.
Huh. Bizarre, and worrying. :/

Lou - N2MIY
February 5th, 2011, 04:46 AM
I suppose the first thing that could help us is if you took a video with sound, with the hood up of the spinup process. Start with the fans running, before pressing run. Then announce and press run, let us hear the sounds, and in particular how long the motor runs until the fault comes. That delay time can be helpful in determining the problem.

There is a belt that runs from the motor to the HDA. Does the disk indeed start to spin up? That belt can be tensioned and maybe the tension needs to be adjusted (belt slipping and disk not coming up to speed fast enough). Belt adjustment is covered in the RA81 service manual on bitsavers. I'm pretty sure that this is the same across RA80/82/82.

Also, the disk motor is a capacitor start motor. In the RA80, the capacitor was not switched by a mechanical centrifugal switch (as with most machine tool motors), it was controlled by the drive controller. Ultimately, the spin-up problem in my RA80 was a bad output pin on an I/O expander that drove the drivers that closed the start capacitor relay. I highly doubt that anyone else would have this problem, but I just mention the capacitor start so that you know to listen for the start capacitor relay to cut out.

The RA82 should have some pretty advanced diagnostics. The RA80 has on board lights and switches and EXTENSIVE interactive on-board diagnostics. ISTR that RA81 and RA82 have a port to connect a 300 baud RS232 terminal so that you can interact with the drive controller directly. The DB25 connector may be up by the motor start capacitor on the right side of the controller when facing the drive from the front.

Get the RA81 service manual (EK-0RA81-SV-001) from bitsavers and look at chapter 4.

The manual will also tell you how to service the lamps. I use needle nose pliers to carefully grab the glass envelope and slide them out, but I think the right tool is actually a piece of rubber tubing. Jameco still sells the bulbs.


February 6th, 2011, 07:53 AM
I gave up trying to get my RA82 to do anything. I couldn't even get anything from the diagnostic serial port. It would be nice to see it spin up and in operation at least once, but the reality is even if it worked I probably would almost never use it.

If you can't get anywhere getting your RA82 up and running you might have an easier time getting your 11/84 UDA50 up and running with an RA70. I'll have to see if I have any working RA70 drives I could spare. I connected one to a 4000-700A and spun it up last night just for fun.


Lou - N2MIY
February 6th, 2011, 09:25 AM
I wish I lived a little closer to you guys to help you out with the troubleshooting / repairs of your drives. I really enjoy the repair aspect. Most of what I get is broken and so since my expectations are low to start with, I'm usually not disappointed.

Glenn, if very little is working, I would suspect a power supply problem on your RA8x drive.

All that said, the RA7x drives are compact and seem pretty reliable. I have an RA72 on an 11/73 that works fine.


February 6th, 2011, 10:34 AM
Because of no sound insulation, I can't run the drive when I get home from work because by then it's quite late.
I'll try and get the video up this afternoon after the laundry has finished.
I'm hopeful that the this isn't too big of an issue as it seems like the drive was very recently pulled out of active service and has not even had a month yet to sit in storage. I'm assuming it's just very cranky.

February 6th, 2011, 03:57 PM
The video just got thrown up on Youtube.


I'm hoping you can hear the motor trying to spin up. I can't use my microphone as my roommates seem to always be either watching TV, doing stuff on youtube, or playing music all day long.
Anyways, that aside, here you go for a quick in-a-nutshell video.

February 6th, 2011, 07:27 PM
I did not hear the telltale sounds of a disk spinning up. It's a very distinctive sound, as I had an RA80 (or was it an RA81)
that Lou now has. It might normally take 20 seconds or so to fully come up to speed, so the fault light going on after just
a few seconds implies something is wrong. I don't know enough about these old drives to say much more. Hopefully it might
be a slipping belt like someone suggested.

February 6th, 2011, 09:20 PM
Let me put up a second quick video that shows it it IS at least turning the motor.
I could not put them in one video because Premier is deciding not to play nice at all with MOV files. :/

Edit: http://www.youtube.com/watch?v=0qhHzuBKLoA

Lou - N2MIY
February 7th, 2011, 02:35 AM
It looks like the brake disengages and the motor starts to spin. However, it doesn't spin for long at all. Nowhere near long enough to get up to operating speed.

My first thought is that the sector pickup is dirty or has some problem. It would be the first indication to the drive that the disk is not spinning when it should be.

However, let's not get ahead of ourselves. Get the RA81 service manual off bitsavers, and start learning how to be more interactive with the diagnostic port. I may start doing that myself this evening.


February 7th, 2011, 08:49 AM
They have a manual specifically for the RA82 (http://www.bitsavers.org/pdf/dec/disc/ra82/). It looks like if the system is not seeing the disc spinning, either the speed transducer is acting up or the cabling to it is.
Also, what would be the signs of the brake not fully disengaging? It's possible that since it's of the friction variety it might be still on and it's overloading the motor.

February 7th, 2011, 03:02 PM
I finished repairing a broken power switch on a VT-100 I grabbed from the office last night and set to work this morning figuring out what was going on.


The thing just smells like the 80's. It's wafting out of the vents in the top. :D

Anyways, I got into the diagnostics console using 300, 8, n, 1 and then fired off a RUN DAIG command.


My assumption is that 00 means it passed so that's good. Then I checked to see if there were any silent faults.


Nope, nothing there either. Clean as a whistle.
I then pressed the RUN/STOP button and let it do its thing, then ran the diagnostics again which passed but then when I checked for any other faults...


Aha! According to the RA81 service manual (there was no RA82 service manual available on bitsavers) a 01 fault code stands for a "Spindle Motor Speed Transducer Timeout" so we are in the right neighborhood.
Though from there I can't determine if it's simply not responding when the drive starts or if it's not giving the computer the data it needs to continue the spinup.
I'm hoping the speed transducer hangs out underneath and outside of the HDA assembly. Regardless, inspection of it means totally unbolting and removing the HDA.

Edit: According to the manual, the transducer is an optical sensor that is triggered depending on weather or not it's passing through a hole in the timing disc, which is luckily located outside the sealed HDA. Might the LED have just died or would that not be giving a totally different error code? (03 - spindle not accelerating during startup)

Lou - N2MIY
February 7th, 2011, 05:03 PM
Man, I love this thread. You gotta love that 80's smell. My 11/73 is in a pedistal mount BA23 case, and every time I sit in front of it (beside it actually) and turn it on, I get a blast of that 80s smell. That machine has smelled like that for the 10 years I have owned it. And of course, the VT100 on that carpet next to the RA82. If it wasn't for the laptop in the picture, you'd might think that photo was taken in the 80s. But I digress.....

I thought the sector transducer was dirty, because on most drives I have worked on, that's how speed is checked. On floppy drives, it's optical. On RL drives, it's magnetic. At any rate, the led or sensor may be dirty and that could be the problem. Only once did I ever have a detector die, and never the LED, and it was on a floppy drive. I say, first use an alcohol soaked q-tip to clean the led and sensor. It looks like it would be hard to reach without removing the HDA. Hopefully you can reach it without that. Also, unplug and replug the sensor's connector a few times. If you have a scope handy, the transducer wiring comes up to the easily accessible circuit board on top of the HDA. I would look for the pulses on the detector output.

As for the brake, you should be able to see the brake disk pad move up or down when the drive controls engage or release the brake. I think you know that the brake is on top of the motor. I thought, from the video, that the brake was indeed released because of how fast the motor was spinning up, and then came to a halt compared to my (Tim's) RA80. I assume you already had a look at the belt tension and that it looks OK.


February 7th, 2011, 08:22 PM
Belt tension seems fine as does the tension spring.
I do have a scope though so I can poke at the leads for the transducer however the only way to access the transducer is to remove the HDA but from the manual, all you got to do to release the HDA is lock the heads, release the belt tension spring, remove some bolts, and unplug a harness.

Edit: It was incredibly easy to remove the HDA. Anyways, from a visual point the transducer looks okay but I can poke at it with the scope. Unfortunately the actual pinout differs from the diagram and it does not state the color coding of the wires so all I can immediately find is the +5v.
What should I be looking for on the scope?

February 8th, 2011, 01:47 AM
Man, I almost regret giving away my RA82-disks :( But I soo needed the space.

Lou - N2MIY
February 8th, 2011, 02:17 AM
Connect ground on your probe to ground on the drive and scope the tach pulse. Maybe put the scope on 2V/div. It should be good and strong since the phototransistor then drives a Darlington pair. You should see a nice pulse train of increasing frequency as the disk spins up.

While you have things open this far, don't remove the transducer, but still try to wipe the led and receiver with a cloth with some alcohol.

Pontus, if you needed the space so bad, you should have kept the RA82s, and given away your sofa.


February 8th, 2011, 07:26 AM
Pontus, if you needed the space so bad, you should have kept the RA82s, and given away your sofa.

I took the more drastic approach and sold the TV to make space. ;)

don't remove the transducer...
Too late. I'm assuming it's positioning was vital. Oh well, I had to format the drive anyways.

February 8th, 2011, 02:09 PM
An even better smell is from an old TTY. Nothing like that oil smell. And of course the sound. I wish I had kept my TTY
that I had many years ago. Oh well.
Tim Radde

Lou - N2MIY
February 8th, 2011, 04:14 PM
Well, at least try to put the transducer back as close to where it was as possible. Hopefully it isn't really used as a sector transducer. If not, you'll be OK.

Selling the TV was no loss. With all this hardware to fix, who has time to watch TV? Ours actually gets more use as a computer monitor than anything else.

Tim, I would guess that the smell from the TTY must have been all that grease / lubricant to keep the mechanical works from seizing up?


February 8th, 2011, 05:54 PM
My assumption is that with the transducer, I should be seeing a toggle from 0v to 5v whenever I get a pulse however none of the lines are doing this. Either the lines have power (+5 or less) or they don't and none toggle when the drive is spinning up. So either it's stuck on or stuck off.
As a test, I found out the drive shows the same symptoms when the thermostat/transducer harness is unplugged so it is indeed not behaving like it should.
I'm seeing nothing in the manual about the transducer being there for alignment (it just states it's for speed), nor does it show the classic green, red, or blue glue spot to make sure that it does not move around.
How common are replacements?

February 8th, 2011, 06:17 PM
Yes, but it's a very distinctive smell. Even now if I smelled it I'd think back to the good old days.

Lou - N2MIY
February 9th, 2011, 02:37 AM
That transducer doesn't look common, but try Googling every number on it. It may still be made by the OEM. Otherwise, we will need to repair it, or adapt some other photointerrupter. I would likely try the repair.

We need to figure out which side is broken, the LED or the phototransistor. The LED may not be visible, because it may be infrared. To verify an IRLED is working, look at it through a digital camera. To see what I mean, look at a TV remote control IRLED through a camera while pushing some buttons.

Assuming he IRLED is fine, next test the phototransistor. If a bright flashlight shown on the window will not get it to conduct, then the detector is shot.

Once the broken half is known, we can plan to rebuild the assembly. I would likely, carefully drill out the back side of the offending piece, intending to insert a T1 size case LED or phototransistor from the appropriate side. If your phototransistor is dead, we may need to add a buffer transistor outside (depending on the robustness of the phototransistor we find.)

Before you drill anything, tell us which side of the sensor is broken.


February 9th, 2011, 07:31 AM
This will take some planning as there are various interlocks that prevent the drive doing much with the HDA removed (which is needed to reach the part in question).

nige the hippy
February 9th, 2011, 01:27 PM
If the interrupter really is shot, (& it does look a bit special), it is possible to get both side-looking ir leds & phototransistors. Very often after the gunk around the wires comes off, the actual components will just slide out of the plastic casing. I've rebuilt "special" opto interrupters this way quite often. Of course if it's completely moulded you might have to do a more serious rebuild, but the slotted plastic assembly with the components in is readily available, just probably not on that particular mounting.

Lou - N2MIY
February 9th, 2011, 03:43 PM
Since you have removed the transducer, test the devices out of circuit.

Using a 1.5V battery, connect - to ground (Pin 2) and + to the +led (Pin 1). Watch through your digital camera.

Using three 1.5V batteries in series (4.5V), connect - to ground (Pin 2) and + to +5V (Pin 3). Watch the tach pulse (Pin 4) on your scope as you shine or don't shine your flashlight on the phototransistor. (Of course, ground your scope probe to the Pin 2 ground connection also).

Let us know what you find.

Between Nige and I, it appears that you have some rebuilding advisors at your disposal. The toughest I ever did was the BOT/EOT leader sensors in my dec TU60. They use incandescent lamps instead of LEDs that were potted into the assembly. I am very sure I have suitable LEDs and phototransistors around here when the time comes for yours.


PS. Also, I should admit that only now did I take a closer look at the transducer connection diagram that you posted earlier. The LED is shown, and the phototransistor is shown driving one other transistor, not driving a Darlington pair. I just wanted to correct that.

February 9th, 2011, 06:58 PM
Oh great. I think we have bigger problems. :(

I checked the IR LED under a nightshot camcorder.
Well, that was okay. Could it be the phototransistor?
To test: Put piece of paper in the way of the LED and see if the scope responds.
Result: Nope. It's not the phototransistor.

What the hell? I checked it earlier and it wasn't doing anything.
Okay, lets put it back together and see what it does.


Good news: I can totally rule out the transducer as being faulty as it seems to be working both while being tested and while in service.
Bad news: My problem is someplace else. :evil:

The FRU reference list int he service manual states an error code 01 could indicate a faulty motor/brake assembly, belt, servo module, or power supply...and I juat realized that errors 02-04 (all pertaining to speed) state a bad transducer.
I beleive I can rule out the power supply as it's rail LEDS are all lit, I'm quite sure the belt is not slipping or broken but the motor or brake, I'm not sure about.

Edit: While Iw as waiting for that video to upload, I went and found a piece of tube that I could pull the bulbs out with (who knew that a *cough*tobacco smoking device*cough* would serve suck a purpose) and suprise, ALL but the fault lamp bulbs are burnt out.
I'm going to have to wait until the weekend to buy replacement bulb, then try again and see what happens and if the REAL fault code shows its ugly face.

Lou - N2MIY
February 10th, 2011, 02:36 AM
OK, now we've to to keep looking downstream. We have to get the RA82 printe set and start looking at the next active component that the phototransistor signal goes to on the circuit board on top of the HDA. At least the transducer works.

This evening after work I will look at the RA82 FMPS (field maint. print set.) and examine the downstream logic. I just downloaded the prints. The board on top of the HDA is called the read/write board and is about 90% toward the back of the print set. I'm going to have to take some time to digest it.


Lou - N2MIY
February 10th, 2011, 05:32 PM
I have reviewed the prints. The tach pulse output from the transducer passes through the read-write (HDA top) board largely unaffected. The only component on that board is a 470 ohm pull up resistor (pretty strong for a pull-up). Then, the signal (called "tach pulse L") travels to the big board (called the Hybrid in the prints). It is inverted there in IC E12 (pin 9 in, pin 8 out), then leaves as "tach pulse H" the hybrid board to go to the servo board. On the servo board, the "tach pulse H" signal goes to and ends at E8 pin 36. That's it, it doesn't go anywhere else!

You can find E8 on this sheet that I have copied for you: http://www.vintage-computer.com/vcforum/attachment.php?attachmentid=5198&d=1297390107

I assume you know the order of pins on dips and can find pin 36. Scope it during spinup and see if the signal is there. If not, go back to the hybrid board, and scope E12 pin 9 and 8, looking for the signal. If it's present on 9 and not on 8, then E12 could be bad. It's a 74LS14 which is dead common. OR....

Something else is gong through my mind. When you were showing the phototransistor output pulse train in the video, what was the peak to peak voltage? The swing should be at least 4V or so, from 0V to at least 4V. Basically, I am concerned that the peaks really be high enough / lows really be low enough to toggle that 74LS14 I mentioned above.

I suggest you download the print set yourself and follow the tach pulse signal yourself to make sure I didn't miss something.


February 11th, 2011, 07:37 AM
I don't yet know how to properly set the scales on the scope properly yet. The manual that came with my scope strangely is for another model. :/
I noticed that as well that the phototransistor was not either on or off. It could be variable which again might point to a weaker than normal IR LED.
The resistor was VERY easy to find. It's about two inches away fromt he connector on the right.
Thanks for the help there. I'll poke around that as soon as I can and see what comes up. I have one mental image in my head right but I'm not going to jinx it.

Lou - N2MIY
February 11th, 2011, 04:01 PM
I just watched the video two more times. When you had the transducer dis-mounted from the HDA, the pulse height on the scope was two divisions, and the trace would go up from the center of the screen. In the part of the video when you put the transducer back on the HDA, the pulses in the trace would drop down one division from the center of the screen. Did you press the invert button and change the vertical amplifier on the scope between the two portions of the video?

I have no idea what model scope you have there. But, the big knob though is the timebase that sets the horizontal sweep rate. There should also be vertical amplifier knobs for each input channel that set the vertical scaling.


February 11th, 2011, 10:18 PM
I was mucking with the settings yes. The scope itself is a Sony/Tektronix 335. Nice $10 find if I do say so.
I probably won't be able to work ont he drive again until Sunday at the soonest.

February 13th, 2011, 12:10 PM
Okay. I double checked and it seems that initially the transducer will let out .1v.
If the gap between the phototransistor and the LED is blocked, it will go to +5V.
So yes, the scope somehow got inverted by accident.

Would you be able to supply the sheet showing where E12 is? I can't find alphanumerical markings along the sides of the board.

Edit: Oh,that was unexpected.
After double checking my scope settings by manually triggering the phototransistor and reinstalling the transducer assembly, I powered up the system and did another spin up with my scope set and...off she went.

Edit: Hurrah! Ran a full diagnostics and not a single fault was found. Looks like I just have a cold joint.
Looks like all I ahve to do now to finish it off is complete the new cables and replace all the front panel bulbs.

February 13th, 2011, 12:29 PM

Lou - N2MIY
February 13th, 2011, 02:56 PM
Yes, most excellent. It is funny how unplugging and replugging things a few times can make it all better. Sometimes the crud just has to be scraped off.

You might as well make one more video of the full spinup so that the viewers at home can hear that monster at full throttle!

Now you have some fine bench time ahead of you as you make those cables. I can take more (and closeup) pictures if you want.


February 13th, 2011, 04:10 PM
Already ahead of you on that (plus a blooper)


All I need to finish those cables is the pinout from end to end. The information about the controller is a little vague about its end.

Agent Orange
February 13th, 2011, 04:50 PM
I'm not in to DEC's but I sure did enjoy following this success story. Congrats.

February 13th, 2011, 06:23 PM

Hmm. It appears that the tennants downstairs are not impressed with this drive. Spin it up at 8:15 at night (all noise must stop at 11 according to the landlord) and they start beating down the walls in a wordless method of saying "Shut the hell up".
Looks like the RA82 work and all work associated with the PDP-11/84 has hust come to a screeching halt in the form of a call from the landlord. :(
Guess this thing's rattling every corner of the house.

nige the hippy
February 14th, 2011, 11:20 AM
Slightly o/t but we used to use a heavy rubber mat made from recycled car tyres and about 3/4 inch thick in soft play areas for sound deadening. I used offcuts on the stairs at my ex's house and it was quite remarkably good at silencing teenagers in army boots at 3AM. Perhaps you could get hold of some & rest the drive on that.
Failing that, a sandwich of thick foam & plywood would probably cut most of the transmitted vibration.

October 29th, 2012, 08:59 PM

It's in the rack and I really want to finish this off.
Since the last time I have moved and gotten hold of a logic probe so I have been using that instead of the scope. I'm still having the erratic issues with the transducer where sometimes it will work but more often it does not. I would like to replace it however I don't know if it's a DEC specific part.


The only markings on it are

L10423 Rev C

Lou - N2MIY
October 30th, 2012, 04:05 PM
Ok, did you clean it with a q-tip and alcohol? I have seen many sector index transducers revived after a good cleaning.


October 30th, 2012, 05:38 PM
I have. It works but it does not. As seen from youtube videos I made it's very hit and miss. Sometimes it will work perfectly, other times it won't. I can tear the drive apart to take it out and test it and it will work but put it back together and it's no good again. Yes the cabling between is good.

Lou - N2MIY
October 31st, 2012, 04:17 PM
When you look at the output of the phototransistor on the scope, what does the voltage look like? Does it have good strong changes in voltage level? I'm wondering if it's marginal when it's in either of the states, and perhaps the next gate downstream is not being satisfied (all the time anyway).


October 31st, 2012, 07:45 PM
Okay, so I set the harness on the bench and supplied +5v to +LED and +5V lines, attaches GND and connected TACH to my scope.
Obstructing the light path produces a really weak response. This might be because I'm abusing the AGC-AVC voltage controls on a signal generator and the LED along pulls the voltage down to 1.2v.

Anyways, if I leave TACH and +5 connected (so +LED and GND are not attached) and shine a flashlight at the sensor I get a good 3v high/low difference. Oddly, if I also attach GND the signal goes weak again. Sounds like it's shorting itself out or again the shady power supply is struggling.

It shows what I previously saw and that is the transducer works but if I install it, it won't. At this point I'm suspicious what would happen if I just snapped off the internal LED and replaced it with a white LED I have.

Lou - N2MIY
November 1st, 2012, 03:34 PM
So, do you think the LED that's on the photointerrupter is an IR LED? (If your eye can't see it, that's likely the case.) If you have a CCD television camera, it might see the IRLED and you may be able to see flickering or intensity change that jives with your "sometimes it works, sometimes it doesn't" diagnosis.

As for replacement with a white LED, it might work since your flashlight saturates the phototransistor nicely.


November 1st, 2012, 06:37 PM
It's an IR LED. I use my Handycam's nightshot to see if it's behaving and it's constant. The sensor seems to react to about any source of light I focus on it.

November 2nd, 2012, 05:34 PM

I noticed that the top and bottom of the transducer are glued in. After popping those off I noticed it isn't potted inside. I pried out the LED assembly which was a blob of epoxy on a PCB and then I referred to the schematics.


That's bad. I should be seeing the GND also go to the optical pickup on the other side but I wasn't seeing anything. Under a a good light however I saw that there was a super tiny wire that had broken.

There was enough wire left that I used some patch wire to repair the connection. It was delicate but it seemed to work.


The result however was VERY reassuring.

The drive now spins up and has reached READY, however all three times I have spun up so far it has either failed to reach ready because of a fault or aborted because of a fault. First one was a SERVO COARSE POSITIONING ERROR, then I got a successful spinup, followed by a SPIN ERROR, then the latest time was R/W COMMAND ERROR. The first two lay suspect to the servo board but the last one I hope is the result of just a poor ribbon cable connection somewhere because it scares the hell out of me. One thing I do for sure know however is that it can and WILL reach a normal working state and that between the last time I had it working and now the drive had been stored with both the heads locked and the belt tension released.

November 2nd, 2012, 07:20 PM
So the problems didn't let up with a connector cleaning. Out came the VT-100 again.


Following the steps in the service manual the system appears to pass with flying colors in the spun down state. Spin the drive up now however...


Error C6 is a PLO error, following that the drive aborts spinup and gives error 26 which is the system indicating the drive speed has dropped 3420 RPM.
The front panel blinks the fault status for SPIN ERROR which states the fault is either on the servo module or CPU module. I retested the PLO circuitry from the diagnostics and it passes. :tellme:

Every so soften the exact errors change or appear or go away but it's always something on the servo board which in the past I have never had any issues with.

I'm running into way too many variables now. I'm just going to back off on this again until I can better troubleshoot this on paper.

November 11th, 2013, 11:48 PM
Still working on this. ;)

So I finally am back in a position to retest having moved to a drier climate and cleaned the machine out. I replaced the bad fan to ease my worries about overheating however:
1: These fans are 120V
2: If you want to use a 12V fan you're going to need a 30 ohm resistor because there is no +12 ANYWHERE in the drive. The closest is +15.

Anyways I started back off with our friend the Spin Error. So I hung my logic probe off the harness. It didn't work.
Odd. It was fine up on the bench. Whats the voltage?
To my surprise the +5 on the R/W was VERY out of range. It was hanging at 1.3v in fact. I discovered that if I disconnected the positive on the phototransistor's LED the voltage would come right back up. It's somehow shorted itself I guess. This MIGHT explain some of my other errors as well if none of the logic on the R/W board was being properly driven. Anyways, I tore the transducer apart again, pulled the old LED out and hot glued in a new one. It's almost 1AM so I'll try putting the drive back together and testing it in the morning but on the bench I'm reliably seeing high/low peaks from the transducer again so we MIGHT finally have it in the bag and be able to move onwards to that hot motor....or that PLO error.

November 12th, 2013, 12:06 PM
Okay, so after a final checkout I can confirm the transducer is now REPAIRED.
Me being an idiot forgot that there was a resistor in series with the transducer's LED already. Oh well, if it was a problem before it's fixed now.

It's working and it's reliable.
HOWEVER something is keeping TACH high. This is why I'm getting spin errors.

Edited: I'm going to start over and figure out where the tach goes.
Following the pulse (I swear I did this before) the TACH PULSE L has a pull-up resistor to 5V, then travels to pin 16 on the cable to the Hybrid board. From there it Passes through a 74LS14 and becomes TACH PULSE H. This travels to pin 5 to the cable for the Servo board (this is the board that my PLO problems would surface from as well).
From there I lose track of it on the schematics. Can anyone else find it? I'm reading this PDF (http://bitsavers.informatik.uni-stuttgart.de/pdf/dec/disc/ra82/) and the Servo board starts on page 125.

November 14th, 2013, 08:04 AM
Okay, lets try this again from square one, jesus christ. http://i.somethingawful.com/forumsystem/emoticons/emot-suicide.gif

I passed on my results on the circuit being stuck high with the resistor in the circuit and after looking at the schematic he says it's STILL the damn transducer as even with the resistor connected the phototransister in the assembly should still be able to pull the signal low when it isn't. The final decision was to completely replace it. I mentioned I couldn't find suitable replacements. He found them in about a minute. >_< (http://www.ebay.com/itm/10-Pcs-1-8-Gap-Mounting-Bracket-Photo-Interrupter-Blk-/321057004128?pt=LH_DefaultDomain_0&hash=item4ac07d1a60)
So this order is in the mail and we'll try again in a few weeks.

November 14th, 2013, 08:28 AM
You're not alone here... I've been watching with interest, but not much to contribute. Expect I'll be going through the same with mine eventually. BTW - Loved that emoticon.

November 14th, 2013, 09:30 AM
This is a bit of a monster to navigate without using the NETLIST. Damn... wish I could edit these PDFs.

Servo Control

Netlist beings pdf-159
Schematic = pdf-135 (sch-01) though pdf-158 (sch-24)
BOM = pdf-129 thru pdf-134

Kind of blindly, I'll try to follow that TACH PULSE -H On the Servo Control BD

pdf-134, sch_pg-01, (D5 ) = "J402-5"
pdf-153, sch_pg-19, (C8 ) = "ROM 1 E8-36"

I think it might be of help to locate all the boards and sections in the schematic for you. At least you'll know where to go without having to search laboriously.

Would that help?

December 2nd, 2013, 01:27 PM
New transducers arrived and was fitted to the old mounting block with a dremel and hot glue.


...But I'm doing something wrong. I HAVE TO BE and I don't know what it is.

For reference, here is the old transducer diagram.
(ignore the pin numbering on J501)

Now here is the diagram for the new one as well as the relevant circuit on the R/W board.
(refer to THIS for correct pin numbering)

I never found that extra transistor so I tried to replicate it with a 2N3904 with the collector being the TACH PULSE, the base being the output of the transducer and the emitter being ground. Didn't really make sense but whatever, so I set it up on a breadboard.


As observed on the old transducer TACH PULSE remains high at all times.

December 2nd, 2013, 02:24 PM
This is one of those instances where a picture is worth more than 1000 words. Sorry I can't do a new schemo for you easily at the moment. That machine is in the midst of a week long disk diagnostic. If you post a new one before trying it, I'll check it.

I don't think an external transistor will be required. The output should be strong enough and in the same phase as the original. (If not, then we'll add one)

Referencing your schematic as it now is...

The opto-coupler should be connected as follows:

Emitter to ground (J501-4 ?)
Collector to TACH PULSE L and pull-up resistor R111 (470 ohm) (J501-7 ?)
LED Anode to R113 (200 ohms would be better?) (J501-1 ?)
LED Cathode to Ground (J501-2 ?)

36ma driving that LED: [82 ohms?] seems a little high to me. Is that in spec for the new device? If you don't want to modify the original board - add a 150 or 200 ohm resistor in series with the LED.

I was confused by the pin numbering so this description seemed clearer. If I understood correctly, you had collector and emitter transposed before - yes?

Testing: Hopefully - the wavelength characteristics of these devices are chosen so ordinary visible light doesn't pollute or swamp the detector. I'd check it out with light sources to be certain. This could be a cause of trouble when in situ as well.

December 2nd, 2013, 06:12 PM
Emitter to ground (J501-4 ?)

Collector to TACH PULSE L and pull-up resistor R111 (470 ohm) (J501-7 ?)

LED Anode to R113 (200 ohms would be better?) (J501-1 ?)
I got a 220 so I'll swap that in. Ok.

LED Cathode to Ground (J501-2 ?)
(BTW, this arrangement does not seem to work (nothing attached to base?). The line is still high.)

36ma driving that LED: [82 ohms?] seems a little high to me. Is that in spec for the new device?
The original transducer used an 80 ohm resistor as well. Even though this is IR I can always check the output with a nightshot camera in case I've overdriven and burned the LED out.

December 2nd, 2013, 06:17 PM
Saw you just replied - so I hope this catches you.

I'm having difficulty understanding which drawings are your proposals, from renditions of how the original was. [didn't look at a schematic yet]

Most cell phone cams are sensitive in IR - so you can use that too.

Having my other machine down is really killing me - this should be simple to sort out.

December 2nd, 2013, 06:28 PM

(BTW, this arrangement does not seem to work (nothing attached to base?). The line is still high.)

The original transducer used an 80 ohm resistor as well. Even though this is IR I can always check the output with a nightshot camera in case I've overdriven and burned the LED out.Yeah... we're talking apples and oranges here.

So from your comments you are including an external transistor in the mix.

In my comments, I have assumed we're talking only about the opto device in your second image.

So to be clear... I need to find schematic pages where J501 is pictured, and to understand what components were on the original sensor.

I now realize you're adding stuff externally that I assumed was on the board.

See my confusion?


Read/Write module diagrams begin on PDF pg 169 to pg 181 with J501 on 179

I now see your partial schematic is taken from pg 179.

Were there components on the original cable assy?

December 2nd, 2013, 06:38 PM
So to be clear... I need to find schematic pages where J501 is pictured, and to understand what components were on the original sensor.
Doesn't exist. I ran up the part numbers on the old sensor and never found any details, that snippit from the RA81 manual (http://i11.photobucket.com/albums/a166/ballsandy/Computer%20related/RA82trans.jpg) is the best there is and implies that in the one package is the IR LED, the phototransistor and an additional transistor. What you see on the breadboard was:
-The load resistor for the IR LED
-The pullup resistor for the TACH PULSE line
-The second transistor that was in the transducer

I never added anything new to the circuit. I'm just trying to make the connections with little knowledge on how it originally worked. If you want me to simplify it, just tell me.

See my confusion?
Is it bad if I say "not really"? :|

December 2nd, 2013, 06:52 PM
There have been a few advances in optoelectronics in the past 30 years, so there should be no need for an external transistor.

If you want to breadboard it before installing that's ok. Your breadboard need only include a series resistor for the LED and a pull-up for the collector of the opto's output transistor.

Connections are in my post:

The opto-coupler should be connected as follows:

Emitter to ground
Collector is TACH PULSE L - to pull-up resistor (470 ohm)
LED Anode to series resistor (standing in for R113)
LED Cathode to Ground

For the actual device cable I expect this would be how to connect it to J501 - The opto-coupler should be connected as follows:

Emitter to ground J501-4
Collector to TACH PULSE L J501-7
LED Anode to J501-1
LED Cathode to Ground J501-2

As I said - 36ma is too much current for a modern LED. I'd try to size the dropping resistor to 10ma at most, unless the specs for the opto device state otherwise. (LED's usually drop 2v - leaving 3v across the dropping resistor. Size resistor accordingly)

If you breadboard it - you should be able to test the output levels by manually interrupting the path. If this doesn't work, check the LED for output and voltage drop across it should be ~2v.

Is there a datasheet for the opto device you bought?

There should be no connection to the opto device's output transistor base. [there may have been in the original]

Sorry for my exasperation.... make that 10000 words.

December 2nd, 2013, 07:23 PM
Try this.... (dug out an old laptop and corrected the second drawing)

But I still need a datasheet on the opto device.

December 2nd, 2013, 07:37 PM
Just checked back through your posts and found the link to the auction for your opto device.

Product Name Slotted Optical Switch Model HY860C
Output Type Photo Transistor Peak Emission Wavelength 940nm IR Diode Forward Current 50mA
IR Diode Reverse Voltage 5V Transistor Power Dissipation 75mW Transistor Collector Current 20mA Photo Transistor Collector-emitter Voltage 30V Photo Transistor Emitter-collector Voltage 5V Diode Power Dissipation 100mW Operating Temperature Range -55~100 Celsius Degree Number of Pins 4 Slot Width 3.2mm/1/8'' Slot Depth 8mm/5/16'' Pin Length 9mm/0.35'' Pitch 7mm/0.28'', 2.5mm/0.1'' Hole Dia. 3mm/0.12'' Total Size 25 x 23 x 6mm/1'' x 0.9'' x 0.2''(L*W*H) Material Plastic, Metal Color Black Net Weight 9g Package Content 10 x Slotted Optical Switch w Bracket
There isn't enough there for me to help with pin identification. The spec does say 50ma on the LED is ok, so forget my worries about that.

The photo transistor is a two pin device. [base not accessible] However, the Collector is not interchangeable with the Emitter. Does the package clearly identify them? The emitter of an NPN must be grounded in your application.

See if any of that helps.

December 2nd, 2013, 07:40 PM
Pin identification can be found here (http://i00.c.aliimg.com/img/ibank/2010/809/435/126534908_99751133.jpg).

I also tried your modified diagram. Same problem. Signal sticks high.

December 2nd, 2013, 07:49 PM
Hi All;
I am slightly confused also..
But, most modern Led's use around 220 ohms for their current limiting resistor.. So, the 82 ohms sounds somewhat low..
Now if the 470 ohm resistor is is for the led than that should be OK.. I would start with a larger ohmed resistor than a smaller one, less likely to burn out the Led, You can always go smaller, but once you have burned it out, it too late to go bigger..
Also, If you still think You need the extra Transistor, I would check that its the correct type NPN against PNP..
If, this doesn't apply, because of my confusion, then I apologize..

December 2nd, 2013, 07:59 PM
...most modern Led's use around 220 ohms for their current limiting resistor.. So, the 82 ohms sounds somewhat low..
I thought so too, but the spec says it's ok.

I'm still trying to identify the collector from the emitter. With all the thrashing around he's been through, we need to check if the part is still good. Perform the following with it "in circuit" on either breadboard or the real deal. [powered]

LED: measure the steady state voltage drop across the LED. If it's ~2v then try to see it with eyes or camera. It emits in IR, so it may not be visible.

Next, the polarity of the output photo transistor. I suppose we just have to try both. However, if in the process of checking things out it got hung from 5v to ground - it could be blown.

To begin troubleshooting it - check that it has 5V across it with the LED disconnected. Then check again with the LED on.

December 2nd, 2013, 09:02 PM
Give me half an hour to make some photos and diagrams. <_<'

December 2nd, 2013, 09:19 PM
Ok - Thanks for the heads up. I'll hang. Been working on making the maintenance print faster to use.

December 2nd, 2013, 09:52 PM
Okay, lets go through everything in detail. For the purpose of testing the circuit while not attached to the HDA I have laid it out on a breadboard.


Green alligator clip: GND
Red alligator clip: +5v
Resistor: 220 ohm

Referring to the seven pin connector...
RED: LED+ (pin 1)
BLACK: GND (pin 2)
WHITE: +5v (pin 3)
BLACK: THERMAL GND (pin 4, not used)
N/C: (pin 5)
GREEN: THERMAL+ (pin 6, not used)

On a schematic, this pictured layout looks like this:

The blue box containing an LED and a phototransistor is an HY860C photoswitch (details available here (http://www.ebay.ca/itm/321057004128?ssPageName=STRK:MEWNX:IT&_trksid=p3984.m1497.l2649).)

An oscilloscope is attached to GND and pin 7 after +5v is applied to the board. The oscilloscope reports +5 is present.

Removal of the 220 ohm resistor changes the schematic as shown and the oscilloscope reports 0V.

Reinstalling the resistor restores voltage through pin 7. Obstructing the phototransistor from the LED however causes the voltage to again drop to 0V.

We can now for certain say that the transducer is functioning and indicating a HIGH with an unobstructed path and a LOW with a blocked path.

Now we add another resistor between +5v and pin 7. A 500 ohm resistor (as a substitute as I don't have a 470 on hand)

From this point onwards, regardless of the path being blocked or the LED being disconnected the TACH PULSE will be stuck high. This is my problem. There are no additional branches in the TACH PULSE trace. It runs from pin 7 on the R/W board to a 75LS14N on the hybrid board which is unable to do anything with the signal because all it can see is a static HIGH signal which to the drive means there is no rotation (which results in a SPIN ERROR)

December 2nd, 2013, 10:01 PM
Please refer again to:

Please note that I changed the Emitter to Pin 4 GND and the Collector to Pin 7 - TACH PULSE L

Your diagrams show the Collector to PIN 3 (+5) which is useless to you, and Emitter to TACH PULSE L. (Emitters are the ones with the Arrows)

Should I hang a little longer while you try it?

December 2nd, 2013, 10:17 PM
Theory of operation:

5V applied to R113 produces a current to the ANODE of the IR emitting LED passing through the CATHODE to ground. This current causes a "Forward" voltage drop across the LED of about 2V nominal, leaving 3V to drop across R113. Measuring the voltage across R113 (3v nominal) and dividing that by the value of R113 will indicate the current passing through the LED. If the voltage across the LED is 5v - then no current is flowing and the LED is open or backwards. If the voltage drop across the LED is zero, the LED is either shorted or not connected to the circuit as expected.

5V applied to R111 passes through J501-7 to the Collector of the Phototransistor. The Emitter of the phototransistor attaches to J501-2 or -4 or other ground. When IR energy is hitting the phototransistor, it turns ON, creating a low impedance path between Emitter and Collector. In the ON state, the transistor steals current from the TACH PULSE L node, and it's voltage drops to near zero. [all the current being shunted to ground] When no IR is present, the phototransistor turns OFF. The voltage on TACH PULSE L rises to near 5V - as no current is shunted to ground and the voltage drop across R111 goes to zero.

Absense of a change of state in TACH PULSE L with a change in IR input indicates one of the following:

TACH PULSE L = 5v with IR Present: The Transistor is not passing current as expected. Check for reversed identification of Emitter and Collector. Check also for blocked optical path or mis-wired circuit. None of the above may indicate a blown transistor.

TACH PULSE L = 0v with IR Absent - The Transistor is unexpectedly passing current to ground. Check for shorted leads (Collector to Emitter), light leakage to the phototransistor, and mis-wired circuit. None of the above may indicate a defective (shorted) Collector Emitter junction.

December 2nd, 2013, 10:42 PM
So you want me to do this:

...which looks like this...

...which on a scope attached to pin 3 (THE WHITE WIRE) and with the LED either on or off and the path either blocked or unblocked, results in this:

You've managed to reverse my stuck HIGH problem into a stuck LOW problem. Good for you. That was an amazing use of my time.

December 2nd, 2013, 10:46 PM
Why is the red jumper on the breadboard?

December 2nd, 2013, 11:00 PM
Assuming Yellow is Attached to the Collector and White to the Emitter... (Is that the way it is?)

Please remove the Red jumper from GND to 7 (Yellow) and move it to: GND to White.

I'm still not certain how Collector was identified from Emitter physically. Can you tell me how you did that?

December 2nd, 2013, 11:16 PM
Guess we're done for the night? Too bad... you almost got there. The Red jumper [see photo] is grounding pin 7 TACH PULSE L. Yeah... it's gonna make a stuck low alright.

Maybe NeXT time?

March 14th, 2014, 09:22 PM
Okay, here we go again.
After working on the paper tape reader project I can answer the question "why is it stuck high??"

The answer is that when I replaced the transducer I was wiring up so that both a block and unblocked paths outputted 5V. I modified the circuit by cutting pin 3 from +5 and connecting it to ground, then I replaced the 470 ohm resistor with a 470k resistor. I also switched the LED resistor back to the original 82 ohm resistor. Now when tested on the breadboard a blocked path is +4 and unblocked is 0v. That's more like it! :)
I then reinstalled everything and tested again. Still no spin but looking at the scope a blocked path was now about 3.6v and unblocked was...about 1.2v.
Pulling the 470k resistor found that there was still 1.2v creeping in someplace. Eventually I found that removing the LS14 made the voltage drop back down to 0v so I switched in another LS14 and again there was about 1.2v creeping in. To the schmitt anything over 1v is a HIGH logic signal so it's stuck high. You have to take a 1K resistor from input to ground to pull it down enough but then you can't pull the voltage back up enough to make it switch states again.


March 15th, 2014, 03:25 PM
Finally with a bit of assistance (for those who held in through all this, I praise you for keeping your cool) we determined the best thing to do was to completely do away with the 74LS14 and use a darlington pair, similar to how the original transducer worked but to also generate the proper logic signalling for Tach Pulse H on pin 8 output of the LS14. The result was that in both prototype and the final installation you could spin the drive up.


Mind you, now the HDA initially goes ready but eventually either the drive will spin itself down or diagnostics will report that either the drive is spinning under 3400 RPM or the spindle is at the wrong speed. Scope picture looks pretty clean though there's a peculiar sparkling effect when the drive is seeking. Even more odd is it can fail a test citing an above speed issue and if I run it immediately after it will probably pass. Noise perhaps? It visually doesn't look like either the 3904 or the phototransistor are not up to the task.

Lou - N2MIY
March 15th, 2014, 05:25 PM
Very nicely done! I very much like reading about this kind of work! But, there is still plenty of work ahead. Enjoy a beer over this little success and prepare for the next battle....


March 15th, 2014, 06:10 PM
Here's a youtube video to enjoy.


March 15th, 2014, 07:08 PM
Okay, here we go again.
After working on the paper tape reader project I can answer the question "why is it stuck high??"

The answer is that when I replaced the transducer I was wiring up so that both a block and unblocked paths outputted 5V. I modified the circuit by cutting pin 3 from +5 and connecting it to ground, then I replaced the 470 ohm resistor with a 470k resistor. I also switched the LED resistor back to the original 82 ohm resistor. Now when tested on the breadboard a blocked path is +4 and unblocked is 0v. That's more like it! :)
I then reinstalled everything and tested again. Still no spin but looking at the scope a blocked path was now about 3.6v and unblocked was...about 1.2v.
Pulling the 470k resistor found that there was still 1.2v creeping in someplace. Eventually I found that removing the LS14 made the voltage drop back down to 0v so I switched in another LS14 and again there was about 1.2v creeping in. To the schmitt anything over 1v is a HIGH logic signal so it's stuck high. You have to take a 1K resistor from input to ground to pull it down enough but then you can't pull the voltage back up enough to make it switch states again.


How did you determine that a 470K resistor was a reasonable value?

Looking at 74LS14 datasheet specs, VT+ max is 1.9V, so on the L to H transition on the input you need to exceed this voltage. So 5V - 1.9V means you can drop about 3V (or less) across the resistor worst case.

The maximum high level input leakage current on the 74LS14 is 20uA per data sheet spec. So using R = E/I I compute the largest value of the pullup resistor you could use would be 3V/20uA is 150K MAXIMUM. 470K is 3X this value.

So I expect if you replaced that 470Kohm resistor with a value in the range of 10K to 100K it would have worked as is.


Also VT- on the 74LS14 is 0.5V to 1.0V, VT+ is 1.4V to 1.9V. So for the worst case 74LS14 device, the input going low has to transition below 0.5V, and the input going high has to transition above 1.9V.

March 15th, 2014, 07:41 PM
I just scrapped that whole schematic. The hand drawn one is the current configuration.

March 15th, 2014, 08:37 PM
I just scrapped that whole schematic. The hand drawn one is the current configuration.


I was just pointing out that the original circuit had an unrealistic pullup value that was too high. It would have required selecting the 'LS14 for very low input leakage (below about 7uA) to have any chance of working. Or if you had used a 74HCT14 instead (with 1uA input current max) it would have worked. Or just change the pullup resistor to the 10K to 100K range as I noted above. Lower is better, as it will improve the risetime.

March 28th, 2014, 09:00 PM
Dammit. This is so frustratingly intermittent!

So the idea was that the transistor was in the wrong place and adding an extra 24" or so of length to the TACH PULSE H circuit wasn't doing a whole hell of a lot of good to keep the signal clean, hence why I would randomly get phantom speed errors. The solution was to move the modification to beside the LS14 it replaced.


This seemed to work and for half an hour of constant testing there was no problems but then I got a random speed error followed by another six minutes later and then four seconds after that it logged a fatal low speed error and spun itself down. Spin it up again and not a minute later it goes down again with a fatal low speed fault. Try again. Seven minutes until failure.



I'm puzzled. We've cleaned up any possible signal conditioning issues related to excessive trace length and we know the circuit works yet still at what seems like complete random it will will fail.

March 29th, 2014, 06:23 AM
Hi All;
I am No expert in these kind of things, but maybe You need either a transistor that delivers a higher ma or a transistor that is a higher speed transistor and can take the constant up and down of the signal.. Or maybe You just got a hold of a Bad Transistor..

March 29th, 2014, 08:00 AM
Can you arrange to see what TACH_PULSE_H looks like on scope as it works and later fails? Is there still a new threshold issue or is it something else now?

March 29th, 2014, 01:53 PM
Hanging the scope off both lines at the same time is easy but the problem is I have to watch the screen like a hawk or else I'll miss any sort of malfunction before the drive spins itself down. It would only be visible for a fraction of a second.

March 29th, 2014, 02:19 PM
Hanging the scope off both lines at the same time is easy but the problem is I have to watch the screen like a hawk or else I'll miss any sort of malfunction before the drive spins itself down. It would only be visible for a fraction of a second.

I gather that you're using an analog scope. It can be hard to catch a glitch, runt pulse, missing pulse, etc. without some form of storage like a digital scope, logic analyzer, or even an analog storage scope if you like to keep things old-school. Triggering can still be a challenge, but at least you don't need to turn up the brightness enough to hope that the single missing pulse burns into your retina. :)

I have zero hands-on experience with the RA82 so far, so this is pure speculation: Since it's complaining about low RPM, maybe the new sensor circuit is marginal enough that it occasionally drops a pulse, and maybe the drive's error detection is dumb or paranoid enough to shut it down after a single extra-long pulse to pulse interval?

March 29th, 2014, 04:24 PM
Well, I still think you might see something worthwhile with a scope if the low level began creeping up, but it's up to you.

Before you substituted the second transistor for the 74LS14 stage, I was almost about to ask if you would be open to an experiment?

Since the LS14 is socketed, perhaps you might try a 74HC14 instead? This would effectively move the thresholds away from the low levels that your opto was having trouble making. I haven't looked at what the other LS14 stages were doing though... but my experience is that the sub usually works in most designs.

Anyway, it should be easy enough to try out, but requires you return to the original configuration.

BTW- Make certain it's an HC14 - not a HCT (which would defeat our purpose)

October 26th, 2014, 01:27 PM
Troubleshooting was postponed until better testing equipment was found.

I now have an HP 3960 Instrument Recorder. Basically for those people who do not have a digital storage scope you can put this baby between the scope and the probes and when properly setup it can log whatever the probes see in intervals up to 12 hours long. I recorded several spin-up/fault triggered spindowns and reviewed the tape. It let me slow it down to 1/15 the speed and helps to prevent wearing the drive out.


>>VIDEO OF DEBUGGING<< (https://www.youtube.com/watch?v=-xqLzwJH5KM)

The results showed that the tach under all circumstances remains within tolerances and accurate so whatever is triggering the spin errors is further upstream though we're starting to get into the more complicated IC's that can't be replaced.

September 20th, 2015, 07:12 PM
I was browsing ebay and saw an overpriced RA82. While finding out what it is, I came across this old thread and read all the way through it. Just wondering if you ever got it up and running?

September 21st, 2015, 09:29 AM
I'm positive now it's not the tach pulse leaving the transducer anymore. There is definately a point somewhere further up the circuit than I have been so far on the PLO board where the logic is intermittently failing, causing the speed errors.
Where exactly, I have STILL not found. It's incredibly frustrating.

September 21st, 2015, 04:29 PM
I hope you figure this out. The RICM has five RA81 drives that will not stay spun up.

September 21st, 2015, 07:34 PM
Have you been able to verify that your tach pulse signal is also healthy? It should be really obvious on a scope.

September 22nd, 2015, 03:56 AM
We haven't spent much time debugging the problem, other than trying lots of different drives.

I had seen this problem earlier and fixed it by replacing the starting capacitor. We tried that new starting capacitor in these drives, but it didn't change the behavior.

There are some details on our efforts here: http://www.ricomputermuseum.org/Home/equipment/dec-pdp-1144/pdp-11-44-restoration

September 22nd, 2015, 08:42 AM
Ah yes. I've read that article before and smirked when I made the connection to my video. :).

Well I can try ad finish tracing down where the signal goes but that might not be until the snow falls. There's a number of things in the shop right now that prevent me from sliding the drive out and easily reaching it for debugging but once it gets colder outside I'll have more reason to tidy up the shop. If you hear nothing in this thread by December, nag me.

September 29th, 2017, 05:52 AM
Hi there,

Here at "Museo Interattivo di Archeologia Informatica" Computer Museum in Cosenza, Italy, we're restoring a VAX 11/780 system. We had the same problem on 2 units, RA81 and RA82. We found something interesting:

the servo sensor seem to have some sort of "goo" on the LED and TRANSISTOR part. Looking at it with a microscope, it seem that the plastic covering the LED and the TRANSISTOR is somehow degraded / gone gummy.

We cleaned it wery nicely using Isopropyl Alcohol and q-tips - this solved our issue on every drive, and now we're going to dump the disks using a Microvax 3600 booted via SIMH / network system :)

We're documenting our entire work on facebook (sorry! a post will follow on our internet site, http://museum.freaknet.org) :


we posted some interesting pictures about this problem.

Any question or hint is welcome :)


October 1st, 2017, 05:08 AM
This is great news!

October 3rd, 2017, 03:03 AM
This is great news!

Some other news:

Well, we need to investigate better this issue, because maybe we had a lot of luck.

We managed to extract data from both our RA82 drives and from our RA81 drive.

We had to play by swapping boards (from the 2 RA82/s) and sensors, and also the disk pack himself. 2 of the 3 sensors had some minor issues (sometime reading, sometime going faulty), one of them (the RA81 sensor) was good so we used it to read all the 3 disks.

Maybe the issue is this plastic going sticky on the sensors itself, maybe is the internal glue I saw from some pictures here.

We are planning to create / adapt a new sensor (still searching for it) adding a little PCB board to fit the original connector with some adapter circuit, so there's no need to tweak/solder into the original disk board, and to have the mod reversable.

More details will follow, I hope, soon :)

TY very much, this thread was very useful!

Note: We had a complete disk dump for our VAX 11/780, that was shutted down in 1992. The disk images boot perfectly under SIMH and is FANTASTIC to see this computer back online (it came from University of Calabria, UNICAL). A lot of FORTRAN programs, utilities by students / users, and preciuos data about the network back in 1992 - DECNET, BITNET, and connection with universities all around the world. We're still digging into this precious material, we hope to publish some paper on this piece of history, that is finally preserved.

We cannot (for now!) share the disk images because they also contain A LOT of personal emails and data; we're thinking about cleaning the home user directories leaving only technical stuff and nothing personal inside, so we can share it around. VMS 5.3 btw :)

A lot of work is ahead...

TY all again,


April 23rd, 2018, 06:42 PM
Unfortunately for me it's now too late to proceed with those steps as I ended up completely rebuilding the assembly.
Now that you mention it though, while I was dissecting the old transducer I did notice there was a soft material in the light path opening.

On that note, an observation.
Last weekend I picked up an ancient Tektronix 564B oscilloscope but it comes with the added bonus of using a storage tube so I can more closely observe the timing signal. I do believe I overlooked something.

(God DAMN I love this oscilloscope)

This was reproduced from the successful spinup and run until a spin error for no observable reason. Timing wise it's okay, because the tach is within spec enough that the drive can find a useable servo track and go READY. Looking back at my notes however I had set my scope to to .5 volts per division (.1 volt per horizontal line on the scale). That means from fully blocked to open the rise and fall is 2.5-2.6v.
I think AK6DN was onto something a few pages back. Sorry for glossing over that. For a CMOS level circuit 2.5v is dangerously close to the cutoff for a logic high. Some will say it's very much out of spec. If this is correct than all it would take to generate a spurious error is the tach voltage dropping 0.2v which could be the result of ANYTHING in the drive.
I will have to recheck my voltages in the rebuilt circuit to verify as it could also be I improperly setup the HP 3960 but an improperly rated resistor could very much be the problem.