PDA

View Full Version : Cleaning IIci...whoops!



geoffm3
February 27th, 2011, 12:56 PM
So the other day I was recapping the IIci motherboard and I decided a couple of the chips around the caps neede to be cleaned due to the corrosion from the leaking electrolyte. I used a small paintbrush dipped in alcohol and brushed it over the affected areas and then all of a sudden, one of the chips in the powerup circuit just flecked off the board! I wasn't even applying any pressure, just gently brushing. So now ive got to fix that. Grrr

Unknown_K
February 27th, 2011, 06:32 PM
Remove the old solder before soldering the chip back on.

NeXT
February 27th, 2011, 08:14 PM
I'm assuming that because you are cleaning the elecrolyte off the board, you are also replacing the caps as well, right?

Chuck(G)
February 27th, 2011, 08:17 PM
Alcohol also dissolves flux, which may have been holding the chip (albeit badly) to the board. I've seen it happen.

geoffm3
February 28th, 2011, 05:38 AM
I'm assuming that because you are cleaning the elecrolyte off the board, you are also replacing the caps as well, right?

Correct, I've replaced all the caps. I've just got to fix the bad solder joints now. I replaced the chip that came off the board, only to have the one next to it snap off... same deal there. It was held on a bit tougher. Thankfully didn't pull up any traces with either one. I just scraped off all the old corroded solder (flux and soldering iron wouldn't work) down to the pad and re-tinned them. The first chip is back on the board, and I defeated the startup circuit just so I could test the rest of the fix. My sound is back now, which was one of the main problems, and the system will power off on its own (before it would stay at the "safe to turn off" screen). I also have problems using the cache card. When I first started trying to use the machine, the machine would boot with the cache card installed, and now it won't. :( The two electrolytics on the cache card are also leaky, so I will probably shotgun that and try just replacing those first.

Chuck: Yeah, I figured that the leftover flux must have been holding it too... the solder was so badly corroded on these particular chips I'm not surprised they turned loose. There are a couple of other chips on the board that look similar to these, so if I run into any other problems I'll suspect them first. ;)

Does anyone have complete schematics for the IIci? I have only been able to find a schematic of the powerup/down circuit online.

EDIT: correction, I've replaced all the SMT eletrolytics on the mainboard. I haven't replaced the four big axial electrolytics yet, cause I didn't have any yet.

geoffm3
February 28th, 2011, 07:42 PM
I replaced the other chip and now I can power up/down the system! Everything pretty much works now on it, except annoyingly the cache card.

geoffm3
March 7th, 2011, 07:31 AM
Bugger. Now it's quit working again. I can't even power it up. The power supply is fine. I guess there's something else in the startup circuit that's at fault. More testing!