PDA

View Full Version : Need help on an IBM 5170 CPU Orientation (How it plugs in)



Old PC Man
July 23rd, 2003, 09:02 PM
I'm trying to restore an old IBM 5170 AT Type 1. When I removed the motherboard to clean the interior, the CPU fell out if the socket. Apparenty the CPU was not inserted as it should have been.

Unlike most motherboards, there is no chip orientation for the CPU. There are no pin numbers either. The CPU has an orientation corner, but, there is nothing on the motherboard to indicate how the chip should be inserted.

Can anyone give me the orientation for the CPU?

Thanks

Classicsat
July 24th, 2003, 10:14 AM
Look on the motherboard. There is a silkscreen around the socket, one corner angled (Away from the ISA slots). Look on the CPU, one of the corners is cut off more that the others (lower left of the chip, looking at the top, with the text in the normal aspect)

Looking at the board, with the side that has the 8042 on it towards you, the CPU goes
in with the test on the cip in the normal aspect.

Old PC Man
July 24th, 2003, 11:55 AM
First let me thank you for your help.

When I look at the silkscreen on the motherboard, there are 2 corners that are angled. These two corners are away from the ISA slots and on the right side of the socket looking at the board from front to back.
This is confusing to me as both of these corners contain soldered conections that actually break the silkscreen. Also, I didn't find the 8042 you referenced which adds to my confusion.

Looking at the board from front (where the memory chip are) to back (where the keyboard plugs in) should the odd corner of the CPU be on the right side toward the back, or on the right side toward the front?

Thanks

Old PC Man

Classicsat
July 25th, 2003, 07:05 AM
The cut corner is towards the front of the computer.
The 8042 is the 40 pid DIP on the upper right most of the board (hides under the
PSU when installed), with the fron to the computer/ board towards you.

Erik
July 25th, 2003, 07:26 AM
This is probably a silly question, but how much damage would be done to the CPU if it was plugged in wrong?

Would it melt down or would the computer just not work until the CPU was properly situated?

Erik

Old PC Man
July 25th, 2003, 07:23 PM
Classcsat:

Many thanks for your patients and for the information provided. I plugged the CPU in as instructed and to my surprise the old PC booted to the ATDG206 Disk I downloaded.

Erik:

From everything I've heard, if the CPU is plugged in incorrectly it will damage the CPU. I've never plugged one in incorrectly, so I can't say for sure this is true.

Now for the next problem I'm experiencing.

The old 5170 has a WD 1003-WA2 Windchester/Floppy Drive controller. The floppies are working fine but my Seagate ST225 HD is not. I know it is not the HD. I tested the HD in an old IBM PC and it worked fine. I've double checked the HD Drive select setting and it's OK. I've changed out both ribbon cables and that didn't help. The controller seems to be communicating with the HD since the FDISK command worked. I just can't partition the drive. The HD just makes noise and then hangs. I downloaded some information on the controller from WD but the information WD provided doesn't match the controller I have. I noticed that pin 15 is missing on the 34 pin controller connection and pin 8 is missing on the 20 pin connection. I haven't seen this arrangement before and I'm wondering if special cables are needed.

I'm also wondering if the controller is for RLL Drives.

The CMOS drive I selected is type 2.

Any help on this problem will be appreciated.