View Full Version : problems starting up Commodore 64

January 29th, 2006, 08:38 PM
Please help me, my youngest sister just purchased a commodore 64 through an auction. I had one when I was a kid but the disk drive stopped loading, I kept all the games, the keyboard and the tv it ran on. I have hooked hers up and got the blue screen but under the "Ready" message there is no cursor, just the letter "Q" that won't budge. I have cleaned the keyboards it came with. The brown keyboard is the only one I can get the blue screen on (it came with that one and a cream one like mine). I have also tried my old keyboard but cannot get the screen up. I plugged my Lemans cartridge in and finally got that to play, on my 4th game it stopped working (the start line keeps flashing across the tv and the car wont drive). When I turned the computer off and on to reload it, still nothing, now I have removed the cartridge and my blue screen is back with "ready" and still no cursor, and now two lines down is the number 2. Can anyone help me, we've been trying to get it working for over a week, today was the first time we got the blue screen. thanks