PDA

View Full Version : Strange VGA Wonder Compatibility Issues With XTIDE



Holmes
May 13th, 2011, 02:44 PM
It's been a while since I last tangled with the issue of running a VGA wonder in my IBM 5150. My last VGA Wonder would run intermittently in this IBM PC (5150), but would run great in my XT (5160). It was an early revision with BIOS v1.00 (I believe).

So I just got another VGA Wonder, but this one is a VGA Wonder-16, V5 Rev 2 copyright 1989. My computer is an IBM PC Model 5150, with AST SixPakPlus, XT-IDE, 1.3GB hard drive loaded with MS-DOS 5.00.

All set? OK. The computer currently has an IBM EGA card with 64K VRAM and runs great. When I install the VGA Wonder, it identifies the monitor and drives it with no intermittent issues like I experienced with my previous VGA Wonder.

The BIG problem is that it will NOT BOOT from the hard drive driven by the XT-IDE! So here's what happens. When I boot the machine, it displays a single line at the top like "ATI VGA Wonder" + some version numbers. So far so good. Then it displays the normal XTIDE messages device ID messages, and comes up with the XT-IDE boot menu. Cool. I select the HD, and it says "Boot sector found", but then locks up. One time it listed 2 lines of garbage characters, but usually it just freezes for several minutes.

I here's what else I tried, and this gets really interesting. With the VGA Wonder in it, I boot to an MS-DOS 5.00 floppy. It boots just fine! When booting this way, I can access the HD, but it sometimes garbles the directory info. I ran a CHKDSK on it, and it gives tons of file allocation errors during the CHKDSK. Strange. I ran the VGA Wonder diagnostics, and the card passed 100% (all video tests and memory tests passes perfectly).

So I turn it off and put the IBM EGA card back in. It boots off the HD! I can run CHKDSK on it without any errors. I boot this configuration to the same MS-DOS 5.00 floppy I used before. Everything is the same, except the video card. It boots fine, and I run a CHKDSK on the HD and no errors at all.

I put the VGA Wonder back in. Again, I cannot boot from the HD. I boot to the floppy disk with MS-DOS 5.00 on it, and run a CHKDSK on the HD and again it gives me tons of file allocation unit errors.

So I stress that I'm doing the exact same thing, with the only difference being the video cards. It's very consistent.

I even tried disabling the AUTOEXEC.BAT and CONFIG.SYS so that it's booting a very vanilla MS-DOS on the HD. Still no difference.

What gives? Does this computer just hate VGA Wonders?

Does anyone have any thoughts or ideas?

modem7
May 13th, 2011, 04:40 PM
In the past few weeks, an AST SixPakPlus was found to be conflicting with the XT-IDE. The answer was to switch the XT-IDE to use a different I/O port range (with corresponding reflash of XT-IDE BIOS). See http://www.vintage-computer.com/vcforum/showthread.php?25146

You may have a similar issue, except that it's the VGA Wonder conflicting with the XT-IDE.

Holmes
May 13th, 2011, 07:48 PM
modem7,

Wow, that sounds like just the sort of problem I'm having. I'll try changing the I/O port range the next chance I get.

Thanks a million! I'll post a report after I give that a try.

Holmes
May 14th, 2011, 02:04 PM
OK, so it did not work.

I tried changing the XTIDE IO base address and control block address. I wasn't sure if control block address needed to be 200h or 8h above the IO base address (conflicting information - the XDTIDE.CFG program says 200h above, the universal BIOS website manual says XTIDE uses 8h above IO base). Anyway, I tried it both ways.

Here are the combos I tried:

IO base address / control block address
280h / 288h
280h / 480h
240h / 248h
240h / 440h

In all cases, it does the same thing. The moment I put the VGA Wonder-16 in, it locks up when trying to boot off the hard drive. When I put the IBM EGA card in, it works great with each setting.

Should I also be trying to change the BIOS memory address as well? I've been leaving that at D0000.

Does anyone have any ideas of what I could try next?

modem7
May 14th, 2011, 02:46 PM
Should I also be trying to change the BIOS memory address as well? I've been leaving that at D0000.
Certainly worth a try.


I wasn't sure if control block address needed to be 200h or 8h above the IO base address
It is 8h.

Holmes
May 14th, 2011, 06:30 PM
OK. So none of the attempts to change the IO base, control block address, or BIOS memory address worked.

For my last few attempts, I tried:

380h / 388h / D000 -> didn't even work with the IBM EGA adapter
380h / 388h / E800 -> didn't even work with the IBM EGA adapter
320h / 328h / E000 -> worked with IBM EGA adapter, but not with VGA Wonder

It's very frustrating. I'm beginning to think it's some quirk in my PC. It does do some strange behaviors with the IBM EGA adapter (like doing what looks like a full memory test even with a warm-boot), and intermittent working behavior with my other VGA Wonder, and this behavior with the XTIDE and the 2nd VGA Wonder.