PDA

View Full Version : Documenting OS/2 by linuxlove



Erik
August 4th, 2010, 09:38 PM
Category:Software
I got my copy of OS/2 Warp 3 Connect from Allen at The Vintage Computer Forum. This page documents all that I have done so far.
Opening the box
http://www.youtube.com/watch?v=C89h_HBJutc
Installation
Try 1: It didn't load on the first try after the first half of the install. Just showed a blinking cursor.

Try 2: Swapped out the 3GB hard drive with a 540MB one. Same result. After a while, it booted from the hard drive OK. Told it to use the Sound Blaster setting for sound and used the ATI Mach 64 driver. On boot, it gave config.sys errors (sound card improperly installed) and the locked up with a trap error due to the video card driver. Formatted and re-installed.

Try 3: Un-installed the Sound Blaster and set the video card setting to "ATI 28800". On reboot, I was waiting for the desktop to show up when the monitor lost power (while on) and I smelled something burning from it! Formatted the hard drive and tried again.

Try 4: Used the "SVGA (ATI)" option to make sure I didn't kill my other monitor! Came up just fine and I could use OS/2, but without sound.

Starting it
This video only shows how OS/2 starts up, it is not the first boot after installation.
http://www.youtube.com/watch?v=99JpLznplAA
Installing drivers
Tried installing the Sound Blaster option and found out that OS/2 does not support IRQ 2 for sound cards. Shut down and changed the IRQ to 7. It installed OK, but MIDI files are awful and have stuck notes when you end a song. IRQ 7 weirdness?
Allen was nice enough to send me some drivers for an ATI Mach 64 from the OS/2 BBS. Installed them and I got the same TRAP errer as before. Maybe the video card is funky?
Tried installing a Compaq Netflex card. Did not work, it just gave me an error of "Unknown error (205) generating response files.". Networking is not yet avalible. Official drivers from Compaq do not work.
Installing software
To date, the only thing installed is IBM Works.
a look at the OS/2 software repository
Getting used to OS/2
It's funny, it seems like you know it, but when you use it it seems so strange...
I find OS/2 quite usable and it has performed well on my Pentium 1 computer. There's not much to say here, because I have the basics down so far.
Problems
Power outage. The system wouldn't get past the blinking cursor after two cold boots. On the third cold boot when it still didn't want to load, I hit CTRL+ALT+DEL to reboot the system. Came up with []OS/2 onscreen and booted fine.