View Full Version : HDD Setup Problem On My System 310.

DOS lives on!!
August 4th, 2011, 06:02 AM
**Long story ahead**

This computer did work properly before with MS-DOS 4.01 on it.

Most of you probably know by now how long I've been dealing with my Dell System 310. (remember the blown power supply?) I like to keep vintage PCs in their original state, so I wanted to install Dell DOS 3.3 (thanks Russ). I'm now using a DOS 3.3 boot disk. I originally had MS-DOS 4.01 on it so I reformatted the hard drive to try to install DOS 3.3. I was using ANYDRIVE to use the hard drive and I think when I reformatted, it messed up ANYDRIVE. So, I went through ANYDRIVEs instructions on installing a new hard drive, and it still doesn't recognize it. I set a lower hard drive setting in the BIOS, checked anydrive's installation by running "ANYDRIVE S" after I restarted, and it said that the installation was successful. Then, I went into FDISK and set the partition active. However, I still can't access the hard drive. Running ANYDRIVE s again after a resart told me that some setting (maybe setting active partition?:confused:) had been changed and that the master boot block had been changed. When I looked at the partition information in FDISK, it displayed the settings and said, "Current Fixed Disk Drive: 1." Could it be giving info about the wrong drive since the HDD is drive 0 or is it just saying that I have one hard drive hooked up?

Here's what FDISK displayed for my hard drive settings,

Partition Status Type Start End Size
1 A Non-DOS 0 814 815What's it mean by Non-DOS?

I ran ANYDRIVE S on the first startup of today and the settings for Drive 0 (the HDD) and Drive 1 (not sure where it came from:?:) have the same settings. The settings are the correct ones for the Maxtor LXT-200A, but where is drive 1 coming from?

Who knows where it will go from here.;-)

DOS lives on!!
August 4th, 2011, 09:17 AM
A strange thing happened, I started it up with an MS-DOS 4.01 boot disk and the computer started right up!! I was able to see the hard drive and can now install things. Now, how am I supposed to get Dell DOS 3.3 on there by using the SYS C: command when I can't put a version of DOS that's older than the one it was started up with.

August 4th, 2011, 09:37 AM
It looks like you need to repartition with fdisk in DOS 3. Fdisk's Non-DOS designation means it doesn't recognize the partition type for whatever reason - and perhaps there is a difference between the partition table created under DOS 4 vs DOS 3 and it's not backwards compatible.

DOS lives on!!
August 4th, 2011, 09:42 AM
Everything is working now, so I'll just live with DOS 4.01 unless I can find a better boot disk. When I tried to create a DOS 3.3 compatable partition, it said, "No space to create a partition." When I tried to delete the DOS partition, it said, "No DOS partition to delete."

August 4th, 2011, 10:43 AM
DOS 3.3 has a 32MB max partition size.

DOS lives on!!
August 4th, 2011, 11:00 AM
DOS 3.3 has a 32MB max partition size.
The Dell System 310 originally came with a 20mb hard drive. I think the previous company used it as a server so they upgraded the hard drive. That's why the DOS 3.3 boot disk couldn't access the hard drive. And maybe that's why it didn't work on my Compaq Portable III when I put in a 40mb hard drive. Problem solved, thanks Russ and everyone else.