View Full Version : Dual pentium pro, HORRIBLE performance, can't figure out why.

September 16th, 2011, 07:48 PM
short story: irregardless of what I do, I cant get my dual p-pro system to work at an acceptable speed. Benchmarks @ 2.5 with memory throughput @ ~28mb/s. Regular Pentium comes in @ 147 and 70mb/s.

Long story: I just got in the voodoo 1 card for my "gaming" dual Pentium pro system and in attempting to install NT 4.0, I noticed it was taking FOREVER. I stopped it after EIGHT hours. I decide to run some benchmarks to see what was going on. Here is the "ideal" setup that I was shooting for:

Asus p65up5 motherboard with c-p6nd cpu card. (REV 1.41 and 1.2 respectfully)
512mb edo ram (8 sticks)
2x Pentium pro overdrives @ 333mhz
matrox G200 video card
voodoo 1 6mb
awe64 sound
3com 509b
IDE raid card LSI series 511

Naturally I pull everything to the bare essentials, and it still made no difference. re-setting the bios did nothing, nor did setting up the bios for "maximum speed". So I run some benchmarks too see whats going on, and this is the result:
And for comparison, here is how my 386dx40 does.

changing video cards made no difference. Changing the ram made no difference. (tried 5 sets)
I change the processors to 200/1m's
Then to 200/256k's

So I test another board. This time its a dual socket 7 with a pair of 200's and 512kb of total cache. Same video card, same ram.
You can see in the bottom right graph the cache working exactly as it should, a LOT different than the other board. Also, i know full well it says failed on the extended memory test, But that's a concern for a later day, as this board did this with EVERY set of ram that I have. (I'm running mem test right now to be sure, I THINK it has a bad socket)

I test a 3rd board, this time its a DIFFERENT p65up5. Its a rev 1.2/1.1 setup. it was NOT compatible with my 1mb chips but the scores were identical. I didn't bother to save any pictures of these.

September 16th, 2011, 08:26 PM
update, the dual Pentium has either a bad memory slot or something else wrong. the memory works without errors in other boards. hooray for memtest!

September 16th, 2011, 09:10 PM
Remember the old advice? read the F******* manual? Get this, just after the cache setting is a setting called deturbo. The manual says, turning this ON will essentially make your system run at 286 speeds. (I'm paraphrasing here) It also says the DEFAULT setting is OFF. Well, I go and check the bios, and its ON. on BOTH boards. Apparently in the latest bios, they changed the default setting from off to on. I tested this by resetting the bios. Here are the benchmark results!

2x 200mhz 256kb cache

2x 200mhz 1mb cache

2x 333mhz 512kb cache (overdrive)

If it EVER find the programmer at Asus that pulled this little stunt, I will get on a plane, goto his house, and KICK HIS DOG. I've been hitting my head on the wall from about 1pm to about 15 minutes ago. That said, I don't know if this is the drian bamage talking but having this fixed so I can get onto tackling NT4 does feel good.

September 16th, 2011, 09:36 PM
I was going to say it probably has a turbo setting somewhere.....

September 16th, 2011, 10:09 PM
Turbo settings make sense as a switch. But in the bios? This is the first Pentium I've owned that has that "feature" and seriously, why on EARTH would you do this? I mean seriously, who would drop $5000 on processors alone, then use a bios setting to make them run like a 286.

Oh well, I'm just happy its working now. I just need to remember to turn the deturbo off on my other board if I need to use it or sell it.

September 17th, 2011, 01:15 AM
Some real old software installers had timing loops that would crash the install, maybe it was a way around that? Anyway since you have it working no big deal.

September 17th, 2011, 01:25 AM
Also in the news, the dual Socket 7 tyan I have, the one that failed memory tests? Upon further examination it turned out that removing the cache resulted in the 100,000 errors by test #2 went to ZERO errors. Further trouble shooting revealed that the on-motherboard tag ram needed 2 jumpers to be enabled to be functional. This was not the case. Now I have the full 512mb of cacheable ram AND zero memory errors! WOOPIEE!! I'm 2 for 2 tonight!

September 19th, 2011, 02:27 PM
Do those Overdrive CPU's have full speed L2 cache like the original Pentium Pros?

September 19th, 2011, 04:45 PM
Do those Overdrive CPU's have full speed L2 cache like the original Pentium Pros? yes, they do