PDA

View Full Version : SE/30 and System 7.5 - newbie questions



tingo
September 21st, 2011, 12:50 PM
Today I bought a Macintosh SE/30. The seller claims it has 8 Mbyte RAM and a 30 MByte hard drive. It cam with System 7.5 installed (Norwegian - I prefer my operating system in English).
The floppy drive works, but sometimes I must push on the inserted floppy before the machine starts reading it.

The mouse is annoying; it moves up and down easily, but left and right only sometimes.

The "about Macintosh" claims that "total memory" is "20 480 kb" but that would be 20 Mbyte, right?
It also says "largest free block" is "6 370 kb".

Also Finder claims that the hard drive (named "HD") is "29,9 Mb" but has "279,5 Mb" free?

1) is there a tool that I could use to find out exactly what hard drive I have, before opening up this machine?
2) Are there any lists of "essential programs"or tools that a System 7,5 user needs?

commodorejohn
September 21st, 2011, 01:54 PM
Disk-insertion trouble isn't uncommon in old Macs; I don't know, you might try replacing the springs in the disk latch if it's really a problem for you. Your trouble with the mouse probably means its rollers are clogged; that's the downside to mechanical mice. You'll need to pop the cover off the bottom, take out the ball, and pick out the accumulated gunk from the rollers to get it working again. (On the bright side, as long as you keep them clean, mechanical mice last much longer than optical.)

20480 KB is indeed 20MB, but even a larger System 7 install shouldn't be eating up 14MB of RAM. I've had problems with this on my Mac IIsi before, and the solution was to go into the "Memory" control panel and turn on 32-bit addressing, but be warned! The SE/30 ROM is not 32-bit clean, so it's entirely possible that doing this will crash the computer. You can solve this by replacing the ROM SIMM on the motherboard with one from a Mac IIfx, I'm told, or there's an extension called MODE32 (http://en.wikipedia.org/wiki/MODE32) that will fix it.

The disk space thing is a little confusing, but what it actually means is that 29.9MB is used (in the English version it would say "29.9MB in disk," and then to the right "279.5MB available.") You can find out the exact disk capacity with the Drive Setup program.

For essential programs, you'll want ResEdit for file-type finagling and general hackery, and StuffIt Expander (thrice-damned tho it be! for its proprietary nature) for unpacking archives. Unfortunately, if it isn't already installed and you don't have another Mac with which to take care of this, it is a royal pain to bootstrap StuffIt on there. I can't even remember how I originally did it...

Congratulations on your acquisition!

Anonymous Freak
September 22nd, 2011, 09:10 AM
Mode32 is the only realistic option to pursue. It is possible to use the ROM SIMM from either a IIsi or a IIfx, but both are harder to find than hens' teeth nowadays, and it turns the "host" machine into something unusable..

WITH Mode32, an SE/30 can address up to 128 MB of RAM just fine. No problems in 32-bit mode at all.

RWallmow
September 22nd, 2011, 06:10 PM
The floppy drive works, but sometimes I must push on the inserted floppy before the machine starts reading it.

The mouse is annoying; it moves up and down easily, but left and right only sometimes.
The floppy drive rails just need to be greased with some silicone grease, WD40 WONT do (however it will help clean up the old dried up grease). Be VERY careful working on the floppy drive NOT to pull up on the top read/write head, the spring on it is EASY to stretch and then it will NEVER read/write disks ever again.

The mouse is like any other mechanical mouse, clean out the gunk and it will work fine. If that's a problem optical ADB mice are out there (not as common as USB or PS2 ones, but they exist, just be careful, early ones need special mouse pads). EDIT: There's also ADB to PS2 converters out there (meant to connect macs to PC KVMs) that should allow you to use a PS2 optical mouse on a mac (I have one made by belkin, I use it to connect my non-USB beige G3 to my PC KVM).

And I second the congrats, I have been trying to find the right SE/30 for myself lately ;-)

geoffm3
September 23rd, 2011, 01:16 PM
I had the same problem with my floppy drive. The white lithium grease they used to grease the mechanism was all dried up. I partially disassembled the loading mechanism and used some solvent to remove the old grease and lubed it back up. Works good as new now.

tingo
September 23rd, 2011, 04:20 PM
Mouse: the thing that surprised me was that the mouse was actually very clean inside. No dust, no gunk, no hairballs. also, the ball felt ok. In the end, I cleaned the mouse ball with water, and that has improved it so it is useable again. Yes to proper things - things that are held together with screws so you can disassemble them and assemble them again.

tingo
October 20th, 2011, 02:55 PM
HFS format floppies - I read somewhere on the net that a machine running OS X up to version 10.4 could write HFS format floppies, even with a usb drive. I have a Mac mini G4 with OS X 10.4, and a usb floppy drive. Short story: it works, I can now copy files onto my SE/30. Yay!

One of the tools I need is Stuffit Expander. I have found a "stuffit-expander.sea" file, transferred it to my SE/30 (which still runs System 7.5, Norwegian), but when I double-click on it, nothing happens.
I thought *,sea files were self-expanding archives?

commodorejohn
October 20th, 2011, 03:09 PM
They are, but Mac OS needs the file type set correctly so that it knows they're executables. Unfortunately, there's no built-in facility to do this, which is the biggest catch-22 in the whole process. ResEdit can change file types, but of course you need to get ResEdit on the Mac with its file type intact.

Luckily, your G4 is already using the HFS+ filesystem, and one would assume that it writes file-type information correctly to HFS floppies, so I would assume that all you need to do is find a file-typer utility for 10.4, change the type code for the .sea file, and copy it over, and you should be in business.

tingo
October 21st, 2011, 10:12 AM
Ah, I had forgotten about file types and creator codes. I found FileType (http://www.frederikseiffert.de/filetype/), put it onto my Mac mini, changed a few files to filetype "APPL" (the program requires that I change Creator code to, so I set it to "----"). I have tried with several programs, including those from http://lowendmac.com/compact/68ksoftware.shtml.

The SE/30 recognizes them as applications / programs, but when I double-click on them, I get an error message saying that the program couldn't be opened because of an error type -39 (in Norwegian: 'Program "XXX" kunne ikke pnes fordi det oppstod en feil av typen -39.').

I have Googled, but couldn't find anything about error type -39.

commodorejohn
October 21st, 2011, 10:44 AM
Looks like error type -39 is a corrupt or truncated file. Just to be sure, the floppy you're using to transfer is HFS-formatted?

RWallmow
October 21st, 2011, 11:00 AM
Looks like error type -39 is a corrupt or truncated file. Just to be sure, the floppy you're using to transfer is HFS-formatted?
And that the disk itself is good with no bad blocks/sectors.

On that note I have had good luck with reformatting disks several times in a row on the older sony mac "superdrive" (like what is in the SE/30) floppy drives to clear up one or two bad blocks, the newer mac (and other brand external USB drives) just don't seem to have as strong of a write head and seem to lay down a "weaker" format on the disks. This is why I usually use my SE-FDHD or another old mac for making all my apple disk images.

tingo
October 21st, 2011, 12:26 PM
Yes, the floppy is HFS-formatted. I did it myself using Disk Utility on the Mac mini. I tried several floppies; this is one of the good ones (Disk Utility would reject the bad ones).