View Full Version : Help with a XT/286

March 13th, 2006, 04:25 AM
My problem regards an old IBM XT/286 that I'm trying to get to work again, after nearly 10 years spent in the basement. When I turn it on, it boots up almost correctly, it does the POST, finds the 640k+512k extension memory, and the two floppy drives. And it stops there. If I insert a DOS floppy, it finds it, but it doesn't ever find the two harddrives (c:\ is unknown). I've checked the connexions, and tried a lot of combinations with the different cables, but still no result. My guess is that the controller card where I plug in all the drives must have a problem, since sometimes, it indicates "Controller #0 error". :(
What do you think is wrong is it ? Also, I have tried using a controller card of another IBM, an AT/286, but I get no results (but I've heard there were some compatibility issues with certains parts between ATs and XTs...)
The BIOS asks me what type the harddrives are; one had a sticker on it with "type 5" written on it, and the other one (the "big" 20mo one) had nothing on it, so how could I find this ?

Thanks. :D

Terry Yager
March 13th, 2006, 01:35 PM
My best guess is that the 20Mb drive will be 4 Heads, 612 Cylinders, and 17 SectorsPerTrack (Type 2?). That geometry is very common among the various 20Mb drives of that vintage. I'm also guessing that you have no problem except a dead CMOS battery. When you figure out the drive type, it should be bootable from the C: drive. That model only supports a very limited number of drive types, so simple trial & error should get you there very easily.


March 14th, 2006, 09:27 PM
Thank you for your answer ! :D I'll try replacing the CMOS battery as soon as I find one. Also, do you how I can access the BIOS on the AT/286, because it keeps telling me "Memory Error, run SETUP" but I can't seem to go there (whereas I just had to do ctrl+alt+esc on the XT). The rests boots just fine, but apparently I have to configure the extra 512k extension RAM. :confused:

Terry Yager
March 15th, 2006, 09:20 AM
Those IBM machines do not have a setup program stored in ROM. You have to run the setup program from a disk.


March 15th, 2006, 12:56 PM
Oh, well I'll try and find one of those then...:D
~Thanks for the reply !

March 20th, 2006, 04:34 AM
It sounds like you are having some of the problems I was having with my XT-286 a few weeks ago. In my case the battery was dead and so the CMOS had lost all the BIOS settings. I used the GSETUP31 utility, which can be obtained from http://www.simtel.net/pub/pd/50318.html.

This utility will allow you to specify [1]Time, [2]Date, [3]Floppy A, [4]Floppy B, [5]HD1 C:, [6]HD2 D:, [6]Base memory, [7]Expansion Memory, [8]Math Coproc and [9]Display.

Using GSETUP31 is quite straightforward, and if you know the Type number of your hard disk then once you have entered that number and restarted your XT-286 it should access the hard disk. (My only reservation about GSETUP31 is its fixed increments for Expansion Memory - they do not allow zero to be set; I had to disconnect the battery to clear the CMOS in order to get this set to 0 after I made the mistake of trying to insert a value.)

It sounds like you have the Type number for one of your disks (5), and if you don't know the correct Type number of your hard disk you could make an educated guess from the corresponding Cylinders/Heads details that are shown. Hopefully this will allow you to get the C: prompt to appear.

-- Iain

March 20th, 2006, 10:47 AM
:) Thanks for the tip; I had indeed downloaded that little program which ultimately allowed be to boot to C:. Unfortunatly, I think the CMOS battery died yesterday, seeing as though it gave upon booting an "Error - Options Not Set". But the problem is...even though at first it gave me the opportunity to press F1 to continue, and eventually landed either on the Basic editor or "a:" , now it just gives me the error and stops there; it doesn't even try to boot anymore. I tried replacing both disquette readers, which I suspect were also partially dead (unable to execute anything), and removed the harddrive, but still no effect. :eh:

Should I assume I'm right and replace the CMOS battery ? Cause even though it's a problem, I thought I'd be at least able to boot, and re-set the options manually each time if necessary, but now, this doesn't seem possible anymore...:confused:

Terry Yager
March 20th, 2006, 11:31 AM
Sometimes power to the CMOS is maintained temporarily by capacitors. You may have to leave the battery out of the machine to allow the caps to bleed-down. A few hours is usually sufficient to reset the CMOS, but make it 24-or-so, just to be safe.


March 20th, 2006, 02:18 PM
Ultimately if you are determined to get this XT-286 running again you are going to want to get a replacement battery. (I was surprised to find how easy it was to get a replacement; I believe it is still used in a number of photographic applications). Once you have a new battery and working CMOS you will be able to set and retain your BIOS settings, which will help eliminate some of the random responses you have experienced at boot up.

Although my machine did manage to detect a single floppy drive when it's battery wasn't present, it was only able to see a second floppy and access the hard drive with a new battery in place and the correct hard disk Type entered in the CMOS.

-- Iain

March 20th, 2006, 07:35 PM
From my experiences, the old xt hardware is very sensitive to problems with the cmos battery. You can get an external rectangular cell(3.6v) on ebay, there should be a connector for it on the xt board, that is what I usually do, also, I remove the old presoldered battery, because it can corrode the board.

Here is the type of battery I am talking about.
http://cgi.ebay.com/TL-5242-B-200-CMOS-3-6V-Battery_W0QQitemZ8782420295QQcategoryZ51110QQssPag eNameZWDVWQQrdZ1QQcmdZViewItem

March 21st, 2006, 01:22 AM
Ok, I'll surely be doing that, since it only gave me those "random responses" today, after disconnecting the old CMOS battery for a couple hours.
At first, it showed improvement, though, since it prompted me to continue by pressing F1 again :) (and landed most of the times in the basic editor). After a lot of reboots, it finally accessed the floppy with the setup for the CMOS. But after setting up the CMOS, and reconnecting the old battery, it started acting weird, giving me random keybord errors, no more "Options Not Set" ones, and ultimatly all it does is count the memory, and just stop there. :confused:

So for now I've disconnected again the old battery, until I can find a new one. But since it's more than 20 years old, I don't really blame it to die now...:smile:
By the way, batteries from ATs and XTs are the same, right ?


March 21st, 2006, 02:04 AM
The CMOS battery for an XT-286 is a 6V 1450mAh lithium unit which is housed in a compartment on the back panel of the computer. It is connected to the motherboard by a flying lead from the battery compartment to a push-on connector. An example of the battery can be seen at http://www.interstatebatteries.com/Batteries/ProductLines/OtherProducts/ProdLine_LIT2075.htm. (The earlier PC-XT did not come with a battery as all its BIOS settings are retained on DIP switches).

-- Iain

March 21st, 2006, 03:32 PM
The CMOS battery for an XT-286 is a 6V 1450mAh lithium unit which is housed in a compartment on the back panel of the computer. It is connected to the motherboard by a flying lead from the battery compartment to a push-on connector. An example of the battery can be seen at http://www.interstatebatteries.com/Batteries/ProductLines/OtherProducts/ProdLine_LIT2075.htm. (The earlier PC-XT did not come with a battery as all its BIOS settings are retained on DIP switches).

-- Iain
I haven't seen a xt with that kind of battery, the 3.6v I posted is what I usually see, what brand xt takes the 6v?

Micom 2000
March 21st, 2006, 07:03 PM
One of my greatest discoveries was an AT clone which had sockets for AA bateries. Why bother with solder-in batteries when you can simply solder in a socket and when the bloody battery fails, you simply replace it with one that meets the voltage requirements of your box. Many camera batteries fulfill the requirements of even the strangest machine.


March 21st, 2006, 07:20 PM
humm, good thaught, but usually people want their vintage stuff to be original or era based, right?
Stuffing a camera lithium cell retainer in the board would look kind of out of place?

March 21st, 2006, 09:57 PM
I managed to find a spare battery , so for now (if it lasts) that should take care or the problem. However, it appears that both hard drives (20 mo) died, since the one that worked fine until now started making a real strange noise and only launches the beginning of DOS, then crashes, and the other one is "unusable", since it has too many bad sectors (can't even be formatted!).

So, does anybody know where I could find one of these ? I tried eBay, but I only managed to find relatively-recent ones, in IDE.


March 22nd, 2006, 01:54 AM
Hi alexkerhead, you asked about the battery type used in the XT's. This is a summary of their battery configuration.

The PC (5150) and PC-XT (5160), with 8088 processors, have no batteries as they do not use CMOS memory for their BIOS settings; their BIOS settings are simply retained on mechanical DIP switches. The PC-AT (5170) and XT-286 (5162) that followed, using 80286 processors, made use of CMOS memory for the BIOS settings and required batteries to maintain the contents of that memory.

The PC, PC-XT and XT-286 all look very similar from the front with only the small print on the IBM badge confirming the identity of the unit. However, the rear panels distinguish between the different units: the PC has a cassette DIN connector next to the keyboard DIN connector, and the XT-286 has a battery compartment door in the middle of the panel. The PC-XT has neither of these features.

You listed a PC-AT (5170) amongst the computers that you own. This machine is fitted with the 3.6V 1900mAh battery that you have referred to. The PC-AT is significantly larger than the PC, PC-XT and PC-286, and is of a more box-shaped design.

The battery in the XT-286 has IBM part number 72X8498 and is a 6V twin cell design different from that used in the PC-AT. The following is a list of equivalent XT-286 batteries from different manufacturers:
Duracell DL223A, EverReady EL223AP, Kodak K223LA, Varta VL223, Panasonic CR-P2, Sanyo CR-P2 and Ray-O-Vac PC223.

-- Iain

March 22nd, 2006, 06:33 AM
Thanks for the info.
The IBM 5170 is among the units that haven't arrived yet, due to heaviness, the shipping is taking a while, when it is here, I will take a look.
Shipping has taken longer than expected.
That is a strange battery configuration nonetheless.
I currently do have a custom XT unit using an IBM 5170 mainboard, and the 3.6v cell I used seems to work, is this wierd?

March 22nd, 2006, 11:18 AM
If you have an XT case with an AT 5170 motherboard it must be quite a customisation. As I understood it, one of the reasons for the increase in size of the AT was that it had to accomodate a larger motherboard, designed around the 80286, that could not fit in an XT case.

If it is a 5170 board then it's CMOS is designed for 3.6V and it will be quite happy with the battery you have connected up to it.

Perhaps you could relieve my curiosity by providing a few more details about the configuration of your customised XT?

-- Iain

Terry Yager
March 22nd, 2006, 12:13 PM
Pictures would be nice too.


March 22nd, 2006, 06:54 PM
my digicam was stolen, but I have an old image of the board itself.
Have you never seen a xt case with the distance for the top part of the board wide open?
Or, you may be right, I might have confused a really old at case for an xt case, if so, I apologize.
I do recall however some magnatron systems having the tall xt configuration.
It fits like a at, but has an extra 5 or 6 inches above the kb connector.
I still need a xt keyboard to use it, it acts wierd with an at kb.
Also, you'll see my signiture mentioned ibm model 25, one of my favs.
She is a beauty isn't she?

April 29th, 2006, 07:38 PM
Where is the cmos battery on an IBM PS2 25xt. Icouldn't find it but it may help my situation.

April 29th, 2006, 08:06 PM
I couldn't find one on my model 25's board, not even a real time clock chip.
Perhaps it doesn't have one onboard?
It does have a four pin connector for a external cmos battery.

Terry Yager
April 29th, 2006, 09:12 PM
It's a PC/XT-compatible, which doesn't store setup info in CMOS RAM, so no need for a battery, unless for an RTC. It isn't MCA, so no need of a Reference Disk to configure it. Tha Starter Diskette is just diags & some other utils.