View Full Version : Transwarp GS stopped working?

November 16th, 2011, 05:22 PM
So I have a Transwarp GS, had it for quite some time and always worked fine. So I was planning on upgrading it a little by replacing the 8k cache card with a 32k cache one. I removed the daughter card just to see what the connectors looked like on the backside in preparation for the replacement. I then put the card right back in, nice and tight, but now the transwarp wont start up! I didn't break or insert anything wrong so what gives? The green led light goes on, but the iigs doesn't recognize that it has a CPU. I then swapped out the transwarp with the 2.8mhz CPU and the machine works fine, so something happened to the transwarp. I pulled out and pushed back in the oscillator, took out and pushed back in the cache card again... nothing... Any help would be greatly appreciated.

November 16th, 2011, 06:21 PM
These cards are very fussy. The CPU cable and the IIgs's CPU socket can be suspect areas. My card was very flaky (checkerboard screen on boot) until I replaced the CPU cable. The socket itself can also wear out (contacts bend in too much), which causes a problem with the stock CPU cable because its pins are so small. If possible gently remove the CPU cable from the TWGS and reseat it. A fried crystal oscillator will also cause similar problems. The stock one on my card was a full TTL part with extension leads on one end (the card has a half TTL socket). They are very sensitive to static electricity damage, or even physical damage because the leads aren't all that big or sturdy.

My machine still crashes from time to time, but that is heat and power related (stock PS is weak). Downclocking it to 9Mhz seems to have solved it for now.

November 16th, 2011, 06:35 PM
Yeah, I also ruled out its not the CPU socket on the mobo (cause I have a spare IIGS and tried the transwarp on there too). Before removing the cache daughter card, I did physically touch the oscillator, so I suppose it's possible I shocked it. But I have a spare compatible oscillator and it still doesn't work. Do you think I could've shocked the cache card? If I did, would replacing that card work? (Cause like I mentioned, I was planning on upgrading to a 32k cache one anyway:) ) However, I don't want to spend the money if its something else. Let me ask you this, if you remove your cache card and turn on your IIGS, does your IIGS still startup? That can help me narrow down the issue.

November 16th, 2011, 06:46 PM
No, it won't startup because the ROM for the Transwarp GS is on the cache card.

November 16th, 2011, 06:49 PM
Bingo then, it must be that. Now I just have to find someone locally with a transwarp and let me try his cache card on mine and see if it works.

November 17th, 2011, 10:10 AM
So I took out the cache card and gave the contacts a good cleaning last night and put it back in this morning and voila! It works. Phew.

November 17th, 2011, 10:46 AM
So I took out the cache card and gave the contacts a good cleaning last night and put it back in this morning and voila! It works. Phew.Thats some good luck, TWGS cards are harder and harder to come by, I have been wanting one for the past 15 years (just cant justify the prices they go for, but I keep buying up IIgs's hoping one day I will find one too, lol)