View Full Version : Need help replacing HD on Macintosh Classic

December 1st, 2011, 11:20 PM
Alright, I'm going to take a stab at posting in the forum here as I've been racking my brains on this for about a month now.

First off, I'm a computer hobbyist, used to be into C programming in high school, ran a BBS, etc. However, I hadn't done that stuff in almost 20 years, and have lost a bit of the really technical knowledge I once had.

Fast forward, I've gotten this bug all of the sudden in the past few months to collect old computers, get them working, refurbish them, etc.

So I got this Macintosh Classic, the Classic I, not the II. A kid sold it to me on Craigslist, with the keyboard and mouse, non yellowed, for only $35! Plus it had some software with it as well.

He said that he suddenly had gotten the picture of the disk with the question mark, so obviously the cpu couldn't find the OS. I didn't have the 800k disks for any of the OS so I won all of the original System 7 with manuals on ebay.

When I put in the Disk Tools and tried to find the drive, it said it couldn't find a suitable SCSI disk...so it's not recognizing the internal HD. Got a new internal HD. It's a 2.1gb Seagate instead of the Quantum 40MB.

Still couldn't find it. Noticed there were no SCSI transistor/terminators on the drive. Bought a passive terminator for the cable. Still doesn't work. Tried putting the old drive in and tapping it, as some people said sometimes the drive gets stuck, didn't work.

Anyone have any ideas why it's not recognizing it? I looked up the jumper layout on Seagate's website to figure out where to put those, it's supposed to be Device 0 correct?

Anyone who has any insight into old SCSI setups or this exact same situation, or knows someone who does, PLEASE help me. This is driving me insane.


December 1st, 2011, 11:38 PM
I have a Classic I with somewhat the same issue. Haven't had the time to tackle it yet but hope to soon.
One thing you could try is to track down an external SCSI drive and try installing System 7 there. Then you could swap one of your drives into the SCSI drive enclosure and see if those are recognized there.
I don't know if it's supposed to be device 0, I'm not sure but I think it just has to be lower than other SCSI drives in the chain.
Does System 7 have a bootable disk tools disk? I remember using a utility to format a SCSI drive before doing the install.

December 2nd, 2011, 12:43 AM
Yeah I have the System 7 Disk Tools disk. I wrote above, that when I put it in, it "can't find a suitable drive on the SCSI connector."

So, I'm not sure exactly where to start. The actual NEW drive I have is here: http://www.seagate.com/ww/v/index.jsp?name=Legacy&vgnextoid=76d95a802efbd010VgnVCM100000dd04090aRCRD&vgnextfmt=default&capacity=&model_number=ST32109N&pf=1&prodfinder_button=1&locale=en-US&product_select=all_product&localePath=en-US&interfaces=&reqPage=Legacy

So I'm not sure which jumpers are supposed to be set where, etc.


December 2nd, 2011, 01:06 AM
Also, I noticed that I had ordered and attached a PASSIVE SCSI terminator, and Seagate said something about having an ACTIVE terminator, so I just ordered one of those as well.

It never hurts to have any of this stuff on hand regardless. Maybe that could be part of the issue?

December 2nd, 2011, 04:40 AM
Youll need a Patched HDSC Setup to recognize non Apple drives.. the HDD inside should be SCSI ID 0. Use CMD Option X O to boot it into ROM, itll at least give you a basic OS to use to troubleshoot your drive. Or if you want just an Apple ROMed drive thatll plug and play.. I got plenty.. an 80mb will do that classic nicely.. You could have it for the cost of shipping..

December 2nd, 2011, 08:14 AM
How to patch the disk for non apple scsi drives: http://www.euronet.nl/users/ernstoud/patch.html

December 2nd, 2011, 11:21 AM
Thank you so much for the help everyone. It's appreciated.

December 2nd, 2011, 11:33 AM
None of the links work on this page, but I'll poke around for it and see what I can make happen.

December 7th, 2011, 11:13 PM
Guys. I'm seriously at a loss at this point. I keep getting the same message that it cannot find a suitable SCSI drive. I ordered an Apple branded SCSI quantum fireball drive that's 1.2gb. System 7 can support up to 2GB.

If someone has one of these and can explain exactly what to do, it would be super helpful. Is it Device 0 if there's only the stock floppy, and then the hard drive? I really am stumped here. I have an active terminator as well, should that be on there?

If anyone lives in the Hollywood, CA area, I'll give you $20 to come by my apartment and check it out really quick. LOL. I just need to know what I'm doing wrong here.

December 8th, 2011, 01:18 AM
it shouldn't be the internal battery right? that should only make me have to keep selecting the hard drive as the boot disk...

HD SC should always recognize it if it's attached, right?

December 8th, 2011, 02:23 AM
If you have another computer that uses SCSI I would check to see if the drive works or if it's a defective drive.

As far as I know it shouldn't be the battery since that won't, to my knowledge, control hard drive detection.

If I remember I'll dump the FWB Hard Drive Toolkit off my old Supermac C500e install disk, it should work under 7.5 and it also supports non-apple drives.

December 8th, 2011, 09:59 PM
I'd appreciate it. I just picked up an old PowerMac G3 today with a floppy drive and ethernet built in, so I can actually get stuff onto floppies.