View Full Version : Moving files from Power Macintosh G3 Beige to Macintosh Classic Via Floppy

December 15th, 2011, 12:10 AM
So I'm still having trouble getting my Macintosh Classic to recognize a SCSI drive (Apple branded or not -- another thread). I'm waiting for a PRAM battery to see if that has anything to do with it.

Some people have recommended other tools like SCSIProbe and Lido.

I picked up a Power Mac G3 tower with a floppy and CD rom drive for a steal, so now I have a diskdrive to make floppies on using DiskCopy in OS 9.2.

Can someone who knows what they're doing explain how I can get the compressed .sit.hqx files onto a disk on the PowerMac and readable on the Mac Classic when I boot into the system firmware so I can run the apps?

I've tried using DiskCopy after uncompressing the file and creating an image out of that app, then trying to "make a floppy" using that image.

OR, just dragging the uncompressed app onto the floppy.

Every time I try to open something on that disk on the Mac Classic, it just says "{application name} could not be opened/printed (the application is busy or missing)"

I read somewhere that has something to do with resource forks vs. resource files, I don't know. I just glanced over it on a message board.

Can anyone give me a quick step-by-step on how to make this happen? This has been a 5 week project now. Haha.


December 15th, 2011, 04:58 AM
.sit.hqx files are compressed with Stuff-It. You need Stuff-It Expander to uncompress them into the actual programs or disk images. Since you now have the G3, use it to format the SCSI drive. I think the versions of HD Setup that came with OS9 no longer have the silly Apple only drive restrictions.

December 15th, 2011, 06:19 AM
I believe OS 8 dropped that Apple drive thing, I know my clones run OS 8 using a retail disk with no hacked formatting programs or installers, but 7.6 had to use a special program to format the drives.

December 15th, 2011, 09:49 AM
Would it be possible to network them via AppleTalk?

December 15th, 2011, 09:49 AM
Okay, so I put the drives (I now have 3) in my PowerMac, and it recognized all of them and I initialized them, but the Mac classic doesn't recognize them at all. One of them doesn't even spin it sounds like.

I had taken the PRAM battery out to replace it, there isn't one in there now. Would that have anything to do with it not recognizing any of them, or any other ideas?

December 15th, 2011, 10:12 AM
I lied the old PRAM battery is in there...but probably dead.

The guy I got it from said sometimes it booted into OS 6, sometimes it didn't. Then it just stopped altogether. I thought it originally was the original HD that was in it, so I got a replacement, then realized it wasn't an apple branded one, and got another.

So yeah, it's just not recognizing any of the drives, they sound like they're spinning a lot faster in the G3 and the needle is moving a lot more.

Not sure exactly what it could be.

December 15th, 2011, 11:41 AM
Would it be possible to network them via AppleTalk?
This is exactly what I was going to ask about. Have ADB will travel! Better yet, ethernet if you can swing it. Any cabled network is the way to go here.

December 15th, 2011, 11:39 PM
Alright, the battery wasn't an issue. I have literally no idea what's wrong with it.

It will not recognize ANY hard drive.

December 16th, 2011, 06:27 AM
At this point I would 1st check the SCSI cable, make sure that isn't your error. If you have another cable I would check that to see if it was bent at some time and is no longer in functioning condition.

December 16th, 2011, 10:17 PM
Checked the cable with a cable I had in my G3 that I was sure worked. Doesn't recognize any of the drives.

The original drive that was stock that came with it and I thought was bad, works in the G3...so it's not the drive.


December 16th, 2011, 11:52 PM
Do ANY of the drives work in the G3?

December 18th, 2011, 12:02 PM
ALL of the drives in the G3 work. It's the Mac Classic that doesn't work. I'm using the G3 to test the drives that I was trying to put in the Classic that weren't working, and ALL of those drives work in the G3.

Someone suggested trying a terminator on the external SCSI terminator, as the internal one may have failed or something. I'll have to try that when I get back from Chicago for the holidays.

If the SCSI controller failed, looks like i'll have to get a new classic from somewhere that works and isn't 100 dollars.