View Full Version : Installing AT&T UNIX System V/386

January 22nd, 2012, 10:49 AM
Today I put together an Intel 386DX-33-based system, and thought about trying something else than DOS/Win3x. So I started it from the first disk of an AT&T System V/386 floppy image set that I found somewhere online, just to see what happens. What happened is in the attached photo (sorry for the poor image quality, I used my cellphone to take it), and I'm wondering if there's something I can do about the HD controller panic issue...

Controller is this one - http://stason.org/TULARC/pc/hard-disk-floppy-controllers/C-D/DIAMOND-FLOWER-INC-Two-IDE-AT-Interface-drives-MIO-23.html - and the hard-disk is some 1GB Seagate "prepared" with Seagate's flavour of Ontrack Disk Manager.


January 22nd, 2012, 10:57 AM
Why are you using such a HBA card?

Does the motherboard not have onboard IDE?

January 22nd, 2012, 11:25 AM
No, it doesn't (Gigabyte GA-386UM REV.2). I don't think I've ever seen a 386 mobo with on-board IDE...

January 22nd, 2012, 03:32 PM
Was the disk placed in the drive after or before the "Insert boot disk and press space bar" or similar prompt?

January 22nd, 2012, 03:52 PM
1GB for a hard disk (it shouldn't matter if it's integrated or not) is pretty large for that time. You may want to start with something in the 100MB range.

January 22nd, 2012, 04:17 PM
Does DOS 3.3 install successfully on that 1GB HDD?

January 22nd, 2012, 04:35 PM
... I don't think I've ever seen a 386 mobo with on-board IDE...Then you've lived a very sheltered life ;-)

January 22nd, 2012, 10:37 PM
The floppy disk was placed in the drive before Ontrack's "press space bar" prompt, but first boot device in BIOS was always C:... damn, I should have tried A: first, to bypass Ontrack... oh well, there's always another day.

Getting a small (a couple hundred megs) HDD is on my list for quite a while, but no luck yet... I haven't tried DOS 3.3 yet, but 6.22 installs without any hitch.

Then you've lived a very sheltered life ;-)

Maybe... but I'm not afraid of the Great Unknown, so enlighten me please... :D

January 23rd, 2012, 01:32 AM
Try to boot the first disk at the space bar prompt, press the space bar and see what happens.
When using a 4 gig drive with overlay software in my 386 using OS/2 v2 installation disks it recognises the drive as 4 gigs using this method. If used before that there's just sys errors

January 23rd, 2012, 01:51 AM
This is the approach that leads to what's described in the first post - mainboard's BIOS is set to boot from C: first, Ontrack takes over and offers the "space bar" prompt, I hit space to boot from floppy, then things become a bit weird: it reads something from the floppy disk then some sort of quick reset happens (I get the Trident VGA BIOS screen, but not the mainboard's BIOS screen), then it continues reading the floppy, displays "Booting UNIX system" (or something like that) for one or two minutes while doing some more floppy-reading, then the screen in the first post.

What I will try later today is have the mainboard's BIOS boot from A: first, so that Ontrack isn't loaded anymore...

January 23rd, 2012, 11:28 AM
I think your On-Track software is probally messing you up. Try letting the computer bios directly reconize the drive and set up the cyls,hds,etc. You'll probally find that it'll only reconize the first 1023 cylinders and set the drive up as 512 mb in lieu of 1 gb. Then try installing the Unix. You could also probally set the drive up manually in bios as a small drive. When Unix takes over after the boot disk, it wants to directly access the hard drive through the bios. Any re-mapping of cyl/hds to a larger drive space will create problems.

Where did you get your disk images? I'd like to try them in a virtual machine.


January 23rd, 2012, 11:39 AM
Is there any way to "unprepare" the disk -- remove ontrack? Your drive capacity will be lower, but that's what you want. Ontrack was meant for DOS; I've never seen it used successfully with other OSes. Maybe Linux works with it nowadays, but back in 1994 it certainly didn't.

January 23rd, 2012, 11:42 AM
Try booting from floppy and zeroing the first sector on the hard drive. That should turn off OnTrack and let you get on with your life. You can also try this. (http://support.microsoft.com/kb/73253)

January 23rd, 2012, 12:01 PM
Where did you get your disk images? I'd like to try them in a virtual machine.

I also have it, I downloaded it from a web site devoted to abandonware. I can not remember where it was.

You can also find it in the eMule network: search for this:

ed2k://|file|ATT-Unix_SVR4_v2.1.rar|8189309|2C04BF823D80EB993AF02A3 8C0287CF5|h=IIAJ4LI3GOOAQC6NPDBV66K4VWLIYWKR|/

It contains this:

AT&T UNIX System V Release 4 Version 2.1

It's UNIX. If you need more info, you don't need this Operating System.

Here are 3.5" 1.44 MB image files with DCF extension and must be copied to
diskette with CCOPY.EXE

Sorry that the Copy Program is in German but the supplier was that mad.

Get 30 3.5" formatted floppies.
Run CCOPY.EXE (Hit a key to go past the intro screen)
Press F2 to copy files to disk.
QUELLE is source
Choose any filename
ZIEL is target
Choose 3.5" FD
GO and have fun!

LABEL Version X of X
AT&T UNIX SVR4.0 2.1 --------------------------------------------------

U01.DCF Maintanace Disk1 2.1 2 of 2
U02.DCF Remote Terminal 2.1 1 of 1
U03.DCF BSD Comp. Pkg. 2.1 1 of 2
U04.DCF BSD Comp. Pkg. 2.1 2 of 2
U05.DCF Networking Supp. 2.1 1 of 1
Util. Pkg.
U06.DCF Xenix Comp. Pkg 2.1 1 of 1
U07.DCF FACE Pkg. 2.1 1 of 1
U08.DCF FMLI Pkg. 2.1 1 of 1
U09.DCF Editing Utils. 2.1 1 of 1
U10.DCF OA&M Basic & Ext. 2.1 1 of 3
U11.DCF OA&M Basic & Ext. 2.1 2 of 3
U12.DCF OA&M Basic & Ext. 2.1 3 of 3
U13.DCF Foundation Set 2.1 1 of 10
Base System Pkg.
2 User System
U14.DCF Base 2.1a 1 of 10
U15.DCF Base 2.1 2 of 10
U16.DCF Base 2.1a 2 of 10
U17.DCF Base 2.1 3 of 10
U18.DCF Base 2.1 4 of 10
U19.DCF Base 2.1 5 of 10
U20.DCF Base 2.1 6 of 10
U21.DCF Base 2.1 7 of 10
U22.DCF Base 2.1 8 of 10
U23.DCF Base 2.1 10 of 10
U24.DCF Maintanance 1 2.1 1 of 2
U25.DCF Base 2.1 9 of 10
U26.DCF Printer Pkg 2.1 3 of 3
U27.DCF Printer Pkg 2.1 2 of 3
U28.DCF Printer Pkg 2.1 1 of 3
U29.DCF 16 to unlimited 2.1 1 of 1
User License
U30.DCF 2 to 16 User 2.1 1 of 1

January 23rd, 2012, 12:20 PM
Wow, that's a lot of replies :)... BIOS doesn't seem to have any HDD auto-detect feature, but it allows me to enter the correct parameters of the drive (C/H/S=2099/16/63); moreover, DOS setup loaded straight from the FDD (no Ontrack) seems to "see" the full ~1GB capacity of the drive (does that mean that I have a pretty smart BIOS for a 386?).

The good news is that, if I boot straight from the FDD (no Ontrack), the AT&T UNIX setup eventually asks for the second floppy disk - I didn't prepare all of them so I'll not finish the setup process today, but I guess I'm on the right track :)...

The kit I'm using is either of these (I MD5ed the floppy images and they seem to be identical):

http://wdl2.winworldpc.com/Abandonware%20Operating%20Systems/PC/Unix%20Linux/AT%26T%20UNIX%20System%20V%20Release%204%20Version %202.1%20(3.5).7z

January 23rd, 2012, 02:53 PM
Thanks for posting the images. I've tried booting it in a virtual machine, but get a panic:

Panic: usrxmemflt: 000000000

So I'm assuming, it dosen't like the xmem of the virtual machine.

I'm using Sun's VirtualBox, so I'll try a couple of the other virtual machines and see if it'll load on them.

Such fun :)