PDA

View Full Version : SCSI hard drive not recognized, Mac IIfx



platatomi
January 23rd, 2012, 05:13 PM
Finally got a display adapter to work with my IIfx (it has been sitting unusable for months), all is well except the 250MB SCSI drive is not recognized by drive setup and will not boot. I have checked all connections and everything seems ok, physically. When the computer is powered on, the drive spins up for a few seconds, then down. After about 15 seconds, the Mac starts looking for a boot disk and the drive spins up again for a few seconds, then back down. Then I have no option but to boot a floppy. What could be the problem here? Is there any way to determine if the problem is the drive or motherboard before I buy a new drive? Thank you for input.

jrehmer
January 23rd, 2012, 05:15 PM
If you have an external enclosure you can put the drive in that. When powered on the drive should not spin down, so if you put it in an enclosure and the drive spins down after power on you'll know the drive is bad.

platatomi
January 23rd, 2012, 05:20 PM
So basically, it should spin down when mounted internally, but not spin down when in an enclosure? Or should it never spin down? (if working properly)

platatomi
January 23rd, 2012, 05:29 PM
I just noticed some very tiny jumpers on the bottom of the drive, what do these do and could their configuration be part of the problem?

jrehmer
January 23rd, 2012, 05:56 PM
The drive should not spin down once powered on whether in an enclosure or in the computer. The jumpers *most likely* relate to the SCSI ID, but you'd have to confirm by finding the information for that drive. You may also want to check out SCSI termination info for the IIfx here: http://support.apple.com/kb/TA42169

From what I understand the IIfx was a bit different in regards to internal termination than other Macintosh II's at the time.

platatomi
January 23rd, 2012, 07:02 PM
It looks like the termination is built into the drive, and the jumpers are set correctly (ID 0) so the last possibility is simple failure. I guess I will look for a replacement.

BuggZ
January 24th, 2012, 06:40 AM
Is the drive an Apple ROM SCSI drive or is it a replacement?

dorkbert
January 24th, 2012, 07:55 AM
Some drives have jumper to specify if the drive should spin up on power; they are geared toward array enclosures where all the drives spin up on power at the same time would overload the power supply. That said, if the drive spun up, it should not spin down unless otherwise told to (for power conservation) but it is unlikely IIfx would do this during boot time. From your description I think the drive is at fault. I don't think the Apple's custom firmware would have anything to do with it; not having Apple ROM on the drive would cause problem with formatting and partitioning later, but it should not be spinning down the drive. That said, some vendors (notably SUN and NetApp) have custom drive firmwares that does funky things such that only drives purchased from them would function with their boxes. You might want to check the drive you're using isn't one of those. One more thing... doesn't IIfx has some funky termination requirement?

Geo3
January 24th, 2012, 07:19 PM
If you could test the drive in external case with another machine. Or you may have format it with third party software like Sliverlining if it is not an Apple HD. Using the 3rd party software would let you use drives that did not have apple roms in them. Not like todays machines which do not seem to mind.

Take Care

platatomi
January 25th, 2012, 02:12 PM
It is Apple branded, manufactured by Quantum. The sticker reads:

"Apple Computer, Inc. Internal 3.5 inch HDD 250MB SCSI Firmware c1993", etc... "Quantum ProDrive LPS"

That should rule out compatibility problems. As for the jumpers, the only options to be set are the SCSI ID, that should be 0 I assume?

mactwiggy
January 25th, 2012, 02:39 PM
The IIfx had to have a special terminator on the end of the internal SCSI cable going into the drive. Mine wouldn't work without it.

dorkbert
January 25th, 2012, 02:47 PM
ID 0 should be fine. I am incline to think the drive is shot.

NeXT
January 25th, 2012, 03:33 PM
Quantum had problems with stictation and gummy bearings. I second dorkbert. Just go find another SCSI drive.

platatomi
January 25th, 2012, 04:20 PM
Just arranged to pick up an 80MB in friday, not as big as I wanted but it will work. (plan to install A/UX 2.0, may be tight fit)