PDA

View Full Version : Osborne Executive - Disk Read Errors, Disk Formatting Issues



bob_c
February 18th, 2012, 02:59 AM
I purchased this Osborne Executive back in 1983 (I think) which was my first real computer. About 3 months ago, I took the Executive out of the closet, thinking I should sell it on Ebay. Once I began working on it, I became obsessed with trying to get it to work properly. Now, I don't think I want to sell it, but I would like to getting it working again.

Initially, the Executive would not read any of the original diskettes so I set up an old PC with a 360K DD drive and began trying to create system disks. After many trials, I finally figured out how to use Dave Dunfield's IMD program. I believe that I now have the ability to create good disks from the image files. I have been successful in getting the Executive to boot (occasionally) from the disks. I am still getting quite a few CP/M BDOS errors when I try to boot the machine. However, I can eventually get it to boot with repeated tries. Also, I have had almost no success at formatting diskettes. I think I have only had ONE good format in all the time I have worked on the Executive!

I successfully loaded one of the Osborne diagnostic disks. The results of the tests show no other errors (ROM, RAM, Video, Keyboard, etc.) except Disk Drive errors -- nearly all of them are "read" errors. Last night I ran the diagnostic program again and on drive A I received 158 read errors and 1 write error; on drive B, I received 119 read errors and no write errors. All other tests completed successfully. If I try to run the diagnostic program on unformatted disks it goes into an endless loop (trying to format the disk) and I have to exit the program manually due to the number of errors!

I have tried two other disk drives that I purchased from Ebay a couple of months ago -- they give me the same type of errors, so I reinstalled the original disk drives back into the unit. From this, I am now starting to think that I may have a logic board problem, rather than a disk drive problem. I have cleaned and lubricated all of the drives numerous times and used two different cleaning disks to clean the read/write heads, and I have cleaned the r/w heads manually a couple of times. I have set the drive speed (on both drives) to the recommended 200 milliseconds and both drives seem to hold this speed. This seems to have helped get the system disks to boot. The executive is getting much better at reading the system disks (I don't have to restart/reset the machine as much to get it to boot), but it is not booting at a 100% rate yet. I don't think it is a cable issue, but I could be wrong, because I can get the machine to boot fairly consistently now. I think I have enough stuff to make a new cable if one of you think it is worthwhile to do so.

I have removed the FDC1793 from its socket (there was some oxidation on the pins). I removed the oxidation from the 1793's pins, reinserted the chip, but it did not seem to have made any difference. I can tell that the machine is doing a much better job at reading the system disks, but I still can't format any disks. I have tried several different "new" disks. I purchased some new "unopened" SSDD disks on Ebay (Maxell, Verbatim, Scotch, and Memorex) none of them seem to have made a difference. They will all produce disks that will read, but none of them can be formatted. As I stated earlier, I have only had one good format in all this time.

As a result, I am starting to think that I may have an issue with one of the chips on the main logic board. I have ordered, but not received yet, new chips to try "piggy backing" some of the chips in the FDC area. I hope to be able to start doing that next week.

I have a used Tektronix 2430a oscilloscope (but I don't yet know how to use it properly) I have just started going through the manuals, it seems to work fine -- but I have a long way to go before I can say I know how to use it proficiently. I have a huge learning opportunity here! :)

Do any of you have any suggestions/ideas on what might be the issue(s)? I would love to get this Executive working and would appreciate your input. I am nearly at the "end" or, perhaps, beyond my limited expertise. Could the FDC1793 be the issue? Would one of the other IC's in the FDC area on the Executive cause the type of errors (especially formatting) that I am getting? I have checked the voltages coming from the power supply to the disk drives and they all appear to be within specifications.

Thanks in advance for taking time to read this post and for any suggestions that you might have to correct the issues. I have looked through much of this site to see it anyone else has had this issue, but I didn't find anything. If you know of a thread that deals with these same issues, could you direct me to that thread?

Have a great day!

bob_c

Stone
February 18th, 2012, 03:52 AM
Have you tried using a head cleaning diskette and its accompanying fluid on the drive(s)? This can and has worked wonders numerous times.

bob_c
February 18th, 2012, 04:10 AM
Have you tried using a head cleaning diskette and its accompanying fluid on the drive(s)? This can and has worked wonders numerous times.

Stone:

I have used two different head cleaning diskettes (and fluid) and don't see any improvement. Also, I have manually cleaned the heads with a cotton swab and alcohol a couple of times with no noticeable improvement.

I have a couple of "extra" ALPS SS/DD drives and they show the same symptoms. I'm starting to think that I have another issue. I am investigating how to properly align the drives that I have, but I haven't figured out how to hook up the drives to my DOS machine -- the BIOS only permits a DS/DD 360K drive for Drive B -- so, I'm going to check to see if one of my old Heathkit DOS machines permits me to install a SS/DD drive in it. I would like to see if the drives exhibit the same behaviour if installed into a different machine.

Thanks!

Bob