PDA

View Full Version : Otrona Attache Troubleshooting



glitch
February 19th, 2012, 05:34 PM
I'm in the process of repairing an Otrona Attache I picked up last summer. When received, it needed some monitor adjustment but did initially display an error about wanting a boot disk. After monitor adjustment, I was attempting to get it into temrinal mode and it randomly failed to come up after a reboot.

I had some time today to try and troubleshoot it a bit. I replaced the boot ROM with a HALT ROM (0x76 at every location), and the processor does indeed halt on power-on and reset. I dumped the boot ROM and disassembled it...seems there's some amount of corruption in the ROM, as the routine it jumps to from 0x0000 never returns and disables interrupts.

Does anyone have an image of the Otrona ROM? I'm also looking for a copy/scan of the user's manual, as apparently the ROM has some diagnostics routines as well as bootstrap/terminal mode.

Sharkonwheels
April 10th, 2012, 11:33 AM
I'm in the process of repairing an Otrona Attache I picked up last summer. When received, it needed some monitor adjustment but did initially display an error about wanting a boot disk. After monitor adjustment, I was attempting to get it into temrinal mode and it randomly failed to come up after a reboot.

I had some time today to try and troubleshoot it a bit. I replaced the boot ROM with a HALT ROM (0x76 at every location), and the processor does indeed halt on power-on and reset. I dumped the boot ROM and disassembled it...seems there's some amount of corruption in the ROM, as the routine it jumps to from 0x0000 never returns and disables interrupts.

Does anyone have an image of the Otrona ROM? I'm also looking for a copy/scan of the user's manual, as apparently the ROM has some diagnostics routines as well as bootstrap/terminal mode.

Been out of here for a while, busy at work.

Got a Chevrolet Volt, and need to get the garage back so I can have a 240V charger installed.

If you're still in need, I have a box with (2) complete Attache's disassembled, minus 1 power supply.
If you want it, it's yours for the cost of shipping, + about $20 for box and materials. I have WAY more than that in the 2 machines.

The missing power supply went to either someone on here, or on a mailing list; can't remember.

VIDEO_DAD
December 22nd, 2012, 10:24 PM
Do you still have that box of Otrona parts?

Would you be able to send me a picture or two?



Been out of here for a while, busy at work.

Got a Chevrolet Volt, and need to get the garage back so I can have a 240V charger installed.

If you're still in need, I have a box with (2) complete Attache's disassembled, minus 1 power supply.
If you want it, it's yours for the cost of shipping, + about $20 for box and materials. I have WAY more than that in the 2 machines.

The missing power supply went to either someone on here, or on a mailing list; can't remember.

r_a_feldman
June 18th, 2013, 10:00 AM
I'm also looking for a copy/scan of the user's manual, as apparently the ROM has some diagnostics routines as well as bootstrap/terminal mode.

If you are still interested in a copy of the diagnostic test info, I can send you that. It is not in the User's manual, but in a separate Diagnostic/Repair booklet.

Bob

VIDEO_DAD
June 18th, 2013, 11:13 AM
I SURE WOULD LIKE TO GET A COPY OF THE DIAGNOSTIC TEST INFO ! ! ! My old Ham Radio (AA2LS) E-Mail is still active on yahoo (aa2ls@yahoo.com).

glitch
June 18th, 2013, 12:15 PM
BitSavers now has a pile of Attache documentation:

http://bitsavers.trailing-edge.com/pdf/otrona/