PDA

View Full Version : PS/2 Model 50 loosing config after installing new battery



Denniske1976
March 16th, 2012, 02:54 AM
Hi all,

Next problem with my stable of PS/2 computers, this time a Model 50 (not Z). Other than the harddisk being shot, also the FDD wasn't reading anything but it was just a matter of replacing the caps, so that works now. Harddisk has about 133K of bad clusters, Ref Disk says "Unable to read hard drive type from drive" during auto setup, so I guess I'm gonna have to find another one of those WD-325N drives (and i really want to, because this Model 50 is the quitest PS/2 I've ever heard, the drive is super quiet -except for the "meep meep" sound when active, and this model was also fitted with some kind of Temp Controlled Fan thingie).

Anyhoo, so I've come to terms with the fact that I'll have to go look for another WD-325N drive... other than that it's actually working now. Except for one weird thing:

I replaced the battery, ran auto configuration from the Ref Disk, after that even set the drive type manually to 30 (along with the date and time) and everything seemed working. Now the weird thing -> I can switch off the computer and after some time (let's say a day or maybe 8 - 10 hours) it will lose the configuration again. When I start the computer within 15 mins, 1 hour, 2 hours, it boots up without errors. When I switch it off now, and switch it back on tomorrow again, I get the 161 and 163 (or is it 162 and 163) messages again. Date is gone, harddrive won't be recognised (well, obviously it's shot as I wiped it and that gave me a "sector flagged bad - 0Ah" error), so I can start again with the Ref Disk, do the above things and it will run again for an hour or two (off that is).

Could this be because if the harddrive that's shot? Because the battery is a brand new one and I can read 6.53V right down to the little card connector where the battery holder connects to the mainboard (dunno where else to check for voltage, but if it's holding the config for 2 hours the BIOS chip is receiving voltage OK, I think).

I'd rather not bin this one... it's a really nice and clean machine, just wanted to get it up and running and try to find a new WD-325N drive for it (I know, gonna be a long wait and weirdly the WD-325Q from my Model 30 286 won't fit, I thought they were supposed to be the same drive? But the connector of my Model 50 is wider than the Model 30 286 one).

So uhm, anyone have an idea where this is coming from?

Stone
March 16th, 2012, 03:44 AM
It's not the HD. Why did you replace the battery? Was it losing it's config *before* you replaced the battery? The CMOS chip itself could be bad.

Denniske1976
March 16th, 2012, 04:20 AM
I've replaced the battery because the old one was dead (0.26V left) and it was giving me the 161/163 errors.

SO now I've ended up with the above "weirdness". Didn't touch the machine otherwise, so I haven't shorted anything out. Never seen a CMOS chip go bad before, is there any way to check it? Because with the Ref Disk I can do anything as if it was normal (except it can't read the HDD config from the harddrive), and it keeps config for about 2 hours or so. When I leave the computer powered on it also keeps config, so wouldn't it lose config again after a reboot, or short time powered off (if the chip couln't hold the data)??

Stone
March 16th, 2012, 04:57 AM
...and it keeps config for about 2 hours or so.I have boards with dead batteries that do exactly that.


When I leave the computer powered on it also keeps config, so wouldn't it lose config again after a reboot, or short time powered off (if the chip couln't hold the data)??This makes some sense but I'm not positive it's conclusive because of my statement above. I've always had success rebooting a machine with a dead battery. I'm not an expert on CMOS chips but I suspect there is some retention power within the chip, itself, even without a battery. What it does, however, is point back to the battery. Are you sure the battery is the correct voltage? Are you sure the polarity is correct?

Denniske1976
March 16th, 2012, 05:49 AM
Dunno if I understand correctly there, but the battery is the exact same one as I've put in my Model 70 without problems. One of those "camera" 6V types it is, it only fits in one way (and I checked + and - to make sure of course). Battery measures 6,53V or something like that, the old only had 0.26V.

I can of course boot, even without a battery installed. I just end up with the 161/163 (or 162/165 I can't really remember) errors. They're gone after I run auto configuration and reboot... only to reappear after the system's been off for a day. That's why I was thinking maybe the harddisk is causing this, since it can't determine the type of disk (it tries to read from the HDD somewhere).

Stone
March 16th, 2012, 06:18 AM
The CMOS can't determine anything. It's only function is to store the settings you give it. If the settings are incorrect for some reason, i.e., the configuration has changed from what it was told to remember or it has failed to remember something for some reason such as dead battery or corrupt CMOS chip, you'll get an error message.