PDA

View Full Version : Concord 286XT ROM / POST errors



SpidersWeb
March 31st, 2012, 02:42 PM
First off, this machine is an XT class machine but has a 286-8 CPU.
RTC is provided by an expansion card etc, HD floppies are through a BIOS expansion card, so is HD support.
It's all 8 bit slots, no 16 bit.

Now it was running fine yesterday, but last night I powered it on and got '007' that is all it says.
No beeps. Have removed all cards, tried a different mono card, no change.

This morning I turned it on and all I got was a blinking cursor.
After a few more power ups I got 007.

I switched memory chips around, from what I beleive is bank 3 to bank 0, and now I get 006. I tried replacing 'bit 6' and 'chip 6' but no change.
So I think it's either a memory error or a memory access problem.

The ROM is different also, and I've captured it. There are two files, both burned on 27128's HI and LO.
It's a PerformancePCs DiskCache BIOS. The motherboard has the SW1 from a PC-XT and responds accordingly.

I'm really really hoping that someone can find the time (I'll be trying to, but dunno how far I'll get) decompile the BIOS and answer a few questions:

- what does error 006 mean?
- what does error 007 mean?
- why does it only test the 512K of the 1024K installed onboard?
- how much memory is used by the DiskCache?
- is this a generic aftermarket BIOS, or is it original and does it do anything special to initialise the 286 bits?

8373

Side question - are 6256 and 41256 chips interchangable?
and is there another BIOS I could load in to this machine to test the memory and give me more useful output e.g. which chip is failing?

SpidersWeb
March 31st, 2012, 03:36 PM
Merged the files

I'm not sure if there was a bug in my utility or if I got the HIGH and LOW around the wrong way, but I had to specify the LOW file as the high file and vice versa to get output that makes sense.

8374

It appears this motherboard expects 2764 chips, hence the 3000 offset on each 27128. Correct me if I got that wrong.

Snippets from reading the ASCII that might be of interest:

- DiskAccelerator V3.16 WM (c) 1986 by Performance PC, Anaheim CA
- Copyright 1986 Ronald C Whites

- Warning: Disk cache is not the first interupt vectors.

- FATAL EMS error (so it supports EMS)

- Copyright Wavemate Inc 1986 Version 1.34 (matches the sticker on the ROM chips)

- 287 internal register error (so it's written for 286's)

- Drive A Failed (I've actually seen this one!)

- System board parity error (I've seen this one too, machine does it whenever I boot off a Datatech MFM card even though the ROM is OK)

- K RAM Failed at offset - (so it doesn't just halt at normal memory errors or cut the available RAM short - re: 512K mystery)


I'd like to be able to modify this ROM image after I've diagnosed it, bit more output would be nice.

Chuck(G)
March 31st, 2012, 04:42 PM
I don't think we'll find a PC with the Concord name on it, as the US Concord manufactured modems and such. However, did you look through the pictures of the 286 motherboards on TH99 (http://stason.org/TULARC/pc/motherboards/m286_i.html)? I'm thinking of one of the Hedaka or Next motherboards might be yours. There's also the Tandy 1000TX, but it's kind of a weird bird.

SpidersWeb
March 31st, 2012, 05:15 PM
It's made by Concord Computers New Zealand, and this is number 270 so I don't think there are a lot in existance (if this isn't the last).
It has a logo of rings, which I just assumed was the Concord NZ logo back then but you guys might recognise it as something else.

I went through those images, none of them match the motherboard.
Photos incoming, although what I need is to understand 006 007 and if it's memory related (makes sense) some way to test the DRAM via ROM.

Photos incoming.

Chuck(G)
March 31st, 2012, 05:24 PM
The photos of the motherboard might at least tell us if it's got a particular chipset (so make sure you get clear pictures of any SMT or PLCC chips in your photos so the numbers can be read).

If the programming's close enough to an XT, we might be able to split an XT POST diagnostic ROM and get some diagnostics run.

I assume that it takes an XT (not AT) keyboard.

SpidersWeb
March 31st, 2012, 05:29 PM
http://i83.photobucket.com/albums/j307/DrRabid/Vintage/concord_XT286.jpg

http://i83.photobucket.com/albums/j307/DrRabid/Vintage/concord_logo.jpg

http://i83.photobucket.com/albums/j307/DrRabid/Vintage/286XT_MB.jpg

The logo is the only real brand identifier, but I've always just thought it was a Concord board.

Edit: yes XT keyboard, I'll go upload the main chipset chip photo now.

SpidersWeb
March 31st, 2012, 05:37 PM
I noticed the serial number is 1491 (or similar) on a machine with no. 270, so could very likely be a generic part.

Chipset:
http://i83.photobucket.com/albums/j307/DrRabid/Vintage/286XT_chipset.jpg

Other main chips:
8237A (left of DRAM)
8259A 8255 8253 (next to keyboard connector)

Besides the CPU, everything else is just your usual DIP logic chips.
between the slots I have:

018-016 REV ___
80286 SYSTEM BOARD
(C) 1986

modem7
March 31st, 2012, 05:47 PM
The white logo on the motherboard (next to slots 4/5) suggests that the motherboard maker is Wave Mate.

SpidersWeb
March 31st, 2012, 05:52 PM
BIOS is labelled WaveMate as well, so that makes sense!
Cheers!

Now to head to google for some searching.

Edit: top right box http://books.google.co.nz/books?id=5z4EAAAAMBAJ&pg=RA1-PA73&lpg=RA1-PA73&dq=WaveMate+286&source=bl&ots=frpfGRzldT&sig=9oU34WoYH-GAesM1YUAQ7EYC-uc&hl=en&sa=X&ei=WLV3T_bsH6yXiAfdytzcBA&ved=0CCQQ6AEwATgK#v=onepage&q=WaveMate%20286&f=false

WaveMate 286E

If only I could find the POST error codes :/
or get a diags BIOS going.

Was running perfectly yesterday in it's case all screwed together.

Chuck(G)
March 31st, 2012, 06:50 PM
If you can burn your own EPROMs, we could try splitting an XT diagnostic POST board. Do you have a CGA or MDA for video for this system (my POST ROM needs one or the other)?

Most vintage people know WM for their earlier Z80 systems, particularly the "Bullet" (https://en.wikipedia.org/wiki/WaveMate_Bullet).

A peek at your BIOS shows that initial diagnostics load AL with an error code and jump to F000:F986, which initializes the (monochrome) display adapter, plunks the error code on the screen and hangs.

Error code 006 is generated from F000:E1CE, where it appears to be checking RAM.

SpidersWeb
March 31st, 2012, 07:52 PM
MDA right now.

And thanks heaps for having a peak, it's nice to have that confirmed. Before 006 I got 007 though. 006 was after I moved memory around :/
So now I wonder what 007 was!

Looking at my 5160 board in front of me, the top bank is Bank 0 (its not marked on the XT286). So I'll try to replace the chips in the top most bank - I have both tested and some NOS from ebay. If I'm patient enough, I can also load them in to my Everex on the 386 one by one to find the bad ones.

Did you decompile the BIOS or were you reading it as hex?

Edit: and yes I have a ROM burner and a pile of working EPROMs, 2764 and lots of 27256 but only a single 27128. The chips that image was pulled from were 27128's but they were offset 1800 each (3000 when merged). I have a tool to split a ROM image, just not sure what offsets to use and what chip size.

Chuck(G)
March 31st, 2012, 09:03 PM
I just loaded the binary into DEBUG. Load it at 8000h and start tracing the flow starting at FFF0.

Take a look at the code around F000:E1DF, that's where your error 7 comes from. It appears to be yet another memory error.

Note that the code at offset 3000 in your ROM isn't the BIOS per se--it's the BIOS extension for the hard drives. Apparently, it also uses memory above 640K for disk cache.

At any rate, you can use a pair of 64Kb/8KB (2764) EPROMs. Split the POST ROM into odd/even bytes and stick each 4K piece at the top of each 2764 EPROM.

SpidersWeb
April 1st, 2012, 04:30 AM
Excellent, thanks.

I've split it and have the two images.
When you say the top, do you mean the last 4K or the first 4K?

Would be doing this now, but my ROM burner is having trouble accurately writing to my 2764s.
It gets further the higher I raise Vpp, but already at 14V and it finds an error within the first few lines of hex. Tried with 4 chips, 2764x3 and 27128. Last ROM I burned no problem at 12.5V but it was a 27C512. Will do some googling and sort that out. It's a cheap chinese Willem/PCB3 setup.

SpidersWeb
April 1st, 2012, 05:10 AM
Got the 2764's to write correctly.
I tried putting the two 4K slices in the first 4K of each chip, machine didn't respond.

Machine had no response to the chips, I also tried swapping them over in case my program had HI/LO mixed up, but nothing at all.

Tried again with 256 chips using an offset of 5800.
4000 being the start point of half a 256 when used in a 128 slot - correct? Plus 1800 offset the original chips were at - correct?
I'm really not sure if I did that calculation right.

Anywho, no response.

Chuck(G)
April 1st, 2012, 07:40 AM
Okay, here's two 2764 images. Let's give them a try--you should at least get a beep. If not, it's back to square one, I guess.

SpidersWeb
April 1st, 2012, 11:40 AM
Ah thanks for that, used yours to compare to mine and I found the difference. One of my files was identical, but the other was quite different - need to find a better set of tools. 2764's are erased, so will burn them with the good images soon.

SpidersWeb
April 1st, 2012, 04:31 PM
Ok now it succesfully starts up the diagnostics :)

By removing chips and checking for messages, I've found bank 0, and bit 0 - where the software claims the problem is.
But it doesn't matter what chip I put in that socket the error wont change. I'll need to keep trying but tiny bit worried it's a board problem. Will see.

Besides the memory everything else passes though.

Chuck(G)
April 1st, 2012, 04:39 PM
Nice to hear that you've had a productive afternoon! :)

SpidersWeb
April 1st, 2012, 06:34 PM
Have confirmed that socket is faulty - or rather something leading up to it.
Switched in at least 5 good chips and retested them after placing them in (just to check I wasn't damaging them).

Can't see anything like a dry joint or burnt component :/

SpidersWeb
April 4th, 2012, 02:55 AM
So I'd put this board away, and threw the ROM's back in the eraser.

Then I think, I'll do some multimeter work. All the common connections were fine, so I followed the unique ones. The first one I followed lead me straight to a solder join with no solder on it!
No wonder it wasn't working. I didn't notice it before. Soldering iron is heating up now, will reburn the diags roms :/

Edit: resoldered said joint, no change. Have been checking restiances and following traces. So far I know all the address lines are OK, suspecting Data In or Data Out but will take a while because each chip it passes through I need to lookup :/