PDA

View Full Version : Hard disk problem Philips PCD 200



RuudB
June 17th, 2012, 10:24 AM
Hallo allemaal,

I own a Philips PCD 200, a 12 MHz 80286. My first question: does somebody have by chance the (technical) manual of this machine? It has several jumpers inside And I haven't any idea what they are for :(

The machine only has a 40 MB HDD so I thought it was time for an upgrade. Having several 40 GB drives laying around doing nothing, the choice was easy. I already used them in some 386 and 486 machines W/O any problem, even hooked one up on a XT-IDE interface! But first I copied the data of the 40 MB drive to another PC.
The first problem: the PCD only supports HDDs up somewhere in the 100 MBs and hasn't an user editable type. In 1988 I faced the same problem and altered the HDD table so the computer could use the 240 MB HDD. So I did the same and created a parameter with 1023 tracks, 15 heads and 63 heads. With 'only' 472 MB I then found out it should have been 1024 tracks and 16 heads. I also realized that I could have 16384 tracks but I can live with a gain of 1000% :)
With FDISK I made a 21 MB C-drive and a 451 MB D-drive. I then activated the C-drive. Next I formatted both partitions, using the /S option for the C-drive (DOS 6.22 NL). I then copied the data from the other PC to the D-drive. Only then I rebooted the PC and..... nothing. I booted from floppy and DIR worked fine but copying data from the D-drive or running PCTOOLS from the D-drive ended up in a read error. Trying to run COMMAND.COM on the C-drive resulted in a read error as well. What can be the reason (except for a brooken HDD) ???

Writing this message I realized I should have tested booting from the C-drive first after having formatted it. And that's what I'm going to do next after finishing this message.

Kind regards, Ruud Baltissen
www.Baltissen.org

Chuck(G)
June 17th, 2012, 11:05 AM
The first thing I'd do is go back to the original BIOS and table. Add your larger drive and do the same thing that you've just done, but after the FORMAT /S, copy some files over from the disk you booted from and make sure that you can execute them from the C: drive.

Then, I'd go with a DDO instead of modifying your drive table. While you may be able to go to 16383 cylinders, the BIOS probably isn't set up to support the extended BIOS calls.

If you get disk errors, be sure to note the exact message. Some errors, such as "General Failure" are catchalls for things that may have nothing at all to do with your drive's real operation.

RuudB
June 18th, 2012, 11:44 AM
Hallo Chuck,

I connected a ST5850A, a Seagate 850 MB, and that one worked fine. The 40 GB also was a Seagate so I connected a WD one and later an IBM one; all showed the same problem. Whatever the reason may be, I am also happy with the ST5850A. Case closed.

Kind regards, Ruud Baltissen
www.Baltissen.org