PDA

View Full Version : Sound Blaster 2.0 MIDI does not work in IBM 5150 PC



IBM
June 27th, 2012, 06:24 AM
Hello everyone. I have an issue and was hoping I could get some feedback. I have Sound Blaster 2.0 CT1350B (DSP v2.01) and it I cannot get the MIDI to work properly in my IBM 5150.

The digital sound works fine, but FM doesn't give so much as a peep. The Sound Blaster 2.0 test program detects the proper I/O 220, IRQ 7 & and DMA 1. The "Voice Output" digital audio test works, but "FM Music Output" MIDI test does not. I have tried numerous games and FM does not work in any of them while digital does. Trixter's 8088 Corruption works (it uses the sound card for timing, I believe, but has no sound anyway). I have tested this card in a few newer Pentium class computers and both the digital sound and MIDI worked fine, so I know it isn't a bad card.

It is rather irritating that the Sound Blaster 2.0 setup disks are all high density, thus requiring me to laplink them to my 5150's hard drive, but they aren't really of that much help anyway.

As for the hardware, I have an 2nd model IBM 5150. I have the standard IBM 360k floppy controller with two floppy drives, a Western Digital "Super BIOS" hard disk controller with a single 20 MB MFM hard drive, an Intel Aboveboard EMS card with one parallel port and one serial port, and an ATI VGA Wonder. It has a V20 CPU and 8087 Co-Pro.

My Sound Blaster 2.0 CT1350B (DSP v2.01) is configured to the default I/O 220, IRQ 7, DMA 1.
The environmental variables are properly set in AUTOEXEC.BAT as "SET BLASTER=A220 I7 D1 T3".

MSD shows my IRQ usage as:

IRQ
0............Timer...................Detected..... ..........BIOS Controlled
1............Keyboard..............Detected....... ........BIOS Controlled
2............I/O Channel...........Detected...............BIOS Controlled
3............COM2/4................Not Used...............BIOS Controlled
4............COM1/3................Detected;COM1......BIOS Controlled
5............Fixed Disk.............Detected...............Unknown (OPTION ROM)
6............Floppy Disk...........Detected...............BIOS Controlled
7............LPT1....................Detected..... .........System Area

Most games don't use an IRQ for MIDI anyway do they, or is there a problem/conflict with LPT1? I do not have a device attached to it. The problem is with my I/O address or DMA then, perhaps? How can that be? I can't find any conflicts. What other issues could it be? What else should I check? Pulling cards does not seem to solve the problem either. Plenty of other people have been able to get Sound Blaster 2.0s to work in PC/XTs. I have dealt with ISA resource conflicts many times before but I am stumped.

Thanks for any help or idea you can provide.

-Isaac

Great Hierophant
June 27th, 2012, 07:12 AM
FM is NOT MIDI. MIDI data comes out of the gameport and goes to another device which makes sound, FM comes from those Yamaha chips and you hear that from the the audio output of the card. FM uses I/O 388-389 or 228-229 and nothing else, no IRQs, no DMAs. It is unlikely that any of the other cards would have an I/O conflict, but its not impossible.

Do you perhaps have a C/MS upgrade on the card or 3 empty sockets? Does your card have a Rev. 3 or Rev. 4 silkscreened on its PCB?

The FM chip is the Yamaha YM3812 and there is a special DAC chip called the Y3014 present, and are often socketed on these cards. Pulling them up and resocketing them may help, but be careful that you don't break any pins.

Perhaps your motherboard has a subtle fault in that it is not sending a proper OSC signal, on the ISA bus, to the card. The FM chip on these cards require a proper OSC signal so they can derive their frequency timings.

Trixter's 8088 Corruption also uses the digital voice of the SB 2.0 for audio playback, it does not use FM.

IBM
June 27th, 2012, 07:51 AM
Ok, my mistake. I used "MIDI" to mean FM. The card has Creative C/MS upgrade chips, yes. I think I tried removing them but it didn't help. Would this matter? There is no revision silkscreened anywhere on the card that I can see. I've reseated the DAC to no avail, and as I said, the card worked on other computers. I have another 5150 motherboard and I don't think it worked on it either, but I'll have to try it again to be certain. A problem with the signal from the 14.138 MHz oscillator on th ISA bus ? I could deal with that if it was indeed the issue. Well if FM doesn't use IRQs or DMA then, as you say, it isn't likely to be a resource conflict. Thanks for the ideas but I'm still stumped!

-Isaac

Thanks.

Great Hierophant
June 27th, 2012, 08:16 AM
It sounds like you have a rev. 0 SB 2.0, and they are finicky beasts. There have been very similar problems with the C/MS upgrade and the non-Creative GAL chip. Even if you remove all the chips, you should still put a jumper on the CMS_OFF pins. Maybe the jumper itself will do.

If you have another Sound Blaster without a 14MHz Oscillator on its PCB, then you may be able to narrow down the problems to your card or motherboard. I think it is extremely unlikely that the motherboard's OSC would be the issue, as it obviously works. If you had a CGA card and a TV with composite video or an RF Adapter, you could tell whether the card is getting a signal.

IBM
June 27th, 2012, 08:45 AM
I do have an IBM CGA card and it works just fine on this motherboard (and I have used it with composite video), so maybe it is something with the card.

Great Hierophant
June 27th, 2012, 11:51 AM
Definitely not an OSC problem, or you would get no color in your composite video, and maybe no video at all. Either there is the issue with the C/MS chip or it may be a weird incompatibility with the IBM PC 5150, which maybe explains the need for revisions.

IBM
June 28th, 2012, 03:23 AM
Well, I took the C/MS chips out and lo and behold, it actually worked. But now it seems like my whole system is unstable. Everything keeps locking up and programs hang with strange errors. Could be unrelated. So I guess I can't have C/MS and FM.

Great Hierophant
June 28th, 2012, 04:43 AM
Did you put a jumper on the CMS_OFF pins?

IBM
June 28th, 2012, 06:27 PM
Yes, I did. That and I pulled the chips from the board. Seems like the system hangs too much. Like if I go and try to run scandisk, it will had 90% of the way thru a surface scan. Or if I'm running a word processor, it hangs if I go to save.

Trixter
June 28th, 2012, 08:52 PM
You've got bigger problems, it sounds. I would remove every card from the system and then reseat it, as a starting point. Run a memory test with CheckIt or similar.

IBM
June 29th, 2012, 04:04 AM
I don't get any memory errors and I've used a few programs to check for problems. When I use Spinrite to check the hard drive it hangs wehn doing the startup memory check. I'm not sure what the problem is. This system used to work fine before FM worked right.

mikey99
June 29th, 2012, 07:14 AM
Did you try setting the SB card for different I/O and IRQ settings ?
Maybe there is a conflict now that FM is working correctly.....

Trixter
June 29th, 2012, 08:20 AM
If you remove the Sound Blaster entirely, does everything run properly?

BTW, Spinrite 5.0 and later has a bug in the memory tests that cause it to freeze up on some DOS versions, so that's not a good test.

IBM
June 30th, 2012, 10:21 PM
My DOS version is IBM DOS 3.1. Spinrite 5.0 never perviously had this error and I'd used it many times. It seems like it's a hard drive problem. When I just boot from floppy the issue is gone. If I take the sound card out it also seems to work. I used a program called HD Test to scan the hard drive. A great program, but for some reason it seems to think the interleave on my drive is 4:1 when it is actually 3:1. Even if I try to change the interleave via HD Test it still shows as 4:1. Other programs like Spinrite and the hard drive BIOS formatter report the hard drive as 3:1 also, yet the preformance of the drive is only about 112 Kb/s when previously it was about 140 Kb/s. So maybe the interleave really is set to 4:1? Not sure how this is relavant to the sound card issue though.