PDA

View Full Version : Compute Magizine SOFTWARE



cavebear53
July 12th, 2012, 11:07 AM
Has any of you typed in the chess program from the December 1984 Issue of Compute Magizine.
It has a bug in it that will not let you place black pieces on the board, Being the only way you have of continuing a game I would like to kill that BUG. Has anyone found that BUG.

Ron

MikeS
July 12th, 2012, 11:45 AM
Has any of you typed in the chess program from the December 1984 Issue of Compute Magizine.
It has a bug in it that will not let you place white pieces on the board, Being the only way you have of continuing a game I would like to kill that BUG. Has anyone found that BUG.

RonWhich version? What computer?

Did you type it in, or how did you get it into the computer?

Do you have any way to upload your program?

Many of the disks are on line, but I think they're only for Commodore; anyone have any info?

barythrin
July 12th, 2012, 12:09 PM
Looks like the magazine scan and code are here (http://archive.org/stream/1984-12-compute-magazine/Compute_Issue_055_1984_Dec#page/n89/mode/2up) although it does have several versions depending on the system.

krebizfan
July 12th, 2012, 12:46 PM
Have you checked the following issues in case there was a mistake in the program listing in the actual magazine? It happened a lot.

The OCR used on the old Compute issues often has mistakes. If you can find a second site with same issues that have code but done by a different scanner, check for any differences between the versions of the code.

cavebear53
July 14th, 2012, 03:54 AM
Thanks for the replys. Its the Atari version, I typed it in and used computes proofreader program to check it no errors in my typing. I checked all issues after this one to see if there was a bug report but found nothing. I also typed in the IBM version for my compaq portable it had a bug in it too if you look at the picture of the screen shot in the listing you will see the board squares set up with the wrong colors it has a dark square on the lower right insted of white I fixed that error, but cant find the error in the atari version

Ron