PDA

View Full Version : A little help with my new AS/400 please :D



Owl
August 17th, 2012, 06:33 AM
So I recently picked up an IBM AS/400 9402-400 system. It's a beast of a machine but surprisingly doesn't use as much power or produce as much noise as I thought it would, so I'm happy! It seems to have 4 hard drives, 2 gigs each in size. Not sure what type of RAID setup it's running.

It is currently running V4R3 and I was extremely fortunate in that the DST password was reset back to the default of QSECOFR/QSECOFR, allowing me to reset the QSECOFR user's password and get into the system.

It does appear to have Client Access/400 and the ability to hook up to an ethernet or token-ring network. The card labelled "2617" is a card for an old 10Base5 network (I was looking for an ethernet port :oops:) - just need to get a transceiver and I'm good to go.

My question is - can someone help me figure out what programs are loaded onto the system? It seems that some of the libraries may have been deleted. I was trying to launch the System/36 RPG programming tool but it reports that "Command CRTS36RPG in library *LIBL not found." In fact, a lot of programs aren't launching and I just hope the libraries haven't been deleted - such as OfficeVision for OS/400. Is it possible I don't have the correct library loaded?

Thanks!

Jimmy
August 17th, 2012, 08:24 AM
Owl:

I am trying to remember back but "WRKLICINF Work with License Information", should give you what you want to know.

Also "WRKCMD " followed by a few characters and an astrick "*" will display the commands, example "WRKCMD DSP*"

Owl
August 17th, 2012, 09:29 AM
Thanks Jimmy, those commands worked.

Ah, seems that "App Dev Toolset for AS/400" is installed - I don't think that has to do with RPG though, unfortunately.

It also appears that I don't have OfficeVision - rather Client Access 400 simply refers to it. Anybody just happen to have OfficeVision? I'd be willing to pay up for it.

Thanks again :)

Jimmy
August 17th, 2012, 09:44 AM
Owl:

Try typing "STRPDM" from the command line that should start program developer manager, if it is installed.

Jimmy

g4ugm
August 17th, 2012, 02:09 PM
Well looking at the port its actually an AUI port, which I thought was "real ethernet" as its designed to be connected to a shared media. You can get transeivers for 10BaseT and 10Base2 as well:-

http://www.ebay.com/itm/ETHERNET-AUI-TRANSCEIVER-10BaseT-RJ45-210TS-Cisco-2501-/360477431596?pt=LH_DefaultDomain_0&hash=item53ee21172c

http://www.ebay.com/itm/CentreCOM-MX10S-AUI-DB-15-to-BNC-10BaseT-w-free-Balun-/350586562939?pt=US_Networking_Splitters_Couplers_A dapters&hash=item51a096697b

SteveH
August 18th, 2012, 09:53 AM
Try the command "Go LICPGM". It'll take you to a menu where you can see what is installed. Also, take a look at the IBM redbook for more information about the IBM eServer AS/400e RISC System Builder Version 3 Release 6 - Version 5 Release 2 (http://www.redbooks.ibm.com/abstracts/redp0342.html?Open).

Owl
August 18th, 2012, 01:23 PM
Thanks for the help g4ugm and SteveH. I'm just trying to figure something out - I heard that the Client Access/400 PC application is stored on the server itself - is this true? I tried looking it up via FTP but the current library is "QGPL" (changing the system's current library does nothing) and nothing in there looks like what I'm looking for. But, of course, I'm looking this up through the AS/400 itself so it may not be that obvious.

SteveH
August 18th, 2012, 03:38 PM
Yes, you should find the CA/400 software on the AS/400 (assuming it has been installed). I'm currently looking at a later box running a more recent version of the OS (v6r1), so the folder structure will differ somewhat for you. If you are going to access the software via FTP, once you've connected issue the command "QUOTE SITE NAMEFMT 1", or just something live "CD /" so that you are looking at the IFS instead of the native libraries. For more details on the NAMEFMT command see Using the FTP Subcommand: NAMEFMT (http://www-01.ibm.com/support/docview.wss?uid=nas1458ff0ae0a9a2ea986256a340061c5 14). Anyway, look for a SETUP.EXE program in a folder something like this "\qibm\proddata\access\windows\image32". Also, assuming the QIBM IFS folder is shared out, you should be able to access the folder from windows explorer; try something like this "\\192.168.139.130\qibm\proddata\access\windows\ima ge32", obviously specifying your IP address and the correct folder path for your v4r3 machine.

Hope that helps.

Owl
August 18th, 2012, 05:17 PM
Thanks a lot for taking the time to check it out for me. It seems the "access" folder doesn't exist under that directory, at least on my system.

Here's the directory listing for \qibm\proddata:

HTTPSVR/
SERVEXP/
HTTP/
OS400/
GUIPLUGIN/
IBMWEBAS/

I can tell for a fact that Client Access is installed - it appears in "Work with License Information" and all of the menus to access all the options are there and they all work (not reporting any missing libraries like the others) - however, I cannot actually start the server because it reports "Host server daemon jobs unable to communicate using IPX." I heard this was a common problem from the IBM website but haven't done any further research.

9993

Because I don't have the AUI transceiver yet I can't view the file structure on Windows so the terminal will have to do.
The only thing I can think of at the moment is that either the Client Access Windows software never came loaded on the system (perhaps on floppy disks), someone deleted it or it was located or moved to some obscure folder.

Is it possible to search for files on the AS/400 itself rather than having to hook it up to a Windows system (like setup.exe)?

Here's my discovery: there is a folder under "Client Access - Work with Folders" named "QIWSFLR" which seems to correspond to PC Access (or Client Access) - just it's for DOS (at least I think it is). I heard they only came on floppy for the Windows versions.

9992

I suppose the best thing to do is try to access that folder over ethernet - how can I transfer that folder into a directory accessible through FTP?

Owl
August 18th, 2012, 06:26 PM
Did some digging in the Licensed Programs menu and found out that the system isn't licensed for Client Access for Windows 95/NT. It is, however licensed for Client Access for Windows 3.1. I'm going to need the 95/NT version so it's not much use to me, unfortunately.

I also found that in the FTP program, /QDLS contains the client access programs, so if I need to get to them I won't need to copy them over. :)

I may have access to another AS/400 where, if it is present, I could try saving the program to a tape and try to load it on this one - not sure if that would work or not.

What's the difference between IBM Personal Communications and Client Access, by the way, if I had to go that route? At this point that's probably the only way to go unless someone has the NT client or the disks for it.

SteveH
August 19th, 2012, 02:36 PM
I just powered up my old AS400 9401-150 running OS/400 v4r5 to see where the Client Access software is located. Under the folder \QIBM\ProdData\CA400\Express there are the install, language and service pack folders:

Install/Image
MRI2924
Service/Image
Service/JRE

On my box I can run the CA/400 setup program via windows explorer from \\192.168.1.10\qibm\ProdData\CA400\Express\Install \Image.

I have got somewhere a CA/400 install CD. I've also got a simple TELNET program that I often use to connect to different AS/400 and iSeries boxes. PM me your email address if you'd like a copy, it is just a single executable and it works fine under Win 2k, Xp, Vista, and 7.

Also, your error "Host server daemon jobs unable to communicate using IPX." is probably just a red herring. You don't need IPX up for Client Access.

Steve

SteveH
August 19th, 2012, 02:43 PM
Forgot to mention, when you get around to setting up your network connection, issue the command "GO TCPADM" to get to the TCP/IP administration menu.

g4ugm
August 20th, 2012, 02:26 PM
What's the difference between IBM Personal Communications and Client Access, by the way, if I had to go that route? At this point that's probably the only way to go unless someone has the NT client or the disks for it.

As far as I know Personal Communications is a terminal emulator (I have it but only use the 3270 emulator). If you don't have a twinax card you wtill need the AUI transeiver so you can connect using TN5250. Client Access allows the PC to use the AS/400 disks as PC disks.

http://www.itjungle.com/tfh/tfh110402-story04.html

seems to have some info...

Owl
August 20th, 2012, 07:31 PM
I just bought myself an AUI transceiver on eBay so hopefully it'll arrive in a week or so and I can try out the Client Access functions (thanks to Steve) :D

Owl
August 26th, 2012, 06:02 AM
I hate to be asking again, does anybody have the RPG compiler by any chance? I wrote a program and submitted it to compile but saw nothing in the list. I then changed "compile in batch" to "no" and it says that "Command CRTRPGPGM in library *LIBL not found"